I'm trying to get Java 6 update 21 to work by installing to a Q: drive location as various recipies suggest is possible. At the moment I am launching the "Java(TM) Platform SE binary" via the sfttray /EXE cmd.exe /LAUNCH approach. I'm logged on as a local admin.

This works fine if the sfttray has been "Run As Administrator". I'm able to go to the Q: drive location and run the javacpl.exe no problems. But if its run via a normal cmd prompt, I get a "Network Error : Windows Cannot Access ...." error. It affects some of the exes in this directory, but javaws.exe has no problems for instance.

If I perform the same installation to a local drive/partition Q: drive rather than the App-V mount point, I get a normal UAC prompt for elevation. Any ideas how I tell UAC that the Q: drive is actually not a network drive and prompt the user for elevated rights? I've tried setting XP SP3 compatibility for the exe but still no joy.

Any ideas? If I can get UAC to correct detect that it's not on a network drive that would be a great start. Otherwise, how can I tell it to ignore this file? I'd rather not fall back to a VFS install unless I really have to.

0 Comments   [ - ] Hide Comments


Please log in to comment

Answer this question or Comment on this question for clarity


try to remove the "Enforce Security Descriptors" within the Sequncer tab of Deployment.
Answered 04/02/2012 by: vkleiner
Orange Senior Belt

  • Hi,
    That's in place already. A normal (non admin) account doesn't have the problem; it's only if they are an admin. I know UAC can detect if an app wants to write to HKLM or Program Files, but why not just raise the UAC prompt?
  • create environment variable _Compat_Layer=RUNASINVOKER
Please log in to comment