So I build XP Images for my company and now and then I see the "Language Toolbar" open on the toolbar.

I'm aware of right clicking into the settings, going to the advanced tab and checking "Turn off adfanced text services". But it doesn't seem to always stay off!? Anyone know a way in the registry under HKLM/? I just found this site the other day and plan to spend a lot of time in the forums helping others out with my success as I have a VERY respectable image that works on over 15 different pieces of hardware from Desktops/Laptops Dell/Compaq/HP and even Gateways hehe.

I do this on the "Local Admin" account and build the image with sysprep/ghost. But when create a local user account and log in with it under "Text Services and Input Languages" it's turned back on for that new user. Hence why I'm looking for a registry change to apply to HKLM

FYI I've done a lot of Googling and haven't found anything yet.
0 Comments   [ + ] Show Comments


Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.


Hi grimmda,

The fact that it is turned on for every new user definitly means you're not looking for a key in HKLM, it will be in HKCU.

Make registry dumps of HKCU before and after turning off the langbar, compare, and you will have found the key(s).

Btw, it will probably have to do with ctfmon.exe. If you google on that, you will surely get some hits.

Answered 08/29/2005 by: Ilikebananas
Purple Belt

Please log in to comment
Well I've found where changing it in HKCU takes place, but when a new user logs in, it sometimes gets turned back on. I'm just going to deal with it in the mean time as it's a low priority problem.
Answered 09/02/2005 by: grimmda
Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity