I've made some changes to my product, not installation related at all, just changed which libs do I use for non installation related issues and suddenly I have this weird msg popping up whenever I try to install.
"The system administrator has set policies to prevent this installation"

Previous versions/builds (even with the same version number) install fine.
This is the output of the verbose logging:

MSI (c) (C0:90) [16:15:32:367]: Product not registered: beginning first-time install
MSI (c) (C0:90) [16:15:32:367]: PROPERTY CHANGE: Adding ProductState property. Its value is '-2'.
MSI (c) (C0:90) [16:15:32:367]: Note: 1: 33 2: 0
This installation is forbidden by system policy. Contact your system administrator.

For a normal installation the ProductState property value is -1 and than things go on just fine...

Any ideas ?

--
Thank you!!!
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Yes Thankyou

HKLM\Software\Policies\Microsoft\Windows\Installer

DisableMSI Type = 0 ( enable MSI )

This was originally set to 1 (disable MSI )

Also try this key ...

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Group Policy Objects\{A541BD3D-1A70-4D7B-BC99-CF1ADFC0DE9F}Machine\Software\Policies\Microsoft\Windows\Safer

Change this value to 1 - to disable the Administrator only install a.k.a
anyone can do it.

If all fails .... The system Administrator has set policies
to prevent this installation,,,,, ensure you are logged on as Administrator
or any Administrative User privileges or Right click setup.exe and Run As Administrator
Answered 11/22/2011 by: levene
Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity