We have a report that shows us software installed over the last 24 hours (see below).  What is strange is that we always seem to catch "TechTool Deluxe" being detected and then un-detected from machines; sometimes the same machine and many times over (see below).

 

Has anyone experienced this or would understand why it is happening?  My only speculation is that the software is being detected on a CDROM drive that is spinning up and down.  Would that cuase the software to be detected and then not?

 

_____________________________________


TechTool Deluxe (3.1.3)
 2014-01-08 07:42:19 - Detected
   TechTool Deluxe (3.1.3) 2014-01-08 07:42:19 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-08 05:42:10 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-08 03:42:14 - Detected
   TechTool Deluxe (3.1.3) 2014-01-08 03:42:14 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-08 01:42:21 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-07 23:42:08 - Detected
   TechTool Deluxe (3.1.3) 2014-01-07 23:42:08 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-07 21:42:15 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-07 19:42:17 - Detected
   TechTool Deluxe (3.1.3) 2014-01-07 19:42:17 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-07 17:42:06 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-07 15:42:07 - Detected
   TechTool Deluxe (3.1.3) 2014-01-07 15:42:07 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-07 13:42:01 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-07 11:41:51 - Detected
   TechTool Deluxe (3.1.3) 2014-01-07 11:41:51 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-07 09:42:05 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-07 07:41:54 - Detected
   TechTool Deluxe (3.1.3) 2014-01-07 07:41:54 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-07 05:41:45 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-07 03:41:42 - Detected
   TechTool Deluxe (3.1.3) 2014-01-07 03:41:42 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-07 01:42:06 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-06 23:41:38 - Detected
   TechTool Deluxe (3.1.3) 2014-01-06 23:41:38 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-06 21:41:41 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-06 19:41:23 - Detected
   TechTool Deluxe (3.1.3) 2014-01-06 19:41:23 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-06 17:41:42 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-06 15:41:31 - Detected
   TechTool Deluxe (3.1.3) 2014-01-06 15:41:31 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-06 13:41:27 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-06 11:41:27 - Detected
   TechTool Deluxe (3.1.3) 2014-01-06 11:41:27 - No longer detected
   Firefox (26.0) 2014-01-06 09:41:22 - Detected
   TechTool Deluxe (3.1.3) 2014-01-06 09:41:22 - No longer detected
   Firefox (25.0.1) 2014-01-06 09:41:22 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-06 07:41:23 - Detected
   TechTool Deluxe (3.1.3) 2014-01-06 07:41:23 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-06 05:41:14 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-06 03:41:04 - Detected
   TechTool Deluxe (3.1.3) 2014-01-06 03:41:04 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-06 01:41:06 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-05 23:40:45 - Detected
   TechTool Deluxe (3.1.3) 2014-01-05 23:40:45 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-05 21:40:39 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-05 19:40:38 - Detected
   TechTool Deluxe (3.1.3) 2014-01-05 19:40:38 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-05 17:40:28 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-05 15:40:26 - Detected
   TechTool Deluxe (3.1.3) 2014-01-05 15:40:26 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-05 13:40:24 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-05 11:40:03 - Detected
   TechTool Deluxe (3.1.3) 2014-01-05 11:40:03 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-05 09:39:58 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-05 07:40:02 - Detected
   TechTool Deluxe (3.1.3) 2014-01-05 07:40:02 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-05 05:39:51 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-05 03:40:02 - Detected
   TechTool Deluxe (3.1.3) 2014-01-05 03:40:02 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-05 01:40:15 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-04 23:39:43 - Detected
   TechTool Deluxe (3.1.3) 2014-01-04 23:39:43 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-04 21:39:43 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-04 19:39:39 - Detected
   TechTool Deluxe (3.1.3) 2014-01-04 19:39:39 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-04 17:39:32 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-04 15:39:43 - Detected
   TechTool Deluxe (3.1.3) 2014-01-04 15:39:43 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-04 13:39:35 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-04 11:39:33 - Detected
   TechTool Deluxe (3.1.3) 2014-01-04 11:39:33 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-04 09:39:39 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-04 07:39:30 - Detected
   TechTool Deluxe (3.1.3) 2014-01-04 07:39:30 - No longer detected
   TechTool Deluxe (3.1.3) 2014-01-04 05:39:37 - No longer detected

 

__________________________________________

SELECT DISTINCT NAME, VALUE1 AS 'Software Display Name', VALUE2 AS 'Software Version'

FROM ASSET_HISTORY A

WHERE CHANGE_TYPE = 'DETECTED'

AND FIELD_NAME = 'SOFTWARE'

AND TIME > DATE_SUB(NOW(), INTERVAL 1 DAY)

ORDER BY NAME, VALUE1

1 Comment   [ + ] Show Comment

Comments

  • just checked the software inventory item, and the application is found in /Applications/TechTool Deluxe.app
Please log in to comment

Answers

1

There was (is?) a detection weakness on the Windows side that looks very similar to your issue: http://www.itninja.com/blog/view/k1000-computer-asset-history-shows-winamp-removed-from-inventory-and-found-again-multiple-times

My guess would be that something similar is going on with this software on Macs. 

Enable debug, gather the logs and submit a ticket to KACE support so they can take a look at it: http://www.kace.com/support/resources/kb/solutiondetail?sol=SOL112035

Answered 01/08/2014 by: jknox
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity

Share