hi ,

While installation of source media , I am getting one warning " The file extension .DB is already registered by another file type dbfile.Do you want to overwrite the registery entry and register this file eextension as Progress file? "

Clicking Yes , installation continues.

I need to suppres this message in my package , but installation through /qb also doesn't suppress the message .Kindly suggest how to do that .
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Is it a vendor MSI?

If it is vendor MSI check that is it some Custom action which is of "Call DLL" type action which do registration for that file.
2. You can just check is Self-Reg table is popullated.If yes then remove the entry from that table and popullated the registry table for that file.
Answered 09/23/2008 by: anks_09
Orange Senior Belt

Please log in to comment
0
no its not vendor MSI , repackaged one and I captured the error also , but dont know , its still showing in the MSI installation
Answered 09/23/2008 by: dpu_bansal83
Orange Belt

Please log in to comment
0
This is nothing to do with registration of DLLs, it just seems that way, thanks to Microsoft's mangled English. It's to do with the association of files with an extension of '.db', in that your test workstation already has an EXE associated with that extension.

I'm afraid I don't know how you could suppress this warning, other than going with a completely silent install. In a blatant exposure of a knowledge gap on my part, I'm afraid I don't know what the WI engine behaviour in that situation would be, whether it defaults to the new extension or retains the old. I suspect the former.
Answered 09/23/2008 by: VBScab
Red Belt

Please log in to comment
0
hello,
this error is all about ur file extensions.
one thing u need to do is remove the appropriate registry keys corresponding to this file extensions in HKCR and move them to HKLM\Software\classes\ .
this will solve ur problem .
Answered 09/23/2008 by: vijaykodali
Senior Yellow Belt

Please log in to comment
0
ORIGINAL: vijaykodali
one thing u need to do is remove the appropriate registry keys corresponding to this file extensions in HKCR and move them to HKLM\Software\classes\ .
With the greatest of respect, this is nonsense. Can I politely suggest that you do some research on the Windows registry and how it's structured? Disregarding the misinformation, I'm intrigued to know how you think such an exercise will eliminate the problem.
Answered 09/24/2008 by: VBScab
Red Belt

Please log in to comment
0
I have made the DB entries in extension table which was missing there and it resolved the problem.

Thanks a lot for all of you guy's support !
Answered 09/24/2008 by: dpu_bansal83
Orange Belt

Please log in to comment
0
I know this was resolved but, out of curisoity, /qb didn't work but wouldn't /qb- fix that?
Answered 09/26/2008 by: schieb
Purple Belt

Please log in to comment
0
Fix?? maybe. But why pass the buck when you can "resolve" the issue for all installation scenarios... it would just hide the issue... what happens if the user does a repair from the control panel..?
Answered 09/26/2008 by: kiptek
Second Degree Green Belt

Please log in to comment
Answer this question or Comment on this question for clarity