I have installed solidworks 2014 R2 and deployed through the test machine but our preference is not have any user interaction. At the end of the install when I click on the solidworks icon I get the Product Activation and setup before I can get into solidworks, there is a tab also for 30 days before I have to activate screen, I want to bypass that and not have the user interact with it, any help
4 Comments   [ + ] Show Comments

Comments

  • Look through the Registry, %USERPROFILE% or ProgramData for these settings. There should be some configurations pointing to the first launch instances.
  • Product activation is a licensing scheme that was developed to avoid users making illegal copies of software. Generally, product activation works on the basis of reading machine specific information such as the MAC address and the bios serial number and uses this as part of the activation token. So even if you are able to determine where the activation information is stored, unless you know the algorithms used to calculate the activation token, it will not work on any other machine. Speak to the vendor and ask if they offer an alternative option such as a licensing server which you can have accessible on the network. (Not unlike Microsoft's KMS server).
  • is you are using the msi to install it, you command line should look something like this. where the "xxxx-xxxx-xxxx-xxxx" is your serial number.




    msiexec /i "32-bit_admin_image_path\SolidWorks\SolidWorks.Msi"
    INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx
    xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=3
    ADDLOCAL=SolidWorks,SolidWorksToolbox,Intel_Modules_AgeiaX86 /qb
    • From what I recall at a previous client, the product still needs activation, no matter what method is used to install it. It was no biggy there, as the target audience was very small (12 designers). I can't imagine too many shops would have a requirement for mass-deployment of a product like this.
  • thanks guys for all the help
Please log in to comment

Answers

-1
i have read complete question and you can find answer here: abc.com
Answered 10/27/2014 by: irving.wei
White Belt

Please log in to comment
-1
Answered 10/27/2014 by: irving.wei
White Belt

Please log in to comment
Answer this question or Comment on this question for clarity

Share