So I've been trying to install Snagit 8 using a custom MST file and am running into issues with the license key. Other options I choose to customize are taking properly, for example not including the desktop icon but for some reason after the install it keeps telling me that I have the eval version installed and I have 30 days to use it. I've entered the license key in NEWKEY, I've created a new row called TSC_SOFTWARE_KEY and put the license there and I;ve changed TSC_SOFTWARE_TYPE to REGISTERED. What else do I need to modify to get the license key to work.

Addtional Info
If I don't use the mst and enter the key manually it works fine
If I look in the registery these 3 keys are missing if I use the mst, Distcode...RegisteredTo...RegistrationKey but as I mentioned other items I modified in the MST are taking so it is being looked at.

I'm sure this is something simple that I'm overlooking, any help would be appreciated. Thanks
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Might want to delete the NEWKEY property you added and use:

TSC_SOFTWARE_KEY

Add your license key to that and give it a go.

If this doesnt work I would go for a snapshot and see where it puts the license key in the registry,, may be able to manually use those registry values to register the product.

Paul
Answered 06/04/2007 by: Inabus
Second Degree Green Belt

Please log in to comment
0
ORIGINAL: djaxis

So I've been trying to install Snagit 8 using a custom MST file and am running into issues with the license key. Other options I choose to customize are taking properly, for example not including the desktop icon but for some reason after the install it keeps telling me that I have the eval version installed and I have 30 days to use it. I've entered the license key in NEWKEY, I've created a new row called TSC_SOFTWARE_KEY and put the license there and I;ve changed TSC_SOFTWARE_TYPE to REGISTERED. What else do I need to modify to get the license key to work.

Addtional Info
If I don't use the mst and enter the key manually it works fine
If I look in the registery these 3 keys are missing if I use the mst, Distcode...RegisteredTo...RegistrationKey but as I mentioned other items I modified in the MST are taking so it is being looked at.

I'm sure this is something simple that I'm overlooking, any help would be appreciated. Thanks



Djaxis, did you find a solution? We have version 10 and the mst is working but for 8.2 I've got the same problem as you mention.
TSC_SOFTWARE_KEY is missing so I'm using NEWKEY but it's doesn't change anything. After every first start of the app it keeps telling me it's unregistered [&:]
Answered 12/15/2011 by: kingskawn
Purple Belt

Please log in to comment
Answer this question or Comment on this question for clarity