I am trying to install AUTOCAD LT 2013 silently for trail version. During installation I have to select Country = Australia. Post Installation while launching the shortcut "AutoCAD LT 2013 - English" I don't want the registration window to appear. I have tried the following commind line for installation

setup.exe /w /t /q setup.ini /Lang en-US /c ACADLT: INSTALLDIR="%ProgramFiles%\Autodesk\AutoCAD LT 2012\" InstallLevel=3 ADSK_EULA_STATUS=#0 ALLUSERS=1 ADSK_DESKTOPSHORTCUT_1=0 ACADCSALLOWEDCOUNTRIES= AU.


I am not sure even after passing
ACADCSALLOWEDCOUNTRIES= AU property installer has selected Australia region or not. Let me know how to know the selected region and also how to suppress Registration window.
Answer Summary:
Cancel
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Community Chosen Answer

3

Can you check if there is a Deploy option on the installer of AutoCAD LT 2013? I worked on the AutoCAD 2013 and found that Deployment tool specifically for AutoCAD 2013. it works like an Adobe Customization wizard but better.

Answered 07/10/2012 by: dj_xest
Fifth Degree Black Belt

  • I tried to search such wizard on the internet but haven't found it for LT 2013. What are the parameters passed during silent installation. Any property you are passing to install for particular country?
Please log in to comment

Answers

1

First: I'd try to extract the underlying MSI and make my changes in an MST.

Is the registration during installation or when starting the application?

During installation: Probably some CA that could be commented out or set an impossible condition (1=2).

When starting application: Run the registration with ProcMon and see if there's a registry or file that you could incoporate in you MST.

Answered 07/06/2012 by: andemats
Second Degree Black Belt

  • I haven't found any custom action in the extracted MSI related to registration windows.
    That registration appears when I launch the shortcut.

    Any idea how to select Country during silent installation . By default it selects United States. But I have to install it for Australia region. I tried 2 properties ACADCSALLOWEDCOUNTRIES=AU and ADLM_EULA_COUNTRY=AU, but still it selects United States as default
  • Hi... were u able to figure out the country selection problem ? I need to select Canada. If i add this prop ADLM_EULA_COUNTRY=CA , how can i verify that the country is CANADA after silent installation ? any registry or file which will tell me that the country is CANADA ?
  • IF its related to EULA ? where can i find that the correct EULA (CANADA) is installed after installation
  • Ok.. I was able to figure out the way to verify the correct country installation. It can be found within the EULA agreements found in Help>About.
Please log in to comment
0

Hi,

I created an admin image of the package with "Create Deployment option". It is installing silently. I have suppressed the Welcome Screen, CIP window and License Agreement Window which appears when shortcut is launched.  

Answered 07/22/2012 by: vmnit
Third Degree Blue Belt

  • good to know then. Any issues?
  • The issue was during uninstallation of setup, it leaves Autodesk Sync uninstalled. All other products installed by setup are uninstalling except Autodesk Sync. Finally I hide the Add/Remove Program entry of Autodesk Sync.....One more thing. I was unable to Hide the Welcome Screen window which appears every time after CIP window. The setup installs AutoUserSettings.xml which contains a value "Date" whose vaule should be set 1 in order to supress the welcome screen

    But that works manually. If i include that file in the package that thing won't work and on every launch of shortcut the application will overwrite that value to 0..... So unable to supress Welcome screen. rest of all things are fine....Any suggestion ??
  • About the Autodesk Sync, you can chain its uninstalls before or after your main AutoCAD uninstall script. I used the SMS_SCCM scripts to achieve a more controlled deployment but took me a while to finish.

    regarding the Welcome screen, during the configuration of deployment package, there is a way to suppress it by unchecking the option in the user preference. "Display welcome screen at startup". You should have disabled it from there.
  • Hi, I also used this option and it works perfectly. But now there is a new requirement, they want me to remove the serial key, so that they can keep track of who has the software.
    Is there a way this can be done in the AdminImageX.ini file
  • This is a big question. "... they want me to remove the serial key, so that they can keep track of who has the software..."

    The serials are needed to run the installs..
Please log in to comment
Answer this question or Comment on this question for clarity