I am trying to install an application silently through SCCM but it does not work for Win7. I am getting the below error.

Error 1312. Cannot create the directory 'C:\Windows\TEMP\miaB7D1.tmp\AginityNetezzaWorkbenchSetupx86.exe'.  A file with this name already exists.  Please rename or remove the file and click retry, or click Cancel to exit.

The file is being created by the application itself. If I run the silent installation with an Admin account it works perfectly. 

I tried with psexec.exe and scheduling a task but nothing works, seems the issue is when the app is installed with system account. 

Has anyone ever had an issue like this and was able to solve it?

Thanks!

0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Community Chosen Answer

2

I have faced this issue with other applications which are created by InstallAware so where ever you get this mia temp folders it is basically InstallAware applications. I did this for Axure and it worked fine manually but failed under system context.

I finally had to capture the package thought it has MSI in it but there is no other way.

Just take care that you do not install an MSP if it is ever released. Manage the upgrades by yourself on the MSI created by you.

Let me know if you face issue again.

Answered 09/13/2012 by: piyushnasa
Red Belt

Please log in to comment

Answers

1

Ensure that you are performing installation for ALLUSERS..

Answered 09/13/2012 by: jagadeish
Red Belt

  • The installation for all users is being done as is one of the default options for the installer. the command I am using is "setup.exe /s". In XP installs without issues. The problem is in Win7 and only with system account.
  • //as is one of the default options for the installer. //

    How come?????
  • You have mentioned that it was working fine on Windows XP.. Did you install it through System Context on Windows XP
Please log in to comment
0

Try to grant permission to the folder before the main install. Hope this help.

Answered 10/11/2012 by: kenshin288
Senior Yellow Belt

Please log in to comment
0

Ensure that you are performing installation for ALLUSERS..

Answered 09/13/2012 by: jagadeish
Red Belt

  • The reason for saying this is, most of the per-user installation will fail when you install it through system context as system context does not have it is own profile as normal user profile..
Please log in to comment
0

Have u copied the source locally & tried ?? I faced this issue once long back (with a different app) when i was trying to run the source from a n/w location (mapped drive). A local copy installation succeeded

Answered 09/14/2012 by: hrs2cool
Black Belt

Please log in to comment
-1

Have you tried clearing your C:\Windows\Temp directory?

 

Answered 09/13/2012 by: SilentKiller
Orange Belt

  • I cleared the temp directory. The file the app is asking to be removed is created by the app itself during installation, Even if I try to remove it I can't because it is being used by the installer at that time.
  • I have an issue like this before, I tried the procmon tool, and it pointed me to the same C:\Windows\Temp location. The install is trying to access a file in the folder and I had an ACCESS DENIED on the file. Try to grant permission to the folder before the main install. Hope this help.
Please log in to comment
Answer this question or Comment on this question for clarity