I'm having some problems making a silent install of Office Proofing Tools 2007. I thought I had done it correctly modifying the config.xml but when launching the command below the installation still launches like default.

"\\server\share\setup.exe" /config "\\server\share\ProofKit.WW\config.xml"

Here is how my config.xml file looks like:

<Configuration Product="ProofKit">

<!-- <Display Level="basic" CompletionNotice="NO" SuppressModal="yes" AcceptEula="yes" /> -->

<!-- <Logging Type="standard" Path="%temp%" Template="Microsoft Office Profing Tools Kit Setup(*).txt" /> -->

<!-- <PIDKEY Value="BCDFGHJKMPQRTVWXY2346789B" /> -->

<!-- <USERNAME Value="Customer" /> -->

<!-- <COMPANYNAME Value="MyCompany" /> -->

<!-- <INSTALLLOCATION Value="%programfiles%\Microsoft Office" /> -->

<!-- <LIS CACHEACTION="CacheOnly" /> -->

<!-- <SOURCELIST Value="\\server1\share\Office12;\\server2\share\Office12" /> -->

<!-- <DistributionPoint Location="\\server\share\Office12" /> -->

<!-- <OptionState Id="OptionID" State="absent" Children="force" /> -->

<!-- <Setting Id="SETUP_REBOOT" Value="NEVER" /> -->

<!-- <Command Path="msiexec.exe" Args="/i \\server\share\my.msi" QuietArg="/q" ChainPosition="after" Execute="install" /> -->

</Configuration>

Is there anything I have forgot/missed?
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
That's an empty template of the config.xml? Maybe start with removing the bold parts of the properties you want to use and don't forget to fill in the correct values (italic parts)

<!-- <OptionState Id="OptionID" State="absent" Children="force" /> -->


You might want to read this page as well: http://technet.microsoft.com/en-us/library/cc179195.aspx
Answered 04/29/2010 by: Rheuvel
Brown Belt

Please log in to comment
0
The template contains default settings expect from the changes done to the first and eleventh line. I tried to remove the bold parts (!) from one or several lines but when trying to launch the installation a message appears saying that the config.xml is not valid. "Run Setup again without using a Setup configuration file, or fix the configuration file".
Answered 04/29/2010 by: RS|Stian
Orange Belt

Please log in to comment
0
ProofingTools should be an OptionId and not the Product. The product is your Office version, like Enterprise, ProPlus, etc...

I really recommend you read every chapter on the following website to understand what you are doing: http://technet.microsoft.com/en-us/library/cc179099.aspx

Basically anything you need to know to get a working config.xml is explained there. So read it carefully, modify the config.xml after that and if it still doesn't work, post your new config.xml again. I'd gladly help you then, but to be honest, at the moment it doesn't look like you put any effort in really understanding how the config.xml works.
Answered 04/29/2010 by: Rheuvel
Brown Belt

Please log in to comment
0
As more and more companies move to this kind of setup - an EXE stub and an XML configuration file, learning about how XML files are formatted would be useful, too.
Answered 04/29/2010 by: VBScab
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity