Hi All,

Has anyone ever created an OSD\shortcut that simply opens a folder in the virtual environment? I thought it would be a simple thing to do but I'm having issues.

The Filename in Codebase ref is FILENAME="%CSIDL_PROGRAM_FILES%\Folder1".
It throws a windows explorer error stating it cannot find C:\Program Files\Folder1. If I manually create the folder locally then it just opens the local folder.

If I change the FILENAME to ="%CSIDL_PROGRAM_FILES%\Folder1\File1.txt" it opens the file without issue.
If I change the FILENAME to ="Q:\VirApp.001\VFS\CSIDL_PROGRAM_FILES\Folder1" it throws an access denied error.

The end user of the app needs to copy files to and from the application folders so thats why I need to give them access to the virtual environment.

Thanks,
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
I think you'll find you need to specify an exe in the filename and the folder as a parameter - you should be able to get away with using explorer.exe, but you will need to ensure that "open window in seperate process" or whatever it's called is set in the local explorer folder view properties..
Answered 02/13/2009 by: DannyC
Orange Belt

Please log in to comment
0
ORIGINAL: DannyC

you should be able to get away with using explorer.exe, but you will need to ensure that "open window in seperate process" or whatever it's called is set in the local explorer folder view properties..

this can be done by running the explorer process with the /separate switch, ex.
explorer /separate C:\temp
Answered 02/13/2009 by: AngelD
Red Belt

Please log in to comment
0
Setting %WINDIR%\explorer.exe as the filename and the folder I need to open as the parameter has worked. The /seperate switch didn't work for me, however I didn't need it as a seperate explorer window opens.
Answered 02/17/2009 by: ChluainEois
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity