Hi all,

I am currently packaging an msi that installs a folder to the
"C:\Documents and Settings\All Users\Shared Documents" area during the setup capture but when i try to install my msi that folder is created under the following......
"C:\Documents and Settings\%logged_on_user%\All Users\Shared Documents".
The directory table looks something like this

WindowsFolder ¦ TARGETDIR ¦ .:Windows
ProfilesFolder ¦ WindowsFolder ¦ .:Profiles
ALLUSERSPROFILE ¦ ProfilesFolder ¦ AllUsers¦AllUsers
Documents ¦ ALLUSERSPROFILE ¦ DOCUME~1¦Documents

My question is how do install files and folders to the Shared Documents area of the All Users Profile?

Thanks,
Rgds,
Mark
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
WIX?
http://www.mail-archive.com/wix-users@lists.sourceforge.net/msg14897.html

[ALLUSERSPROFILE]\documents should work for XP machines.. are you using ALLUSERS=1?
Answered 08/20/2009 by: turbokitty
Sixth Degree Black Belt

Please log in to comment
0
or just using the [Documents] dir as the destination as it is already defined in the directory table (ALLUSERS=1)

Where do your files appear in Installation Expert (if u r using wise)
Answered 08/20/2009 by: kiptek
Second Degree Green Belt

Please log in to comment
0
Hi Mark,

Did you find a way to install files and folders to the Shared Documents area of the All Users Profile?

I am curious to know about it because when I tried doing it, I wasnt able to get through it.

So Please share it.

Thanks
Answered 08/24/2009 by: WiseNdMe
Senior Yellow Belt

Please log in to comment
0
I'm not sure what the trouble is. I just ran a quick test and [ALLUSERSPROFILE]\documents worked for me on an XP machine. Is Vista what's causing trouble?
Answered 08/24/2009 by: turbokitty
Sixth Degree Black Belt

Please log in to comment
Answer this question or Comment on this question for clarity