Having been a WPS 5 user for some time I am now beening faced with the deep joy of having to use v4.01! which although I know has a few bugs do not know how they present themselves. When trying to repackage what seems to be a fairly straight forward app setup capture returns the following messages during the final stage;

"Could not write row in table: Environment" followed by...

"Cannot copy file: the file name you specified is not valid or too long...."

this results in none of the source files being copied across. One of my colleagues advised he'd seen similar things before for which the solution was to re-run the scan, unfortunately this doesn't seem to work in this instance.

I have the following options selected;

Copy Source Files During Installation Save.
Store Source File Pathnames as Relative Pathnames.

Any help or advise would be greatly appreciated!
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
There is a path name length limitation, but not sure if Wise or Windows Installer is responsible for that. I've run across it before.

Unfortunately there's not a lot you can do except modify the install path to one with a shorter name.

Also watch for spaces in the path names. Some Unix/Oracle type apps don't like them. If you must use a path name with spaces use the short file name(s), i.e. c:\progra~1

If you could name the specific app you're trying to package, and more details on how you're packaging it -- maybe somebody already has experience with it.

ORIGINAL: Naffcat

Having been a WPS 5 user for some time I am now beening faced with the deep joy of having to use v4.01! which although I know has a few bugs do not know how they present themselves. When trying to repackage what seems to be a fairly straight forward app setup capture returns the following messages during the final stage;

"Could not write row in table: Environment" followed by...

"Cannot copy file: the file name you specified is not valid or too long...."

this results in none of the source files being copied across. One of my colleagues advised he'd seen similar things before for which the solution was to re-run the scan, unfortunately this doesn't seem to work in this instance.

I have the following options selected;

Copy Source Files During Installation Save.
Store Source File Pathnames as Relative Pathnames.

Any help or advise would be greatly appreciated!
Answered 12/13/2004 by: aogilmor
Ninth Degree Black Belt

  • This is a Windows* OS/file system issue.The cause is directory paths on the drive is longer than 255 characters (including spaces).There's a lot of additional softwares which can fix this problem like Long Path Tool.
    http://PathTooDeep.com
Please log in to comment
0
It didn't appear to be path length related, but the work round was to create the MSI from scratch. Not ideal I know.
Answered 12/16/2004 by: Naffcat
Senior Purple Belt

Please log in to comment
0
I have seen this error as well and it only occurred when my client setup used a mapped drive and not a UNC path to the Software Manager Repository.

Try reinstalling the client of WPS and use the UNC path and see how it goes.
Answered 12/16/2004 by: MSIMaker
Second Degree Black Belt

Please log in to comment
0
When you begin to capture, you select "Copy Source Files During Installation Save" and specify a "Destination Directory". The path of the Destiatnion Directory must not end with a backslash (\)
Answered 12/17/2004 by: xink22822
Senior Yellow Belt

Please log in to comment
0

This is a Windows* OS/file system issue.The cause is directory paths on the drive is longer than 255 characters (including spaces).There's a lot of  additional softwares which can fix this problem like Long Path Tool.
http://PathTooDeep.com

Answered 11/17/2012 by: GabrielNar
White Belt

Please log in to comment
Answer this question or Comment on this question for clarity