Hi all

I have repackaged an application containing several files under c:\Program Files (x86)... and a few files under c:\Users\<profile>\AppData\<app>

I have put the userspecific files in a isolated component in the same feature as the corresponding shortcut.

I have created a custom action "Set Directory" and set the directory "USERFOLDER" to: [%APPDATA]\<manufacturer>\<product>

The resulting MSI installs all files succesfully for the first user. But when I log on with other users selfhealing fails.

Eg.

I install the MSI for user A. Logs out of the system and logs on again with user B.

Selfhealing is not initiated when clicking on the shortcut.

BUT if I delete the files for user A and user B initiates selfhealing then the files are reinstalled for user A (instead of user B)?

 

Does anyone know how to solve this?

---

I am working with "Wise Package Studio" and "Windows 7 (64 bit)"

 

Best Regards,

Christian

 

 

 

Answer Summary:
Actually I made a rookie mistake and forgot to add the HKCU-registry as keypath :( My keypath was one of the files. New keypath solved the problem :)
Cancel
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Answers

2
  • - Did you install per-machine using ALLUSERS=1?
  • - Did you give the component containing the files a keypath that is a HKCU registry key?
  • - Also, check if, during the install for the second user, Windows Installer can actually reach the original MSI that you installed from
  • - Is your shortcut advertised?

For more info, you could always have a look at my blogs on the topic:

http://www.itninja.com/blog/view/a-general-approach-to-software-packaging-propagating-user-settings

http://www.itninja.com/blog/view/a-general-approach-to-software-package-using-duplicatefiles

Answered 05/09/2012 by: pjgeutjens
Red Belt

  • Hi pjgeutjens

    Ty for your reply.

    Actually I made a rookie mistake and forgot to add the HKCU-registry as keypath :(
    My keypath was one of the files.

    New keypath solved the problem :)
Please log in to comment
Answer this question or Comment on this question for clarity