Has anyone else noticed that when there is a " in a scripting task that the K1 interprets it as " ?

Specifically the "Reboot a windows system" script that I believe is a canned script has this problem.

 

Also have there been any hotfixes or patches that people have had installed on their machine since the 5.5 upgrade?

Our core financial platform was scheduled to be updated this past weekend and through the K1 it just did not work.

I used the exact same script that I used last time we did the upgrade which back then it worked like a charm.

 

We found that it pushed the script to a number of machines, but it only ran on 2 of 311 machines!

I know that it can run a script because I did a few smaller scripts on Friday which worked just as they should.

 

I'm not above saying I screwed something up, but something just isn't working right in 5.5 for us.

 

Thanks folks.

3 Comments   [ + ] Show Comments

Comments

  • I'm also noticing that as of this morning the CPU usage reporting to our VM software is completely through the roof.
    And yes I've restarted the K1 multiple times over the last two days.
  • The K1000 load was over 100! THe throughput setting was on 3 and our agent check in settings haven't been touched.
  • This content is currently hidden from public view.
    Reason: Removed by member request
    For more information, visit our FAQ's.
  • We also had several scripting & patching issues right after the 5.5 upgrade but after applying all 9 hotfixes we are only seeing a few scripting issues:

    k1_hotfix_5.5_K1_13891_script_quoting_20130913.kbin
    k1_hotfix_5.5_K1_14050_HD_slowdown_20130909.kbin
    k1_hotfix_5.5_K1_14059_Patching_Signature_Reload_20130910.kbin
    k1_hotfix_5.5_k1_14076_SCR_DB_access_20130923.kbin
    k1_hotfix_5.5_K1-13919_20130830_UI_Freeze.kbin
    k1_hotfix_5.5_Share_Inventory_K1_13928_20130906.kbin
    k1_hotfix_5_5_90545_Hide_License_Install_Count.kbin
    k1_hotfix_5_5_K1_14047_HD_column_sort_20130912.kbin
    kbox_patch_5.4_5.5_k1_14101_crontab_update_20130930.kbin

    We also had a few scripts that changed to having '&quot' and I just manually fixed them all - Thankfully it was only a few out of roughly 80 scripts.

    Also having to check the "wait for completion" box on the script tasks in order for most scripts to work - which is not something I've had to do in the past either.

    I have 2 support tickets open with KACE, one regarding the syntax of custom inventory rules and one regarding the Run Now Script Page clearing in the middle of push to 34 devices.

    Environment:
    K1000 5.5.90545 using DFS replication with 2800 clients spread out in in 45 locations acrooss the State. 2263 clients at agent version 5.5.25198, 500 at version 5.4 and 37 still at 5.3. and getting upgraded as I type this. Network running Windows Server 2008 R2. We also have the K2000 with 34 RSA's.
Please log in to comment

Answers

This content is currently hidden from public view.
Reason: Removed by member request
For more information, visit our FAQ's.

1

I had some scripting issues after our upgrade too. I had support working on a ticket for the '"' issue. The sent me some hotifxes that didn't resolve the issue. However the technician suggested I use Firefox in lieu of IE to update the broken scripts and it worked. The quotes (") saved as normal via Firefox and the changes then stuck. So I ended up just manually fixing our scripts which worked in our case...we're talking a doable amount here.

Another issue I've noticed is I now have to check the "wait for completion" box on the script tasks in order for most scripts to work - which is not something I've had to do in the past...

 

Answered 10/28/2013 by: jegolf
Red Belt

  • Wonder why firefox would work properly and IE wouldn't? And you're right I never have had to do the "wait for completion" box before. Thanks for the info sir.
    • I talked with support and they are looking through logs on why the script didn't run.
      The guy also gave me about 4 different hot fixes.
Please log in to comment
Answer this question or Comment on this question for clarity