i am gettig the following error 0x80070490 after i select a valid TS from my Sccm PE boot drive. It seems to fail before the TS begins its partition step.

the only error in smsts.log is:

unable to find a volume that is sutable for stageing the boot image. element not found.

 

i am trying to figure out what this error means. i am trying to image a lenovo yoga with win 8.1. the device does not have a hardware nic so i am useing a usb NIC which is working because i was able to pull up my TS's. i imported the driver pack from lenovo onto the sccm server, created a driver package, and distributed the content to our DP (distribution point). i then modified my TS to look for the yoga devices and install the driver package.

the one thing i didnt do is add any drivers to my boot image when i imported them into SCCM. would i recive a generic error like this if i didnt have chipset drivers or something like that in my boot image? i didnt think this step was necessary because i already have drivers for the USB NIC's in the boot image.

below is the smsts.log for the machine. this only happens on this model device. all other models run the TS as expected.

any help with this would be appreciated.

thank you,

-pat

 

 

Answer Summary:
Cancel
2 Comments   [ + ] Show Comments

Comments

  • sorry about the formatting not sure if there is a better way to upload logs




    <![LOG[Setting RebootSettingsConfig policy in the environment.]LOG]!><time="16:06:18.472+300" date="03-27-2014" component="TSMBootstrap" context="" type="0" thread="1044" file="tsmediawizardcontrol.cpp:1984">
    <![LOG[Downloading policy body {94db3168-1b1f-4d27-8787-9476c3c64689}.]LOG]!><time="16:06:18.488+300" date="03-27-2014" component="TSMBootstrap" context="" type="1" thread="1044" file="tspolicy.cpp:2103">
    <![LOG[Preparing Policy Body Request.]LOG]!><time="16:06:18.488+300" date="03-27-2014" component="TSMBootstrap" context="" type="0" thread="1044" file="tspolicy.cpp:2106">
    <![LOG[ Setting transport.]LOG]!><time="16:06:18.488+300" date="03-27-2014" component="TSMBootstrap" context="" type="0" thread="1044" file="tspolicy.cpp:2107">
    <![LOG[ Setting policy location = http://<mp>/SMS_MP/.sms_pol?{94db3168-1b1f-4d27-8787-9476c3c64689}.1_00.]LOG]!><time="16:06:18.488+300" date="03-27-2014" component="TSMBootstrap" context="" type="0" thread="1044" file="tspolicy.cpp:2109">
    <![LOG[Executing Policy Body Request.]LOG]!><time="16:06:18.488+300" date="03-27-2014" component="TSMBootstrap" context="" type="0" thread="1044" file="tspolicy.cpp:2126">
    <![LOG[CLibSMSMessageWinHttpTransport::Send: URL: WCSCCM02.BallHort.com:80 GET /SMS_MP/.sms_pol?{94db3168-1b1f-4d27-8787-9476c3c64689}.1_00]LOG]!><time="16:06:18.504+300" date="03-27-2014" component="TSMBootstrap" context="" type="1" thread="1044" file="libsmsmessaging.cpp:8604">
    <![LOG[Request was successful.]LOG]!><time="16:06:18.504+300" date="03-27-2014" component="TSMBootstrap" context="" type="0" thread="1044" file="libsmsmessaging.cpp:8939">
    <![LOG[Hash computed from CSP: Microsoft Enhanced RSA and AES Cryptographic Provider, AlgID: 32780, HashSize: 32 ]LOG]!><time="16:06:18.504+300" date="03-27-2014" component="TSMBootstrap" context="" type="0" thread="1044" file="libcrypt.cpp:700">
    <![LOG[Expected Hash size: 32, Computed Hash size: 32 ]LOG]!><time="16:06:18.504+300" date="03-27-2014" component="TSMBootstrap" context="" type="0" thread="1044" file="libcrypt.cpp:747">
    <![LOG[Request location: HTTP://<MP>/SMS_MP/.SMS_POL?{94DB3168-1B1F-4D27-8787-9476C3C64689}.1_00]LOG]!><time="16:06:18.504+300" date="03-27-2014" component="TSMBootstrap" context="" type="1" thread="1044" file="libsmsmessaging.cpp:4813">
    <![LOG[Response ID: {94DB3168-1B1F-4D27-8787-9476C3C64689}]LOG]!><time="16:06:18.504+300" date="03-27-2014" component="TSMBootstrap" context="" type="1" thread="1044" file="libsmsmessaging.cpp:4814">
    <![LOG[Reading Policy Body.]LOG]!><time="16:06:18.504+300" date="03-27-2014" component="TSMBootstrap" context="" type="0" thread="1044" file="tspolicy.cpp:2134">
    <![LOG[Parsing Policy Body.]LOG]!><time="16:06:18.504+300" date="03-27-2014" component="TSMBootstrap" context="" type="0" thread="1044" file="tspolicy.cpp:2141">
    <![LOG[::CompressBuffer(65536,-1)]LOG]!><time="16:06:18.504+300" date="03-27-2014" component="TSMBootstrap" context="" type="0" thread="1044" file="ccmzlib.cpp:700">
    <![LOG[Compression (zlib) succeeded: original size 1556, compressed size 426.]LOG]!><time="16:06:18.504+300" date="03-27-2014" component="TSMBootstrap" context="" type="0" thread="1044" file="ccmzlib.cpp:489">
    <![LOG[Setting AppManClientConfig policy in the environment.]LOG]!><time="16:06:18.504+300" date="03-27-2014" component="TSMBootstrap" context="" type="0" thread="1044" file="tsmediawizardcontrol.cpp:1992">
    <![LOG[Downloading policy body {20e18f50-175f-4aa0-93eb-f102a91db67d}.]LOG]!><time="16:06:18.504+300" date="03-27-2014" component="TSMBootstrap" context="" type="1" thread="1044" file="tspolicy.cpp:2103">
    <![LOG[Preparing Policy Body Request.]LOG]!><time="16:06:18.504+300" date="03-27-2014" component="TSMBootstrap" context="" type="0" thread="1044" file="tspolicy.cpp:2106">
    <![LOG[ Setting transport.]LOG]!><time="16:06:18.504+300" date="03-27-2014" component="TSMBootstrap" context="" type="0" thread="1044" file="tspolicy.cpp:2107">
    <![LOG[ Setting policy location = http://<mp>/SMS_MP/.sms_pol?{20e18f50-175f-4aa0-93eb-f102a91db67d}.3_00.]LOG]!><time="16:06:18.504+300" date="03-27-2014" component="TSMBootstrap" context="" type="0" thread="1044" file="tspolicy.cpp:2109">
    <![LOG[Executing Policy Body Request.]LOG]!><time="16:06:18.504+300" date="03-27-2014" component="TSMBootstrap" context="" type="0" thread="1044" file="tspolicy.cpp:2126">
    <![LOG[CLibSMSMessageWinHttpTransport::Send: URL: WCSCCM02.BallHort.com:80 GET /SMS_MP/.sms_pol?{20e18f50-175f-4aa0-93eb-f102a91db67d}.3_00]LOG]!><time="16:06:18.504+300" date="03-27-2014" component="TSMBootstrap" context="" type="1" thread="1044" file="libsmsmessaging.cpp:8604">
    <![LOG[Request was successful.]LOG]!><time="16:06:18.504+300" date="03-27-2014" component="TSMBootstrap" context="" type="0" thread="1044" file="libsmsmessaging.cpp:8939">
    <![LOG[Hash computed from CSP: Microsoft Enhanced RSA and AES Cryptographic Provider, AlgID: 32780, HashSize: 32 ]LOG]!><time="16:06:18.504+300" date="03-27-2014" component="TSMBootstrap" context="" type="0" thread="1044" file="libcrypt.cpp:700">
    <![LOG[Expected Hash size: 32, Computed Hash size: 32 ]LOG]!><time="16:06:18.504+300" date="03-27-2014" component="TSMBootstrap" context="" type="0" thread="1044" file="libcrypt.cpp:747">
    <![LOG[Request location: HTTP://<MP>/SMS_MP/.SMS_POL?{20E18F50-175F-4AA0-93EB-F102A91DB67D}.3_00]LOG]!><time="16:06:18.504+300" date="03-27-2014" component="TSMBootstrap" context="" type="1" thread="1044" file="libsmsmessaging.cpp:4813">
    <![LOG[Response ID: {20E18F50-175F-4AA0-93EB-F102A91DB67D}]LOG]!><time="16:06:18.504+300" date="03-27-2014" component="TSMBootstrap" context="" type="1" thread="1044" file="libsmsmessaging.cpp:4814">
    <![LOG[Reading Policy Body.]LOG]!><time="16:06:18.519+300" date="03-27-2014" component="TSMBootstrap" context="" type="0" thread="1044" file="tspolicy.cpp:2134">
    <![LOG[Parsing Policy Body.]LOG]!><time="16:06:18.519+300" date="03-27-2014" component="TSMBootstrap" context="" type="0" thread="1044" file="tspolicy.cpp:2141">
    <![LOG[::CompressBuffer(65536,-1)]LOG]!><time="16:06:18.519+300" date="03-27-2014" component="TSMBootstrap" context="" type="0" thread="1044" file="ccmzlib.cpp:700">
    <![LOG[Compression (zlib) succeeded: original size 6358, compressed size 985.]LOG]!><time="16:06:18.519+300" date="03-27-2014" component="TSMBootstrap" context="" type="0" thread="1044" file="ccmzlib.cpp:489">
    <![LOG[Media root drive is: D:\]LOG]!><time="16:06:18.519+300" date="03-27-2014" component="TSMBootstrap" context="" type="1" thread="1044" file="tsmediawizardcontrol.cpp:2046">
    <![LOG[Setting launch mode to: UFD]LOG]!><time="16:06:18.519+300" date="03-27-2014" component="TSMBootstrap" context="" type="1" thread="1044" file="tsmediawizardcontrol.cpp:2065">
    <![LOG[BootpackageID: CM100004 AssociatedWInPE: CM100004 SourceVersion: 14 AssociatedSourceVersion: 15]LOG]!><time="16:06:18.519+300" date="03-27-2014" component="TSMBootstrap" context="" type="1" thread="1044" file="tsmediawizardcontrol.cpp:2148">
    <![LOG[WinPE associated with task sequence does not match boot media.]LOG]!><time="16:06:18.519+300" date="03-27-2014" component="TSMBootstrap" context="" type="1" thread="1044" file="tsmediawizardcontrol.cpp:2195">
    <![LOG[Installing WinPE associated with task sequence CM100059:0.]LOG]!><time="16:06:18.519+300" date="03-27-2014" component="TSMBootstrap" context="" type="1" thread="1044" file="tsmediawizardcontrol.cpp:2228">
    <![LOG[Staging boot image CM100004]LOG]!><time="16:06:18.519+300" date="03-27-2014" component="TSMBootstrap" context="" type="1" thread="1044" file="bootimage.cpp:716">
    <![LOG[Mounting \Device\HarddiskVolume2 at Z:]LOG]!><time="16:06:22.222+300" date="03-27-2014" component="TSMBootstrap" context="" type="1" thread="1044" file="mountpoint.cpp:49">
    <![LOG[Unmounting volume Z:\]LOG]!><time="16:06:22.222+300" date="03-27-2014" component="TSMBootstrap" context="" type="1" thread="1044" file="mountpoint.cpp:104">
    <![LOG[Checking to see if the data path is on a bootable volume]LOG]!><time="16:06:22.262+300" date="03-27-2014" component="TSMBootstrap" context="" type="1" thread="1044" file="bootimage.cpp:1013">
    <![LOG[ Volume C:\ because it is not suitable as the system partition]LOG]!><time="16:06:22.262+300" date="03-27-2014" component="TSMBootstrap" context="" type="1" thread="1044" file="bootimage.cpp:394">
    <![LOG[Searching for a volume to stage the boot image]LOG]!><time="16:06:22.262+300" date="03-27-2014" component="TSMBootstrap" context="" type="1" thread="1044" file="bootimage.cpp:1037">
    <![LOG[ Volume D:\ is not on a fixed disk]LOG]!><time="16:06:22.262+300" date="03-27-2014" component="TSMBootstrap" context="" type="1" thread="1044" file="bootimage.cpp:345">
    <![LOG[ Volume C:\ because it is not suitable as the system partition]LOG]!><time="16:06:22.262+300" date="03-27-2014" component="TSMBootstrap" context="" type="1" thread="1044" file="bootimage.cpp:394">
    <![LOG[ Volume X:\ is not on a fixed disk]LOG]!><time="16:06:22.262+300" date="03-27-2014" component="TSMBootstrap" context="" type="1" thread="1044" file="bootimage.cpp:345">
    <![LOG[BootImage::FindBootableVolume( NULL, sPath), HRESULT=80070490 (e:\nts_sccm_release\sms\framework\tscore\bootimage.cpp,1044)]LOG]!><time="16:06:22.262+300" date="03-27-2014" component="TSMBootstrap" context="" type="0" thread="1044" file="bootimage.cpp:1044">
    <![LOG[Unable to find a volume that is suitable for staging the boot image.
    Element not found. (Error: 80070490; Source: Windows)]LOG]!><time="16:06:22.262+300" date="03-27-2014" component="TSMBootstrap" context="" type="3" thread="1044" file="bootimage.cpp:1044">
    <![LOG[BootImage::PrepareForStaging(sLocalDataPath), HRESULT=80070490 (e:\nts_sccm_release\sms\framework\tscore\bootimage.cpp,718)]LOG]!><time="16:06:22.262+300" date="03-27-2014" component="TSMBootstrap" context="" type="0" thread="1044" file="bootimage.cpp:718">
    <![LOG[TS::Boot::BootImage::StageBootImage( pAssociatedWinPE->GetPackageID(), TsBootProgress, pv, hCancelEvent), HRESULT=80070490 (e:\nts_sccm_release\sms\client\tasksequence\tsmbootstrap\tsmediawizardcontrol.cpp,2231)]LOG]!><time="16:06:22.262+300" date="03-27-2014" component="TSMBootstrap" context="" type="0" thread="1044" file="tsmediawizardcontrol.cpp:2231">
    <![LOG[Failed to stage WinPE. Code(0x80070490)]LOG]!><time="16:06:22.262+300" date="03-27-2014" component="TSMBootstrap" context="" type="3" thread="1044" file="tsmediawizardcontrol.cpp:2231">
    <![LOG[Command line for extension .exe is "%1" %*]LOG]!><time="16:06:22.262+300" date="03-27-2014" component="TSMBootstrap" context="" type="0" thread="1044" file="commandline.cpp:228">
    <![LOG[Set command line: "X:\sms\bin\x64\TsProgressUI.exe" /Unregister]LOG]!><time="16:06:22.262+300" date="03-27-2014" component="TSMBootstrap" context="" type="0" thread="1044" file="commandline.cpp:731">
    <![LOG[Executing command line: "X:\sms\bin\x64\TsProgressUI.exe" /Unregister]LOG]!><time="16:06:22.262+300" date="03-27-2014" component="TSMBootstrap" context="" type="1" thread="1044" file="commandline.cpp:827">
    <![LOG[==========[ TsProgressUI started in process 1120 ]==========]LOG]!><time="16:06:22.277+300" date="03-27-2014" component="TsProgressUI" context="" type="1" thread="1124" file="winmain.cpp:330">
    <![LOG[Command line: "X:\sms\bin\x64\TsProgressUI.exe" /Unregister]LOG]!><time="16:06:22.277+300" date="03-27-2014" component="TsProgressUI" context="" type="0" thread="1124" file="winmain.cpp:332">
    <![LOG[Unregistering COM classes]LOG]!><time="16:06:22.277+300" date="03-27-2014" component="TsProgressUI" context="" type="1" thread="1124" file="winmain.cpp:204">
    <![LOG[Unregistering class objects]LOG]!><time="16:06:22.277+300" date="03-27-2014" component="TsProgressUI" context="" type="1" thread="1124" file="winmain.cpp:495">
    <![LOG[Shutdown complete.]LOG]!><time="16:06:22.277+300" date="03-27-2014" component="TsProgressUI" context="" type="1" thread="1124" file="winmain.cpp:512">
    <![LOG[Process completed with exit code 0]LOG]!><time="16:06:22.277+300" date="03-27-2014" component="TSMBootstrap" context="" type="1" thread="1044" file="commandline.cpp:1123">
    <![LOG[Successfully unregistered TS Progress UI.]LOG]!><time="16:06:22.277+300" date="03-27-2014" component="TSMBootstrap" context="" type="1" thread="1044" file="utils.cpp:2903">
    <![LOG[ExecuteSelectedTaskSequence(fpCallbackProc,pv,hCancelEvent), HRESULT=80070490 (e:\nts_sccm_release\sms\client\tasksequence\tsmbootstrap\tsmediawizardcontrol.cpp,1568)]LOG]!><time="16:06:22.277+300" date="03-27-2014" component="TSMBootstrap" context="" type="0" thread="1044" file="tsmediawizardcontrol.cpp:1568">
    <![LOG[hrReturn, HRESULT=80070490 (e:\nts_sccm_release\sms\client\tasksequence\tsmbootstrap\tsmediaresolveprogresspage.cpp,445)]LOG]!><time="16:06:22.277+300" date="03-27-2014" component="TSMBootstrap" context="" type="0" thread="1044" file="tsmediaresolveprogresspage.cpp:445">
    <![LOG[ThreadToResolveAndExecuteTaskSequence failed. Code(0x80070490)]LOG]!><time="16:06:22.277+300" date="03-27-2014" component="TSMBootstrap" context="" type="3" thread="1044" file="tsmediaresolveprogresspage.cpp:445">
    <![LOG[ThreadToResolveAndExecuteTaskSequence returned code 0x80070490]LOG]!><time="16:06:22.277+300" date="03-27-2014" component="TSMBootstrap" context="" type="1" thread="888" file="tsmediaresolveprogresspage.cpp:221">
    <![LOG[Setting wizard error: An error occurred while starting the task sequence (0x80070490). For more information, contact your system administrator or helpdesk operator.]LOG]!><time="16:06:22.277+300" date="03-27-2014" component="TSMBootstrap" context="" type="0" thread="888" file="tsmediawizardcontrol.cpp:1588">
    <![LOG[ResolveProgressPage::OnWizardNext()]LOG]!><time="16:06:22.277+300" date="03-27-2014" component="TSMBootstrap" context="" type="0" thread="888" file="tsmediaresolveprogresspage.cpp:113">
    <![LOG[Activating Finish Page.]LOG]!><time="16:06:22.277+300" date="03-27-2014" component="TSMBootstrap" context="" type="0" thread="888" file="tsmediafinishpage.cpp:107">
    <![LOG[Loading bitmap]LOG]!><time="16:06:22.277+300" date="03-27-2014" component="TSMBootstrap" context="" type="1" thread="888" file="tsmbootstrap.cpp:1271">
    <![LOG[Executing command line: X:\windows\system32\cmd.exe /k]LOG]!><time="16:06:26.282+300" date="03-27-2014" component="TSBootShell" context="" type="1" thread="776" file="bootshell.cpp:860">
    <![LOG[The command completed successfully.]LOG]!><time="16:06:26.282+300" date="03-27-2014" component="TSBootShell" context="" type="1" thread="776" file="bootshell.cpp:942">
    <![LOG[Successfully launched command shell.]LOG]!><time="16:06:26.282+300" date="03-27-2014" component="TSBootShell" context="" type="1" thread="776" file="bootshell.cpp:432">
  • Could if be an UEFI partition issue? I have the Yoga's also, but use Kace to image them. Looking at the logs it looks like it's not a suitable partition.
  • This content is currently hidden from public view.
    Reason: Removed by member request
    For more information, visit our FAQ's.
Please log in to comment

Answers

0
so i wanted to add to this, cause the driver update mentioned in the last answer didn't seem to fix the issue for us.
I tried adding all the nic and controller drivers for the machine, and no dice.
I should clarify, in case it's different, that ours with tihs same error message indicated in the original thread, is a Thinkpad Yoga S1 with and SED drive.
the fix that seems to be working, at least once, is to use the lenovo secure erase disk to perform a secure erase of the drive, and then i can boot to pe, and start the build without issue.
however, if I retry the build, it will again fail, until I go back in and rerun the secure erase.
not yet sure why this is needed, but at least I have a temp workaround.
Answered 07/22/2014 by: orgwizard
White Belt

Please log in to comment
-1

I had tried formatting the disk before trying to run the TS. it didn't work, still got the error.

allot of people from various Blogs suggested changing the AHCI mode in the BIOS to something else to be compatible with your boot image.

however I think that just masks the real issue, you want to make the boot image compatible with the new machine not the other way around.

on the boot image I installed a SATA AHCI controller from the drivers I imported into SCCM for the Yoga. I then updated the distribution point, and created new bootable PE media to attempt the TS again.

the machine now starts my TS like it should because it can communicate with the Hard drive properly.

Answered 03/28/2014 by: pmac@ball
Senior White Belt

Please log in to comment
Answer this question or Comment on this question for clarity