Hello,

 

I am attempting to deploy Sage Line 50 v 7 via a .cmd file using SCCM 2007

 

Sage installs fine if I use the following command within the programs section of the package.

 

msiexec.exe /q ALLUSERS=2 /m MSIXPQVC /i "SageLine50.msi"

 

However, nothing happens on the receiving client if I set the package to run the program as a .cmd file.

 

Content of the .cmd file as below –

 

:: INSTALL SAGELINE50

 

msiexec.exe /q ALLUSERS=2 /m MSIXPQVC /i "SageLine50.msi"

 

::Copy file to the C: Drive

 

XCOPY /H /K /Y /C "%~dp0COMPANY.*" "C:\PROGRAM FILES (X86)\LINE50"

 

Any advice or ideas would be appreciated.

2 Comments   [ + ] Show Comments

Comments

  • Always, always, ALWAYS use full paths in command/script files. For DOS batch files, the trick is to use the %~DP0 prefix. Google it.

    Also, the '/M' argument in your command line is completely spurious.

    Lastly, please remove your duplicate post.
  • Why do you have the /m parameter in your install? The /m parameter requests that a MIF file is generated and the filename of the mif file should follow the /m switch. Using MSIXPQVC is a strange filename indeed - it this intentional?
    Also, if you are deploying through SCCM then you should set ALLUSERS=1 rather than 2 as SCCM deploys through a system account and you are not going to get a user context install anyway.
Please log in to comment

There are no answers at this time

Answers

Answer this question or Comment on this question for clarity