My first replication PC - it seems straight forward, and I don't know what it's not working.

I replicated all files to C:\K1000 just fine (had it on the same subnet while replicating, then moved to new building location)

I have tried multiple combinations of user/password (pctech, PCNAME\pctech, DOMAIN\pctech), and none seem to work. I've tried managed installs, and pushing run now scripts, and nothing works. I mean, I don't get errors, but I watch network monitoring tools on that machine, and nothing gets pushed out. Simple things that I've tested before and verified that work - like UltraVNC - wont work when using the replication pc. I even set it to NOT fall back to the K1000 to ensure I can verify that the replication works.

Any suggestions? i followed the admin guide, and did it exactly right. I don't know what's going wrong here.
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Could you post a screenshot of your setup? Can you access the replication share from one of the target PCs?

Casey
Answered 03/15/2012 by: cmccracken
Orange Senior Belt

Please log in to comment
0
Sure -
http://dl.dropbox.com/u/119117/replication.PNG

In regards to the download path user&pass, I've used a local admin credentials as well, and it won't work.
Answered 03/15/2012 by: sfigg
Red Belt

Please log in to comment
0
I'm assuming pctech has rights on D5M4CYQ1? If it is a windows PC, did you also give share permissions?

Casey
Answered 03/15/2012 by: cmccracken
Orange Senior Belt

Please log in to comment
0
Yes, PCTECH is a local account, as well as a domain account and I've tested both. I'm on one of the "Middle: Hubble" machines right now, and I can go to \\D5M4CYQ1\K1000 and it goes right in without any password.
Answered 03/15/2012 by: sfigg
Red Belt

Please log in to comment
0
I turned on debugging and this is what Is coming up (I'm just testing RUN NOW scripts to the actual K1000 Replication machine for debugging purposes since I can't VNC into machines right now to turn on debugging, etc. Still should work though)

parameter 'download_location' is missing a value

[Thu Mar 15 12:42:36 2012] runkbot ----- Starting runkbot.exe ["C:\Program Files\Dell\KACE\runkbot.exe" 434 1331833348r2]-----
[Thu Mar 15 12:42:36 2012] searchPath='C:\Program Files\Dell\KACE\;C:\ProgramData\Dell\KACE\;C:\windows\system32;C:\windows;C:\windows\System32\Wbem;C:\windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\Dell\DW WLAN Card;C:\Program Files\QuickTime\QTSystem\;C:\Program Files\Common Files\Roxio Shared\DLLShared\;C:\Program Files\Common Files\Roxio Shared\OEM\DLLShared\;C:\Program Files\Common Files\Roxio Shared\OEM\DLLShared\;C:\Program Files\Common Files\Roxio Shared\OEM\12.0\DLLShared\;C:\Program Files\Roxio\OEM\AudioCore\;C:\Program Files\Codebox\BitMeterOS;C:\Program Files\Windows Imaging\;C:\Program Files\Dell\KACE\;C:\ProgramData\Dell\KACE\;C:\Program Files\Dell\KACE\;C:\ProgramData\Dell\KACE\' envPath='C:\ProgramData\Dell\KACE\' tempPath='
[Thu Mar 15 12:42:36 2012] Logging to [C:\windows\TEMP\dklog2]
[Thu Mar 15 12:42:36 2012] Kbot [434-1331833348r2] not found locally, downloading ...
[Thu Mar 15 12:42:36 2012] DownloadFile: Downloaded C:\ProgramData\Dell\KACE\kbots_cache\434-1331833348r2.xml from http://kbox.cusd200.org/service/kbot_service_notsoap.php?METHOD=getkbot&KUID=FA9AB05D-DC76-4A26-A3BE-834D0BBE9782&KBOT_ID=434&KBOT_VERSION=1331833348r2&CLIENT_VERSION=5.3.47173 Download speed: 42096.000000 bytes/second
[Thu Mar 15 12:42:36 2012] FetchAndWriteToCache: kbot version changed from 1331833348r2 to 1331833300r2
[Thu Mar 15 12:42:36 2012] KLaunchProcess: Call KLaunchFlagsCmdArgs to launch '. -wait -hide KDeploy.exe -install -software_id="2883" -name="CoWriter 6" -install_cmd="C:\windows\System32\msiexec.exe /qn /i CoWriter6.msi" -download_location="" -checksum="794388ca8e2721694276f010671f8845" -flags="DZ"':
[Thu Mar 15 12:42:36 2012] KLaunch Computer Name is "D5M4CYQ1"
[Thu Mar 15 12:42:36 2012] KLaunch User Name is "SYSTEM"
[Thu Mar 15 12:42:36 2012] KLaunch Flags/Cmd/Args: ". -wait -hide KDeploy.exe -install -software_id="2883" -name="CoWriter 6" -install_cmd="C:\windows\System32\msiexec.exe /qn /i CoWriter6.msi" -download_location="" -checksum="794388ca8e2721694276f010671f8845" -flags="DZ""
[Thu Mar 15 12:42:36 2012] KLaunch Initiating local execute...
[Thu Mar 15 12:42:36 2012] KLaunch Locally exec "KDeploy.exe"
[Thu Mar 15 12:42:36 2012] KLaunch WaitNamedPipe for StdOut Pipe \\.\pipe\KLaunch_V1_StdOutD5M4CYQ15904
[Thu Mar 15 12:42:36 2012] KLaunch Start of ExecuteThread
[Thu Mar 15 12:42:36 2012] KLaunch WaitNamedPipe couldn't find StdOut Pipe \\.\pipe\KLaunch_V1_StdOutD5M4CYQ15904: (2) The system cannot find the file specified.


[Thu Mar 15 12:42:36 2012] KLaunch Command="KDeploy.exe" Args="-install -software_id="2883" -name="CoWriter 6" -install_cmd="C:\windows\System32\msiexec.exe /qn /i CoWriter6.msi" -download_location="" -checksum="794388ca8e2721694276f010671f8845" -flags="DZ"" WorkingDir="" Machine="D5M4CYQ1" UserName="" Domain="" Password=XXXX Priority=32 ProcessId=5904 Timeout=3600000 NoWait=0 KeepAlive=0 Interactive=0 Hide=1 NoStdio=0
[Thu Mar 15 12:42:36 2012] KLaunch WaitNamedPipe for StdErr Pipe \\.\pipe\KLaunch_V1_StdErrD5M4CYQ15904
[Thu Mar 15 12:42:36 2012] KLaunch *CreateNamedPipe StdOut Pipe \\.\pipe\KLaunch_V1_StdOutD5M4CYQ15904
[Thu Mar 15 12:42:36 2012] KLaunch WaitNamedPipe couldn't find StdErr Pipe \\.\pipe\KLaunch_V1_StdErrD5M4CYQ15904: (2) The system cannot find the file specified.


[Thu Mar 15 12:42:36 2012] KLaunch *CreateNamedPipe StdErr Pipe \\.\pipe\KLaunch_V1_StdErrD5M4CYQ15904
[Thu Mar 15 12:42:36 2012] KLaunch Don't WaitNamedPipe for StdIn Pipe (disabled)
[Thu Mar 15 12:42:36 2012] KLaunch *Don't CreateNamedPipe StdIn Pipe (disabled)
[Thu Mar 15 12:42:36 2012] KLaunch Pass 1 of 5 Timed out. Wait 1000 ms and try again.
[Thu Mar 15 12:42:36 2012] KLaunch *ConnectNamedPipe StdOut Pipe \\.\pipe\KLaunch_V1_StdOutD5M4CYQ15904
[Thu Mar 15 12:42:37 2012] KLaunch WaitNamedPipe for StdOut Pipe \\.\pipe\KLaunch_V1_StdOutD5M4CYQ15904
[Thu Mar 15 12:42:37 2012] KLaunch CreateFile StdOut Pipe \\.\pipe\KLaunch_V1_StdOutD5M4CYQ15904
[Thu Mar 15 12:42:37 2012] KLaunch WaitNamedPipe for StdErr Pipe \\.\pipe\KLaunch_V1_StdErrD5M4CYQ15904
[Thu Mar 15 12:42:37 2012] KLaunch *ConnectNamedPipe StdErr Pipe \\.\pipe\KLaunch_V1_StdErrD5M4CYQ15904
[Thu Mar 15 12:42:37 2012] KLaunch CreateFile StdErr Pipe \\.\pipe\KLaunch_V1_StdErrD5M4CYQ15904
[Thu Mar 15 12:42:37 2012] KLaunch Client start stdio redirection listen threads.
[Thu Mar 15 12:42:37 2012] haveTokenLsaPriv returning: 1
[Thu Mar 15 12:42:37 2012] KLaunch Start of ListenStdOut thread
[Thu Mar 15 12:42:37 2012] KLaunch Redirected Input Output Successful
[Thu Mar 15 12:42:37 2012] KLaunch Start of ListenStdErr thread
[Thu Mar 15 12:42:37 2012] KLaunch ExecuteAsCurrentUserOnDesktop
[Thu Mar 15 12:42:37 2012] searchPath='C:\Program Files\Dell\KACE\;C:\ProgramData\Dell\KACE\;C:\windows\system32;C:\windows;C:\windows\System32\Wbem;C:\windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\Dell\DW WLAN Card;C:\Program Files\QuickTime\QTSystem\;C:\Program Files\Common Files\Roxio Shared\DLLShared\;C:\Program Files\Common Files\Roxio Shared\OEM\DLLShared\;C:\Program Files\Common Files\Roxio Shared\OEM\DLLShared\;C:\Program Files\Common Files\Roxio Shared\OEM\12.0\DLLShared\;C:\Program Files\Roxio\OEM\AudioCore\;C:\Program Files\Codebox\BitMeterOS;C:\Program Files\Windows Imaging\;C:\Program Files\Dell\KACE\;C:\ProgramData\Dell\KACE\;C:\Program Files\Dell\KACE\;C:\ProgramData\Dell\KACE\' envPath=' tempPath='
[Thu Mar 15 12:42:37 2012] KLaunch Run as user "NT AUTHORITY\SYSTEM"
[Thu Mar 15 12:42:37 2012] haveTokenLsaPriv returning: 1
[Thu Mar 15 12:42:37 2012] KLaunch Execute command=[KDeploy.exe] args=[-install -software_id="2883" -name="CoWriter 6" -install_cmd="C:\windows\System32\msiexec.exe /qn /i CoWriter6.msi" -download_location="" -checksum="794388ca8e2721694276f010671f8845" -flags="DZ"]
[Thu Mar 15 12:42:37 2012] searchPath='C:\Program Files\Dell\KACE\;C:\ProgramData\Dell\KACE\;C:\windows\system32;C:\windows;C:\windows\System32\Wbem;C:\windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\Dell\DW WLAN Card;C:\Program Files\QuickTime\QTSystem\;C:\Program Files\Common Files\Roxio Shared\DLLShared\;C:\Program Files\Common Files\Roxio Shared\OEM\DLLShared\;C:\Program Files\Common Files\Roxio Shared\OEM\DLLShared\;C:\Program Files\Common Files\Roxio Shared\OEM\12.0\DLLShared\;C:\Program Files\Roxio\OEM\AudioCore\;C:\Program Files\Codebox\BitMeterOS;C:\Program Files\Windows Imaging\;C:\Program Files\Dell\KACE\;C:\ProgramData\Dell\KACE\;C:\Program Files\Dell\KACE\;C:\ProgramData\Dell\KACE\' envPath=' tempPath='
[Thu Mar 15 12:42:37 2012] KLaunch CreateProcessAsUser returned successfully
[Thu Mar 15 12:42:37 2012] KDeploy ----- Starting KDeploy.exe [KDeploy.exe -install -software_id="2883" -name="CoWriter 6" -install_cmd="C:\windows\System32\msiexec.exe /qn /i CoWriter6.msi" -download_location="" -checksum="794388ca8e2721694276f010671f8845" -flags="DZ"]-----


[Thu Mar 15 12:42:37 2012] KDeploy ERROR - parameter 'download_location' is missing a value


[Thu Mar 15 12:42:37 2012] KLaunch End of ExecuteThread
[Thu Mar 15 12:42:38 2012] KLaunch Local command returned -1(0xFFFFFFFF)
[Thu Mar 15 12:42:38 2012] KLaunchProcess: KLaunchFlagsCmdArgs completed exitCode=-1
[Thu Mar 15 12:42:38 2012] runkbot : Failed to launch KDeploy.exe process: -1
[Thu Mar 15 12:42:38 2012] KLaunchProcess: Call KLaunchFlagsCmdArgs to launch '. -wait -hide KDeploy.exe -install -software_id="2883" -name="CoWriter 6" -install_cmd="C:\windows\System32\msiexec.exe /qn /i CoWriter6.msi" -download_location="" -checksum="794388ca8e2721694276f010671f8845" -flags="DZ"':
[Thu Mar 15 12:42:38 2012] KLaunch Computer Name is "D5M4CYQ1"
[Thu Mar 15 12:42:38 2012] KLaunch User Name is "SYSTEM"
[Thu Mar 15 12:42:38 2012] KLaunch Flags/Cmd/Args: ". -wait -hide KDeploy.exe -install -software_id="2883" -name="CoWriter 6" -install_cmd="C:\windows\System32\msiexec.exe /qn /i CoWriter6.msi" -download_location="" -checksum="794388ca8e2721694276f010671f8845" -flags="DZ""
[Thu Mar 15 12:42:38 2012] KLaunch Initiating local execute...
[Thu Mar 15 12:42:38 2012] KLaunch Locally exec "KDeploy.exe"
[Thu Mar 15 12:42:38 2012] KLaunch WaitNamedPipe for StdOut Pipe \\.\pipe\KLaunch_V1_StdOutD5M4CYQ15904
[Thu Mar 15 12:42:38 2012] KLaunch Start of ExecuteThread
[Thu Mar 15 12:42:38 2012] KLaunch Command="KDeploy.exe" Args="-install -software_id="2883" -name="CoWriter 6" -install_cmd="C:\windows\System32\msiexec.exe /qn /i CoWriter6.msi" -download_location="" -checksum="794388ca8e2721694276f010671f8845" -flags="DZ"" WorkingDir="" Machine="D5M4CYQ1" UserName="" Domain="" Password=XXXX Priority=32 ProcessId=5904 Timeout=3600000 NoWait=0 KeepAlive=0 Interactive=0 Hide=1 NoStdio=0
[Thu Mar 15 12:42:38 2012] KLaunch *CreateNamedPipe StdOut Pipe \\.\pipe\KLaunch_V1_StdOutD5M4CYQ15904
[Thu Mar 15 12:42:38 2012] KLaunch CreateFile StdOut Pipe \\.\pipe\KLaunch_V1_StdOutD5M4CYQ15904
[Thu Mar 15 12:42:38 2012] KLaunch *CreateNamedPipe StdErr Pipe \\.\pipe\KLaunch_V1_StdErrD5M4CYQ15904
[Thu Mar 15 12:42:38 2012] KLaunch WaitNamedPipe for StdErr Pipe \\.\pipe\KLaunch_V1_StdErrD5M4CYQ15904
[Thu Mar 15 12:42:38 2012] KLaunch *Don't CreateNamedPipe StdIn Pipe (disabled)
[Thu Mar 15 12:42:38 2012] KLaunch CreateFile StdErr Pipe \\.\pipe\KLaunch_V1_StdErrD5M4CYQ15904
[Thu Mar 15 12:42:38 2012] KLaunch *ConnectNamedPipe StdOut Pipe \\.\pipe\KLaunch_V1_StdOutD5M4CYQ15904
[Thu Mar 15 12:42:38 2012] KLaunch Don't WaitNamedPipe for StdIn Pipe (disabled)
[Thu Mar 15 12:42:38 2012] KLaunch *ConnectNamedPipe StdErr Pipe \\.\pipe\KLaunch_V1_StdErrD5M4CYQ15904
[Thu Mar 15 12:42:38 2012] KLaunch Client start stdio redirection listen threads.
[Thu Mar 15 12:42:38 2012] KLaunch Redirected Input Output Successful
[Thu Mar 15 12:42:38 2012] haveTokenLsaPriv returning: 1
[Thu Mar 15 12:42:38 2012] KLaunch Start of ListenStdOut thread
[Thu Mar 15 12:42:38 2012] KLaunch Start of ListenStdErr thread
[Thu Mar 15 12:42:38 2012] KLaunch ExecuteAsCurrentUserOnDesktop
[Thu Mar 15 12:42:38 2012] searchPath='C:\Program Files\Dell\KACE\;C:\ProgramData\Dell\KACE\;C:\windows\system32;C:\windows;C:\windows\System32\Wbem;C:\windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\Dell\DW WLAN Card;C:\Program Files\QuickTime\QTSystem\;C:\Program Files\Common Files\Roxio Shared\DLLShared\;C:\Program Files\Common Files\Roxio Shared\OEM\DLLShared\;C:\Program Files\Common Files\Roxio Shared\OEM\DLLShared\;C:\Program Files\Common Files\Roxio Shared\OEM\12.0\DLLShared\;C:\Program Files\Roxio\OEM\AudioCore\;C:\Program Files\Codebox\BitMeterOS;C:\Program Files\Windows Imaging\;C:\Program Files\Dell\KACE\;C:\ProgramData\Dell\KACE\;C:\Program Files\Dell\KACE\;C:\ProgramData\Dell\KACE\' envPath=' tempPath='
[Thu Mar 15 12:42:38 2012] KLaunch Run as user "NT AUTHORITY\SYSTEM"
[Thu Mar 15 12:42:38 2012] haveTokenLsaPriv returning: 1
[Thu Mar 15 12:42:38 2012] KLaunch Execute command=[KDeploy.exe] args=[-install -software_id="2883" -name="CoWriter 6" -install_cmd="C:\windows\System32\msiexec.exe /qn /i CoWriter6.msi" -download_location="" -checksum="794388ca8e2721694276f010671f8845" -flags="DZ"]
[Thu Mar 15 12:42:38 2012] searchPath='C:\Program Files\Dell\KACE\;C:\ProgramData\Dell\KACE\;C:\windows\system32;C:\windows;C:\windows\System32\Wbem;C:\windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\Dell\DW WLAN Card;C:\Program Files\QuickTime\QTSystem\;C:\Program Files\Common Files\Roxio Shared\DLLShared\;C:\Program Files\Common Files\Roxio Shared\OEM\DLLShared\;C:\Program Files\Common Files\Roxio Shared\OEM\DLLShared\;C:\Program Files\Common Files\Roxio Shared\OEM\12.0\DLLShared\;C:\Program Files\Roxio\OEM\AudioCore\;C:\Program Files\Codebox\BitMeterOS;C:\Program Files\Windows Imaging\;C:\Program Files\Dell\KACE\;C:\ProgramData\Dell\KACE\;C:\Program Files\Dell\KACE\;C:\ProgramData\Dell\KACE\' envPath=' tempPath='
[Thu Mar 15 12:42:38 2012] KLaunch CreateProcessAsUser returned successfully
[Thu Mar 15 12:42:38 2012] KDeploy ----- Starting KDeploy.exe [KDeploy.exe -install -software_id="2883" -name="CoWriter 6" -install_cmd="C:\windows\System32\msiexec.exe /qn /i CoWriter6.msi" -download_location="" -checksum="794388ca8e2721694276f010671f8845" -flags="DZ"]-----


[Thu Mar 15 12:42:38 2012] KDeploy ERROR - parameter 'download_location' is missing a value


[Thu Mar 15 12:42:38 2012] KLaunch End of ExecuteThread
[Thu Mar 15 12:42:38 2012] KLaunch Local command returned -1(0xFFFFFFFF)
[Thu Mar 15 12:42:38 2012] KLaunchProcess: KLaunchFlagsCmdArgs completed exitCode=-1
[Thu Mar 15 12:42:38 2012] runkbot : Failed to launch KDeploy.exe process: -1
[Thu Mar 15 12:42:38 2012] Uploading Log file [C:\windows\TEMP\dklog2]
[Thu Mar 15 12:42:38 2012] DownloadFile: Downloaded C:\windows\TEMP\dklog3 from http://kbox.cusd200.org/service/kbot_service_notsoap.php?METHOD=getuploadpath&KUID=FA9AB05D-DC76-4A26-A3BE-834D0BBE9782&FILENAME=KBOT_LOG.txt Download speed: 6516.000000 bytes/second
[Thu Mar 15 12:42:38 2012] UploadFile: Uploaded to http://kbox.cusd200.org/service/kbot_upload.php?machineId=3739&filename=KBOT_LOG.txt&checksum=e058f86a03c79b024234b55eec0cb2d9&mac=FA9AB05D-DC76-4A26-A3BE-834D0BBE9782 Upload speed: 1718.000000 bytes/second
[Thu Mar 15 12:42:38 2012] Cleaning up log file [C:\windows\TEMP\dklog2]

[Thu Mar 15 12:42:38 2012] runkbot ----- Exiting runkbot.exe -----
Answered 03/15/2012 by: sfigg
Red Belt

Please log in to comment
0
This is from the kdeploy log:

[Thu Mar 15 15:39:38 2012] KDeploy ----- Starting KDeploy.exe [KDeploy.exe -install -software_id="2883" -name="CoWriter 6" -install_cmd="C:\windows\System32\msiexec.exe /qn /i CoWriter6.msi" -download_location="" -checksum="794388ca8e2721694276f010671f8845" -flags="DZ"]-----
[Thu Mar 15 15:39:38 2012] KDeploy ERROR - parameter 'download_location' is missing a value
Answered 03/15/2012 by: sfigg
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity