If we install a application for a user from his machine using admin privelleges. Application repair on first launch even on same machine.
Also applications contains user registries and shortcut are advertised.

But why does it repairs as installation is done for same machine using admin privelleges.
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Also applications contains user registries.This is a TINY clue...
Answered 09/08/2010 by: VBScab
Red Belt

Please log in to comment
0
I mean to say that application contains a user data and shortcuts are advertised.
It repairs on first launch for the user, but the problem is that the application is installed for the same user using admin privelleges.
Answered 09/08/2010 by: rupya1983
Senior Yellow Belt

Please log in to comment
0
for the same user using admin privelleges

and with this same user's credentials?

if this is on XP, look at the eventvwr log, you'll find Windows Installer events telling you which component in your msi is triggering the repair.
(I miss that on Windows 7 btw, anyone know if I can get it back?)

PJ
Answered 09/08/2010 by: pjgeutjens
Red Belt

Please log in to comment
0
yes it was tigerring for the component that contains user registries.

problem is that why it was repairing for the same user, because instalation is done for the same user using admin credentials.
Answered 09/08/2010 by: rupya1983
Senior Yellow Belt

Please log in to comment
0
Do you mean that you have a user logged in and you then install using something like 'Run As...'? If so, then that won't install the user components for the logged-in user, but for the account you used to install.

Or do you mean that the repair is happening every time the same user logs in, not just the first time?
Answered 09/08/2010 by: VBScab
Red Belt

Please log in to comment
0
Better to check in Event Viewer for the Error or warning. Probably some user specific component or components are broken.
Answered 09/08/2010 by: er.hsingh
Orange Senior Belt

Please log in to comment
Answer this question or Comment on this question for clarity