Hi,

I have some post configuration in which registry values are getting updated with server entry.When i export the registry the value comes as below,

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\vendor_name\application_name\server_names]
"server_names"="abc.cd.ef 100.100.56.100
abc-cd.ef.gh 100.200.500.55
"
When i import the registry the values are not getting imported as spaces are there.

But the actual registry value in the regedit will be in single line,

server_names=abc.cd.ef 100.100.56.100abc-cd.ef.gh 100.200.500.55

This affects the functionality of the application.please suggest.
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Try to append reg with vbscript and use it as a custom action in your msi
use the command WshShell.RegWrite
Answered 05/12/2011 by: rajdera1
Orange Belt

Please log in to comment
0
Is it a MULTI-STRING type of registry? After exporting, if you import without altering the string, I don't see any reason for you to get error.
Answered 05/12/2011 by: murali.bhat
Purple Belt

Please log in to comment
0
Its a String Value only.Am not getting any error while reporting, but the values are not getting imported.I guess it may be due to hexa decimal values.
Answered 05/12/2011 by: re_123
Senior Yellow Belt

Please log in to comment
0
Probably. Try adding hex in the beginning.

"server_names"=hex(7):
Answered 05/12/2011 by: murali.bhat
Purple Belt

Please log in to comment
0
I imported the registry as we use to import the files from the physical location.It worked out.[:)].

Thanks For the help.
Answered 05/12/2011 by: re_123
Senior Yellow Belt

Please log in to comment
0
Hi am working Microsoft outlook add inn 2007 .when i launched outlook first it will go for reboot .as per our company standard i have to suppress that any one help me out
Answered 05/12/2011 by: vinayak.msi
Yellow Belt

Please log in to comment
0
Vinayak - Your question is irrelevant to the subject line and to the previous thread started by re_123. Please start a new thread.
Answered 05/12/2011 by: murali.bhat
Purple Belt

Please log in to comment
Answer this question or Comment on this question for clarity