Hi,

I have packaged SMS Add-in For Microsoft Excel.when i Install it with administrator and Local User ID it works fine for all users but not for standard user. When i login using a standard user i get "Registry editing is been disabled by your administrator". I have created Active setup which install registry keys to HKCU. As soon as i Login using a standard user account i get a window "Registry editing is been disabled by your administrator". How can i make this work.

Please help. I need to solve this asap.

Thanks
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
.when i Install it with administrator and Local User ID it works fine for all users but not for standard user.

What do you mean by this ?
Answered 05/05/2010 by: mekaywe
Brown Belt

Please log in to comment
0
Hi Rachitha

Are you able to edit the HKCU registry keys manually when you are logged in standard user?
Answered 05/05/2010 by: joseph
Orange Belt

Please log in to comment
0
Registry editing is been disabled by your administrator

This sounds to me like a domain level user policy being enforced. If by Local User you mean a non-domain user, or admin user, that's another indication.

First of all, let loose ProcMon on your excel addin, look for ACCESS DENIED messages to identify exactly which key is supposed to be written.
Secondly, about the policy, have a talk with your AD admins.
Finally, which method are you using to write the HKCU keys? If you are for example triggering a REG or REGEDIT /S command this might fall under the above mentioned policy, there might be other methods that do get through (VBS / MSI)

PJ
Answered 05/05/2010 by: pjgeutjens
Red Belt

Please log in to comment
0
I am not able to edit registry manually also.
I used Regedit /s "MyFile.reg" in ACTIVE Setup.
This user ID is a non-admin user.
Answered 05/06/2010 by: Rachitha.pb
Senior Yellow Belt

Please log in to comment
0
Hi Rachitha,

If you are not able to edit manually , then you cannot import those HKCU keys with either regedit /s or vbs.
I guess it depends upon your group policies.
Answered 05/06/2010 by: joseph
Orange Belt

Please log in to comment
0
I used Regedit /s "MyFile.reg" in ACTIVE Setup

pretty sure that's the cause of your problem. The policy springs into action when you run regedit.exe

try writing a vbs to write your regkeys and putting that in the Active Setup
Answered 05/06/2010 by: pjgeutjens
Red Belt

Please log in to comment
0
If I write a vbs also the entry has to go to registry only right?
then it will give the same error.

So do you think there is no solution to this issue apart from aksing the admin to give permissions?
Answered 05/06/2010 by: Rachitha.pb
Senior Yellow Belt

Please log in to comment
0
pjgeutjens,

Yes, I do accept this , without running regedit.exe , we can use vbs script to import these..
Answered 05/06/2010 by: joseph
Orange Belt

Please log in to comment
0
Joseph,

I was actually not 100% sure after reading your post, so I did a quick test (we have similar policy here) [:D]

putting a VBS on restricted user's desktop that contains Set oShell = WScript.CreateObject("WScript.Shell")
oShell.RegWrite "HKCU\Software\Test","test"
User could run the vbs and the key was written.

A Batch file (as close as I could get on short notice) containing REGEDIT caused the forementioned error

PJ
Answered 05/06/2010 by: pjgeutjens
Red Belt

Please log in to comment
0
I tried to import reg files through vbs i get the same. Rigistry editing has been disabled by your administrator.
Answered 05/06/2010 by: Rachitha.pb
Senior Yellow Belt

Please log in to comment
0
As said above use "RegWrite" command in your VBS which should write the HKCU keys
Answered 05/06/2010 by: mekaywe
Brown Belt

Please log in to comment
0
Hi,
Can you please help. Im not much aware of the vbs.

this is my registry keys.

REGEDIT4

[HKEY_CURRENT_USER\Software]
"+"=""

[HKEY_CURRENT_USER\Software\Classes\Interface\{000C0601-0000-0000-C000-000000000046}]
"(Default)"="Word/Excel .NET 2.0 Lockback Bypass Key"
"+"=""

[HKEY_CURRENT_USER\Software\Microsoft]
"+"=""

[HKEY_CURRENT_USER\Software\Microsoft\Office]
"+"=""

[HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Excel\Answer Wizard]
"PluginsAW"="C:\\Program Files\\2sms.com\\SMS Add-in for Microsoft Excel\\ExcelSMS.aw"

[HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Excel\Answer Wizard]
"PluginsAW"="C:\\Program Files\\2sms.com\\SMS Add-in for Microsoft Excel\\ExcelSMS.aw"

[HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Excel\Answer Wizard]
"PluginsAw"="C:\\Program Files\\2sms.com\\SMS Add-in for Microsoft Excel\\ExcelSMS.aw"

[HKEY_CURRENT_USER\Software\Microsoft\Office\Excel]
"+"=""

[HKEY_CURRENT_USER\Software\Microsoft\Office\Excel\AddIns]
"+"=""

[HKEY_CURRENT_USER\Software\Microsoft\Office\Excel\AddIns\ExcelSMSAddin.Connect]
"*"=""
"Description"="ExcelSMSAddin.Connect"
"Description"="SMS Messaging for Microsoft Excel"
"FriendlyName"="ExcelSMSAddin.Connect"
"FriendlyName"="SMS Add-in for Microsoft Excel"
"LoadBehavior"=dword:00000003
"LoadBehavior"=dword:00000003

[HKEY_CURRENT_USER\Software\Microsoft\Windows]
"+"=""

[HKEY_CURRENT_USER\Software\Microsoft\Windows\HTML Help]
"+"=""
"ExcelSMS.chm"="C:\\Program Files\\2sms.com\\SMS Add-in for Microsoft Excel"
Answered 05/06/2010 by: Rachitha.pb
Senior Yellow Belt

Please log in to comment
0
Well, now seems like a good time to learn. You won't get very far in the packaging world without knowing VBS. It really isn't that hard. Take a look at script examples and take it from there.
Answered 05/06/2010 by: VBScab
Red Belt

Please log in to comment
0
Hi Rachitha,

Below is the example , u can modify according to your requirement.

Option Explicit
Dim SysVarReg, Value
Value = "1234567890"
Set SysVarReg = WScript.CreateObject("WScript.Shell")
SysVarReg.RegWrite "HKCU\Software\AppName\Valuename\TEST", Value

Thanks,
Joseph.
Answered 05/06/2010 by: joseph
Orange Belt

Please log in to comment
0
Thank you guys,

I could write the script. My problem is solved... My application is working fine now
Answered 05/06/2010 by: Rachitha.pb
Senior Yellow Belt

Please log in to comment
0
if you don't like VBS (although it's the best thing to use in this case) you could try using the Reg command.

Reg add should do the trick
Answered 05/06/2010 by: timmsie
Fourth Degree Brown Belt

Please log in to comment
Answer this question or Comment on this question for clarity