Has anyone successfully deployed Apple's Quicktime player 7.1.5? I have the QuickTime.MSI from QuickTimeInstaller.exe version 7.1.5.120 (just copied out of %TEMP%) and this thing will just not deploy via GPO. All it's predecessors do, but this one - nope. It attaches to the GPO, but then on boot nothing happens, not even a mention in app event log - never ever seen anything like this. I've downloaded it a couple times, tried different MSIs with the same GPO (no problem) but when I attach 7.1.5 I get no joy. The MSI (and MST I've made) install just fine with an MSIEXEC statement, but as I say - I cannot get GPO to push it. Any ideas - or can anyone tell me whether they've successfully gotten 7.1.5 installing via GPO?

0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Answers

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.
0

I am having the same problem. I hope someone has some help with this.

Answered 03/20/2007 by: jfrasier
Sixth Degree Black Belt

Please log in to comment
4

I will bet you have a language issue... I ran into the same problem... more on that in a minute.  First, here's the process I did:
Downloaded QuickTimeInstaller.exe from the apple website
Cleaned out my temp folder
"started" an install of quicktime
grabbed the QuickTime.msi from the newly created folder in my temp folder

Used the ORCA tool to create the following TRANSFORM:
Property Table:
REGSRCH_INSTALL_ASU = 0
DESKTOP_SHORTCUTS = 0
QTINFO.BISQTPRO = 1

Registry Table:
Added an entry to ensure that the Taskbar icon never showed up...
Registry = NoTaskIcon (Some Unique Key -- Whatever name you pick)
Root = 2
Key = SOFTWARE\Apple Computer, Inc.\QuickTime\ActiveX
Name = QTTaskRunFlags
Value = #2
Component = QTPlugin.ocx

Shortcut Table:
Removed the QuickTimePlayer_Desktop entry (Because I don't believe programs should put shortcuts on the desktop).

HERE'S THE GROUP POLICY TRICK
Method 1 (The workaround I discovered): When you add the package through Group Policy, you'll have a tab that is titled 'Deployment'.  Click that and then click advanced.  Check the box that says 'Ignore language when deploying this package.'  This is because (as I'll explain in a minute), that Quicktime 7_1_5_120 defaults to the Chinese Language!  This workaround will get the program to install okay (really, your system is rejecting the package because it doesn't believe the Chinese program should install on an English system.  I know, it seems contrary to logic since there is an entry in the Property table for 1033 (english language), but unfortunately, that is the case.  This is the method I used to get 7_1_3_100 installed on my systems.

Method 2 (A BETTER VERSION): If you open up the QuickTime.msi package through ORCA (DON"T START A TRANSFORM FOR THIS STEP), then immediately click on 'View->Summary Information.  (If you have already started a blank transform, you will be unable to edit the package information.)  You'll notice the supported languages are something like, 1033,1036,1031,1041,1043,1040,2052,1034,1030,1035,1042,1044,1053,1028.  Remove them all but 1033 -- English.  Then save the msi overtop of itself (another thing I absolutely hate doing, but it is required this time).  This method will cleanly get the English version to install through GP happily.  :)  I used this method for getting 7_1_5_120 on my systems.

You should rate this post, it was a triumphant discovery!  :)
-David

Answered 03/21/2007 by: dlernstrom
Senior Yellow Belt

Please log in to comment
0

Thanks for the detailed reply. I did try both of the language ideas you gave with no success. I had found that information somewhere on this site -- maybe even from you. If I ever get a basic install to work I know the ideas about the transform will be used so I appreciate that.

I am beginning to think there is something larger happening here as I also can't get an adobe acrobat reader install to work. Again, neither install even seems to be recognized by the workstations because there are no entries about it in the eventviewer.

Thanks again.

Jane

Answered 03/21/2007 by: jfrasier
Sixth Degree Black Belt

Please log in to comment
0

Here's a couple of quick thoughts...
If you are installing the software on a per machine basis, make sure the software is in the 'Computer' section of the GPO.  Also make sure that the appropriate target (authenticated users/machine names/etc) have Read & Apply Group Policy security permissions.

The most useful thing I would suggest is to do a 'Resultant Set of Policy' on the particular machine for a username and see if your given machine/username combination will be affected by your GPO.  If you haven't ever done a RSOP, it basically gives you a Group Policy-like window that shows you the sum-total of what settings the machine will eventually have.  If you perform a RSOP and don't see your package listed, then there is a problem with how you've put the package into Active Directory.

-David

Answered 03/21/2007 by: dlernstrom
Senior Yellow Belt

Please log in to comment
0

I hate to be such a newbie, but we all were once...

I did put it in the computer section and put the computer in the OU. I don't understand where I am supposed to do the part about 'have Read & Apply Group Policy security permissions.

Answered 03/21/2007 by: jfrasier
Sixth Degree Black Belt

Please log in to comment
0

Regarding the 'Read' and 'Apply Group Policy' sections:
1) Right click on your OU, left click on properties.
2) left click on the Group Policy tab.
3) Right click on the Group Policy Object you created, left click on properties
4) left click on the security tab

Check to make sure whatever machines/individuals are either listed here explicitly or collectively as appropriate.  For instance, a group policy applying to everything beneath your chosen OU tier could be represented by 'Authenticated Users' having 'Read' and 'Apply Group Policy' options checked.  If you only want it to apply to one machine in that OU, click on the 'Add' button, make sure 'Computers' is included as an Object Type, and then enter the machine name in the blank.

---------------------------------------

Did you run a Resultant Set of Policy yet?  Right click on a given machine within the OU (or on the OU itself) and go to All Tasks.  RSOP Logging represents the system as it currently is, RSOP Planning allows you to specify what potential changes you are about to make to analyze the impact of those changes.  You probably ought to do 'Logging' since you have already implimented your changes.

Answered 03/22/2007 by: dlernstrom
Senior Yellow Belt

Please log in to comment
0

Hi fostkey,
yes, did the rollout this week. We even have the update function on, which will remove Versions like 7.03 and 7.04.
As David already stated, alter the language field on the 'Summary Information' dialog. This affects only the language of the Readme file (and the dialogs, which you wont see with GPO install).

If this still doesn't help, switch on MSI logging on the client (can easely be done via Group Policy).
Try the install again.
After that, go the %windir%\temp folder and look for log files.

Really make sure, that the computer account of the target machine has the right to 'Apply Group Policy'

Run 'gresult /z' on the clients command line and look for your GPO being there.

And finally, have a look at this KB article:
http://support.microsoft.com/kb/840669/en-us

Have lost hours and hours of time, because of this issue!

Regards, Nick

Oops, there's a typo: The command is: gpresult /z :-)

Answered 03/22/2007 by: nheim
Tenth Degree Black Belt

Please log in to comment
0

dLernstrom -- thanks. I did that. Still nothing and the rsop does not show that it is getting the information to install the program.

Nick -- thanks for some more ideas. I will look at those.

You guys are great.

Jane

Answered 03/22/2007 by: jfrasier
Sixth Degree Black Belt

Please log in to comment
0

I ran the gpresult and it shows that GP was applied but  the GPO for installing QT was not listed.

I looked at that article and thought ah-ha since our network is 1GB. I added the registry entry listed in that article and even set it for the longest amount of time but it still didn't work. We do get that userenv error about not being able to contact the domain fairly often.

Any more ideas? I have spent hours and hours of time on this.

Jane

Answered 03/22/2007 by: jfrasier
Sixth Degree Black Belt

Please log in to comment
0

Jane,

Don't look at nothing showing on the RSOP as being a discouraging find!  That is actually the most helpful thing you can discover, because that tells you that your active directory structure is preventing the particular group policy from applying to the machine.

Other things I would check is if your new GPO is disabled.  I disable GPOs while I configure them so that they don't get pushed out until I know they are right.  The last step I make before I consider them done is to un-disable the policy.

It has been also suggested to disable either the Computer Configuration or the User Configuration of a Group Policy to optimize the systems applying policy, for example if your policy only applies to computers, disable the user part of the policy.  Perhaps you have disabled the computer policy half.

I don't think the gpresult would show anything that RSOP didn't already discover -- that the machine is not receiving the policy.

Answered 03/22/2007 by: dlernstrom
Senior Yellow Belt

Please log in to comment
0

I also don't think the KB article would apply to your situation since the RSOP would have contacted the machine to query what policy it knew about.

Your RSOP (logging) proved that your target system is not receiving the policy at all.  The machine was contacted by the DC in order to generate this report.

You could take the specific target machine directly out of the equation by doing a RSOP (planning) on the entire OU to see if your new group policy applies to any machines in the OU.  RSOP planning can run against an entire OU/Container (provided you are sending it out to all 'Authenticated Users').

Are you trying to deploy the software to all users within the OU or just to target machines?

-David

Answered 03/22/2007 by: dlernstrom
Senior Yellow Belt

Please log in to comment
0

Right now I have assigned the software in the computer configuration and have only put my test computer in there. The ultimate goal is to send it to all computers for all users. Many of our computers are shared.

I checked and the GPO was enabled. I did disable the user part. The RSOP does show 3 GPOs-Default Domain Policy, Password Policy and one I made so that IE7 would not be offered.

Answered 03/22/2007 by: jfrasier
Sixth Degree Black Belt

Please log in to comment
0

I just ran the RSOP on the OU container and it does not show the GPO for installing QT

Answered 03/22/2007 by: jfrasier
Sixth Degree Black Belt

Please log in to comment
0

I just did a little test where I created a brand new empty group policy in my OU and then ran "C:\Windows\System32\gpresult /z > c:\output.txt" (Piped my output into a file rather than the screen because the output was huge).  There is a section that looked something like this:

USER SETTINGS
--------------
    CN=ADMINDLE,OU=_Testing,DC=MYDC
    Last time Group Policy was applied: 3/22/2007 at 11:55:49 AM
    Group Policy was applied from:      MYDC
    Group Policy slow link threshold:  500 kbps

    Applied Group Policy Objects
    -----------------------------
        New Group Policy Object


This told me that the BRAND NEW Group Policy still showed up without any modifications.  Testing whether or not a brand new Group Policy Object shows up in this list would remove anything Quicktime related from the equation.

Tell me if a blank 'New Group Policy Object' shows up in your gpresult.

Answered 03/22/2007 by: dlernstrom
Senior Yellow Belt

Please log in to comment
0

Boy do I feel stupid! [&o]

I was trying your blank new policy and discovered that I had created my InstallQT GPO but had not linked it to the OU!!!!

Thanks so much. I haved really checked to see how QT is but I did see that it was doing an install.

In a way I was hoping hoping it was some sort of screwy AD thing and that one of you would have the answer and it would solve ALL of our network related problems.  LOL

Thanks again.

Jane

Answered 03/22/2007 by: jfrasier
Sixth Degree Black Belt

Please log in to comment
0

No worries.  I have found a lot of answers to my AD/GP goofs through AppDeploy and so it is good that somebody else is also sufficiently helped.

Haven't heard anything from fosteky on whether or not his issue was resolved.

Jane or fosteky, let us know if there are any other problems with QT.

Answered 03/22/2007 by: dlernstrom
Senior Yellow Belt

Please log in to comment
0

It worked great on the test computer in my office. Then I tried it at another location, with the source of the msi as a server in my building. It did not work, and because of our vlan I thought that was the problem. I then copied the .msi and .mst to a computer that this other computer could see, gave auth. users permissions to that folder. I removed the GPO from before and made a new one pointing to this new source.

When I restarted the computer, nothing. I did a gpresult and it said that it DIDN'T get the GPO yet in the software installation section it was there with the remote server. I ran a gpupdate /force and same thing. I have rebooted the computer many time. I don't know how to 'tell it' to get the files from the local server. It is really not a server, but that shouldn't matter, should it? I checked the DC that it was logging into to be sure that AD was replicated.

Their were not log files or eventviewer messages about the install except yesterday when I was doing it from the remote server (which happens to be a DC).

Any ideas?

Thanks
Jane

Answered 03/23/2007 by: jfrasier
Sixth Degree Black Belt

Please log in to comment
0

Just a thought but have you given "Domain Computers" read permissions to your server share folder?

Also, check your application log in Event Viewer on the PC.  If the MSI is being applied but there are errors they should show up there.

A quick note to dlernstrom.  Awesome fix for the QuickTime msi.  I would never have thought to edit the language options in the MSI.  Cheers, it did the job.

Answered 03/23/2007 by: rodt99
Orange Belt

Please log in to comment
0

That is a great idea, rod. I haven't done that. I am working in a library environment and now can't work on that computer because we are open but I will try it when we close this afternoon.

Jane

Answered 03/23/2007 by: jfrasier
Sixth Degree Black Belt

Please log in to comment
0

Wow, this string really multiplied since I've been gone for the week (was ill) and I'm just getting back now. So just a couple comments:
1) all the GPO software deployment advice - it's appreciated but I know GPO software deployment backwards and forwards now, it's nothing simple like that.
2) the advice about the language - that rings true. I recall having a very similar issue with Macromedia's Fireworks 8, which wanted to install in a Chinese language setting, and once I set the GPO to ignore language it worked. I look forward to trying the direct edit on the QT MSI - I figure if the vendor delivers such a screwed up MSI why treat it like a normal vendor MSI. I'll respond with results and hopefully some kudos.

Thanks....

Answered 03/26/2007 by: fosteky
Purple Belt

Please log in to comment
0

Fosteky -- I hope that works for you.

I am still having trouble. I made sure that domain computers have read permission to the GPO and that apply group policy is checked.

This is what I saw on one computer today when I did gpresult /z

Applied group policy section included the InstallQuicktime GPO

but under Software Installations in RSPO, it says NA.

There was no mention of installation in the eventviewer. Do you have any other ideas?

Jane

Answered 03/26/2007 by: jfrasier
Sixth Degree Black Belt

Please log in to comment
0

OK, here is another one.

I tried installing quicktime on another computer and it didn't work. When I ran gpresult I got:

The computer is a part of security groups:
NULL SID
NT Authority\Network

This sounds like a bad thing to me.

Jane

Answered 03/27/2007 by: jfrasier
Sixth Degree Black Belt

Please log in to comment
0

Hi Jane,
this looks to me, as some group memberships aren't resolved properly.
First of all, i would try to rejoin this machine to the domain and see, if this behavior remains.
See: http://technet2.microsoft.com/WindowsServer/en/library/5dbc99be-7404-41a6-9be7-171d40c398db1033.mspx?mfr=true
Regards, Nick

Answered 03/27/2007 by: nheim
Tenth Degree Black Belt

Please log in to comment
0

Thanks for the pointer toward the language problem, setting the GPO to ignore language resulted in the GPO finally pushing the MSI and MST at least, but of course in the last language on that list. So I direct edited the MSI with ORCA per David Ernstrom's advice and am now pleased with the result.

Answered 03/27/2007 by: fosteky
Purple Belt

Please log in to comment
0

I got this to work via GPO pretty nicely with the edits using ORCA.

Anyone know what table to change to have this install in the Program Files\Accessories Folder instead of just "Program Files"?  or to just take it out as a start menu folder all-together may be a good option

anyone? bueller?

-J

Answered 04/17/2007 by: mcburn13
Senior Yellow Belt

Please log in to comment
0

The shortcuts are all created via the Directory Table in conjunction with the Shortcut Table.

To remove the entries entirely, you'll want to delete the 4 entries in the shortcut table and also delete the entry in the Directory table called 'QuickTimeProgramMenuFolder'.

The process of dumping the 4 QT shortcuts into the Programs->Accessories folder is as simple as editing the Directory Table by modifying the following entry:
Directory: QuickTimeProgramMenuFolder
Directory Parent: ProgramMenuFolder
DefaultDir: ACCESS~1|Accessories

A more elegant way would be to create the following Directory Table entry:
Directory: AccessoriesFolder
DirectoryParent: ProgramMenuFolder
DefaultDir: ACCESS~1|Accessories
------AND MODIFY the following entry:-------
Directory: QuickTimeProgramMenuFolder
Directory Parent: AccessoriesFolder
DefaultDir: QT|QuickTime

The latter solution would give you a QuickTime folder within the accessories folder to house your shortcuts.

-David

-------------------------------------------------------------------------------------------------
Edit: 4/17/07 1:30 PM
The above solution doesn't work due to Apple's Custom Actions.  Look at a following post for one that accomplishes the same thing.
-David

Answered 04/17/2007 by: dlernstrom
Senior Yellow Belt

Please log in to comment
0

I did this:
A more elegant way would be to create the following Directory Table entry:
Directory: AccessoriesFolder
DirectoryParent: ProgramMenuFolder
DefaultDir: ACCESS~1|Accessories
------AND MODIFY the following entry:-------
Directory: QuickTimeProgramMenuFolder
Directory Parent: AccessoriesFolder
DefaultDir: QT|QuickTime

It still installed into the program files folder instead of its subfolder Accessories.
Any suggestions?

Answered 04/17/2007 by: mcburn13
Senior Yellow Belt

Please log in to comment
0

Well... it WOULD have worked if Apple had of followed standard procedure of MSI development.

However, after a brief investigation, I discovered that apple is overwriting those parameters in their custom actions.  You will be able to accomplish what you are after by making the following modification to the CUSTOMACTION table (ignore my previous suggestion on how to move the shortcuts):

Action: Set_PROGRAMMENUNAME
Type: 307
Source: PROGRAMMENUNAME
Target: Accessories\QuickTime\

I did test this and know it works.

Incidentally, looking at how that custom action is called, if the PROGRAMMENUNAME was specified as a property or set via the command line, you could also accomplish the same thing.  Something on the order of: "msiexec /i QuickTime.msi PROGRAMMENUNAME=Accessories\Quicktime\".  The PROGRAMMENUNAME value does not need to be in quotes. (tested 4/27/07 1:29 PM)

-David

Answered 04/17/2007 by: dlernstrom
Senior Yellow Belt

Please log in to comment
0

that did the trick. While waiting for your response I took out ALL of the entries for the shortcut menu and deleted the row in DIRECTORY for quicktimeprogrammenufolder.
This got rid of any folder entries...but I decided that I wanted users to have the ability to start QT without digging around the C drives (but not clutter up the program menu folder)

Answered 04/17/2007 by: mcburn13
Senior Yellow Belt

Please log in to comment
0

Glad to hear it.  Let me know if there are any other issues.

-David

Answered 04/17/2007 by: dlernstrom
Senior Yellow Belt

Please log in to comment
0

two quick questions for using dlernstrom's method.

1) I need to ensure tiff's are not associated with quicktime, this goes for both file association and mime association, where in the MSI are the default file associations set and how can you set whether its associated with quicktime or not.

2) We will be deploying this with AD and it will be with elevated privileges. However my understanding there are a couple files quick time writes when being launched the first time. Our users one have roaming profiles which are stored on a network drive, two c drive is pretty much locked down to where users cannot write to.

Answered 07/10/2007 by: rjnagy
Senior Yellow Belt

Please log in to comment
0

Hi Ric,
you need to deploy the 'Quicktime.qtp'.
See: http://www.appdeploy.com/packages/detail.asp?id=520
There are a lot of tips.
Regards, Nick

Answered 07/10/2007 by: nheim
Tenth Degree Black Belt

Please log in to comment
0

Okay thats fine the only question I have on that is once i install quicktime the way I want and snag the QTP from a box:

1. Is it being directly injected into the package first deleting the old qtp then adding the new

2. Is it being added via a MST

3. Is it a custom action that must take place after the install if this is the case, is there a site that defines or aids in writing custom actions.

I am using admin studio 8.5 and am just looking at the most efficient and effective means of doing this.

Thanks in advance.

Ric Nagy

Answered 07/13/2007 by: rjnagy
Senior Yellow Belt

Please log in to comment
0

Hi Ric,
1. There is no 'quicktime.qtp' in the original package. Therefore you have to add it in the file table.
2. This would be the preferred way, although you could change 'quicktime.msi' directly, it is not recomended.
3.  You need a custom action, if you want to make it work in W2K + XP AND on VISTA.
    In W2K + XP this file goes to: '%ALLUSERSPROFILE\Application Data\Apple Computer\QuickTime'
    In VISTA, its lcation has changed to: '%USERPROFILE\AppData\LocalLow'

We install this file to '[INSTALLDIR]\UserSet' and copy it from there with a line in the 'DuplicateFiles' table to its final destination.
We use a custom action to set the line in 'DuplicateFiles' dependent on the OS.
We also copy the 'com.apple.QuickTime.plist' file to '%ALLUSERSPROFILE\Application Data\Apple Computer\QuickTime'. It contains the serial#.
With this approach, no source is needed for a repair of the user settings and its a lot faster also.

Finally, we use entries in the registry table to do an 'Active Setup' call the first time a profile is loaded after the installation.
This calls 'msiexec /i [ProductCode] REINSTALL=UserSettings REINSTALLMODE=up /qn'

Hope this gives you the idea.

Regards, Nick

Answered 07/16/2007 by: nheim
Tenth Degree Black Belt

Please log in to comment
0

Nick I went ahead and was redoing the package.
Removed all the languages except 1033 then added the information we wanted to show up in ARP and then according to one other post in this thread ripped out the other language folders and resaved the MSI.

At this point opened tuner to create my transform and added the following which was according to dlernstrom

Property Table:
REGSRCH_INSTALL_ASU = 0
DESKTOP_SHORTCUTS = 0
QTINFO.BISQTPRO = 1

Registry Table:
Added an entry to ensure that the Taskbar icon never showed up...
Registry = NoTaskIcon (Some Unique Key -- Whatever name you pick)
Root = 2
Key = SOFTWARE\Apple Computer, Inc.\QuickTime\ActiveX
Name = QTTaskRunFlags
Value = #2
Component = QTPlugin.ocx

now the next and last thing I was going to do was add the qtp. The plist im not sure if we need because we have special circumstances here allowing us to use quicktime with out the registration number.

So in Tuner I went to Files and Folders
I did a right click on destination computer and show folder.
Now there I did not have an all users option

So at this point I was a little confused and called Macrovision
They had me right click Destination Computer, show folder, and select AppDataFolder

Now supposedly according to the guy I talked to thats the same as Application Data...please correct me if im wrong...They then told me to create the subfolders Apple Computer\Quicktime. I actually wondered if under Destination Computer if I should have created the following folder structure :%ALLUSERSPROFILE\Application Data\Apple Computer\QuickTime

He is telling me at this point I should be able to just drop the qtp file in there. I could have however swore that someone posted if you do that it gets overwritten the first time quicktime runs.


This was the part that lost me

We install this file to '[INSTALLDIR]\UserSet' (Not sure where that is) and copy it from there with a line in the 'DuplicateFiles' table (Familiar with the duplicate files table but are we just copying and pasting from the user set to the dupe file table?) to its final destination (wasnt sure if thats all final destination meant).
We use a custom action to set the line in 'DuplicateFiles' dependent on the OS.
We also copy the 'com.apple.QuickTime.plist' file to '%ALLUSERSPROFILE\Application Data\Apple Computer\QuickTime'. It contains the serial#.
With this approach, no source is needed for a repair of the user settings and its a lot faster also.

Finally, we use entries in the registry table to do an 'Active Setup' call the first time a profile is loaded after the installation.
This calls 'msiexec /i [ProductCode] REINSTALL=UserSettings REINSTALLMODE=up /qn'



also didn't fully understand the last part

Answered 07/18/2007 by: rjnagy
Senior Yellow Belt

Please log in to comment
0

Hi Ric,
Read this post from John McFadyen carefully:
http://itninja.com/question/how-do-you-roll-out-new-machines?4146
It explains this approach very well.

Basically, it solves the problem of using different destination directories for 'quicktime.qtp' in XP and VISTA.
The Active Setup entry makes sure, that this file is installed in each profile.

Hope, this clarifies it a bit.

Regards, Nick

Answered 07/18/2007 by: nheim
Tenth Degree Black Belt

Please log in to comment
0

Ok, hopefully someone can help a noob :-)

I followed the instructions just as spelled out... deleted shortcuts, added registry entries, modified the proporties table.

first, the follow mods to the props table are to be done:
Property Table:
REGSRCH_INSTALL_ASU = 0
DESKTOP_SHORTCUTS = 0
QTINFO.BISQTPRO = 1

The desktop shortcuts one was easy... just modified the row.  However, the other 2 did not exist, so I am assuming I was supposed to create those rows

Lastly, after I do everything and deploy QT, there are no shortcuts (yeah!), there is no icon in the systray (yeah!), but when I go into QT and check the QT prefs, the CHECK FOR UPDATES box is still checked.

does anyone have any recommendations?

Answered 08/22/2007 by: ghershinow
Yellow Belt

Please log in to comment
0

Hi Greg,
this flag is set in the quicktime.qtp settings file.
Therefore, you need to deploy this file to all profiles.
Regards, Nick

Answered 09/07/2007 by: nheim
Tenth Degree Black Belt

Please log in to comment
0

Thanks to everyone for their help.  Special thanks to Nathan Coulling for helping me out with the MST/QTP file.  All the computers in the school now have QT :-)

Answered 09/07/2007 by: ghershinow
Yellow Belt

Please log in to comment
0
ORIGINAL: dlernstrom
HERE'S THE GROUP POLICY TRICK
Method 1 (The workaround I discovered): When you add the package through Group Policy, you'll have a tab that is titled 'Deployment'. Click that and then click advanced. Check the box that says 'Ignore language when deploying this package.' This is because (as I'll explain in a minute), that Quicktime 7_1_5_120 defaults to the Chinese Language! This workaround will get the program to install okay (really, your system is rejecting the package because it doesn't believe the Chinese program should install on an English system. I know, it seems contrary to logic since there is an entry in the Property table for 1033 (english language), but unfortunately, that is the case. This is the method I used to get 7_1_3_100 installed on my systems.

Method 2 (A BETTER VERSION): If you open up the QuickTime.msi package through ORCA (DON"T START A TRANSFORM FOR THIS STEP), then immediately click on 'View->Summary Information. (If you have already started a blank transform, you will be unable to edit the package information.) You'll notice the supported languages are something like, 1033,1036,1031,1041,1043,1040,2052,1034,1030,1035,1042,1044,1053,1028. Remove them all but 1033 -- English. Then save the msi overtop of itself (another thing I absolutely hate doing, but it is required this time). This method will cleanly get the English version to install through GP happily. :) I used this method for getting 7_1_5_120 on my systems.

You should rate this post, it was a triumphant discovery! :)
-David


A quick THANK YOU note to dlernstrom!

I've spent most of today trying to fix this problem, albeit with QT version 7.2.

I managed to figure out it was a language issue that was blocking the install fairly quickly, looking at the GP settings you can see the language is set to "Chinese (Taiwan)", but I just opted for your first method, and set the 'Ignore language when deploying this package.' option, which, like you, I wasn't particularly happy about. Luckly googling found this thread, and your post, which is a much better method! I would never have though of editing the summary information! I've rated your post by the way - top marks!

Thank you once again

Ben
Answered 10/09/2007 by: bjblackmore
Senior Yellow Belt

Please log in to comment
0

Pretty bad that the Error 47: Invalid URL. () problem still exists in the latest version of Quicktime (7.6.5) in Windows 7.  [:@]

Answered 01/23/2010 by: NINO_NANO
Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity