Hey guys first post, great site by the way!

I am sure this is something obvious that i'm missing (though i am relatively inexperienced).

Using Wise Package Studio I have performed a capture on a small relatively non-complex program installation and have the following problem when installing with the captured MSI.

If the program is installed using the supplied setup it installs all the files to "C:\Program Files\%APP%\ and everything works fine, the application reads all the files from this location.

When I capture the installation, all the files are there and installed to the same location. After installing with the MSI, all the files are accounted for, yet when the program is run, it looks for the installed files in the users profile e.g C:\Documents and Settings\Administrator\*.*. So when the program runs I get the error "Runtime error: Cannot find file c:\Documents and Settings\Administrator\%file.xxx%.

If I copy the files to here manually (after installing with the MSI) it works fine.

I thought there may be a reg key or something that was captured while installing under administrator but there is nothing evident.

It all looks fine to me in the package, anyone have any ideas?

Thanks in advance
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Community Chosen Answer

1
I had similar problem with one application, i think the shortcut is pointing towards the administrator profile
check the shortcut(.exe) to which location it is pointing to
Answered 01/31/2007 by: rakesh.kumar
Senior Yellow Belt

Please log in to comment
Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

2
Also check the Working Directory parameter of the shortcut, you may have to place the directory of the application files there...
Answered 01/31/2007 by: gmorgan618
Blue Belt

Please log in to comment
0
Ahhhhhhh you guys are my new hero's!!! I knew it would be something simple! Turns out that the working directory was blank so i'm assuming it defaults to the users profile (correct me if i'm wrong) or is set somewhere else. Man that is a load off my mind!

Thanks again guys, this is the best forum!
Answered 01/31/2007 by: houston
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity