Hi,
Im making a package containing an ActiveX (ocx-file) for a webb-application. I'm using WPS and made it through snapshot. It's nothing wrong with the package really, but the activex is always disabled in user-accounts. A test installation in an admin-account and the webbapplication starts and works great. Changing to a user-account and its not working, well it says that the activex is disabled and then you can click and enable it in internet explorer options - manage addons (ugly solution). The two keys that are needed to fix this resides in current user and comes with the package, but of course they will not be installed in the user account. The msi-file "self-heals" (uh? can i say that?) after the manual enabling of the activex....to late....

Someone has to have encountered this before or something close, and i just cant come up with any good idea to solve this.

The application should start without any "enabling" by the user.
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
active setup.
Answered 09/16/2008 by: kiptek
Second Degree Green Belt

Please log in to comment
0
Did you make sure to install as per-machine meaning, ActiveX registration exist under HKCR and not under HKCU\Software\Classes?
Answered 09/16/2008 by: AngelD
Red Belt

Please log in to comment
0
kiptek:
Thanks! Thats what I will do.

AngelID:
Yeah, its per-machine and the registration keys goes to HKCR. But there's keys in CU that enables the activeX.
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Stats\[a - lot - of - numbers]
If the above exists the activex is enabled. If its not present, it will not work.
Answered 09/16/2008 by: polkagris
Orange Belt

Please log in to comment
0
ORIGINAL: polkagris

kiptek:
Thanks! Thats what I will do.

AngelID:
Yeah, its per-machine and the registration keys goes to HKCR. But there's keys in CU that enables the activeX.
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Stats\[a - lot - of - numbers]
If the above exists the activex is enabled. If its not present, it will not work.


I just run into an ActiveX (installed by vendor MSI) where I had to set Flags = 4 under HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Stats\{ActiveX GUID} otherwise the user had to allow the ActiveX.

You can also make this per machine by adding the GUID to
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Ext\PreApproved
Answered 10/16/2009 by: Bobo
Orange Belt

Please log in to comment
Answer this question or Comment on this question for clarity