Hi, I have a problem when tring to add a msi package to a GPO.
I get the error message:
Add operation failed. Unable to extract deployment information from
the package. Run validation on the package to ensure that the
package is correct.


and in event viewer i can see this:
Product: *****-- The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2705. The arguments are: Directory, ,

Anyone seen this before?
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Hi,

Have you validated the package as suggested?

Is it a vendor supplied / transformed MSI or have you repackaged the application?

Are you able to add other MSI packages to this GPO without any problems?


Cheers,
Rob.

EDIT: This may be useful: http://support.microsoft.com/?kbid=324886 - it was only reviewed by MS a week ago!
Answered 10/19/2005 by: MSIPackager
Third Degree Black Belt

Please log in to comment
0
Hi, yes I did a validation and i did it again now and got it right.

There was errors with the Directory table and some values where wrong in Directort Parent on some Directories.

It is a vendor MSI and not a repackage application, and the event viewer log was a good hint on where to search but I didn't see what was wrong the first time.
Answered 10/19/2005 by: painless
Senior Yellow Belt

Please log in to comment
0
lol, funny.
Answered 10/20/2005 by: brenthunter2005
Fifth Degree Brown Belt

Please log in to comment
0
[:@]
Answered 10/20/2005 by: MSIPackager
Third Degree Black Belt

Please log in to comment
Answer this question or Comment on this question for clarity