Hi,
I am creating an MSI Package for an application Platypus Trader v4.5.It does not have any dependencies and consists of raw files provided to me as source.The MSI package needs to be installed over Windows XP-DSI and Windows Vista Operating systems via OVCM(Open View Configuration Manager).I am creating the ODBC settings for the application wherein a system DSN is created and i need to enter the server name and port number.

Now my problem is that when I test the MSI Package via OVCM on Windows Vista and Windows XP-DSI operating systems using test privileges,it does not display the correct port number(displays 1433 which is incorrect).

If I logout from my test account and then login into administrator account and then check the ODBC Settings,it displays the correct port number(2431).I checked the registry path under "HKLM\Software\Microsoft\MSSQL\ConnectTo" path,it shows the correct port number on both admin as well as test user privileges.However, this is not reflected in the ODBC screen with test account.

I have tried rebooting the system and logging in with my test id again but still not helped change the port number.

Kindly assist on the same asap.

Note:On SOE systems, the port number is correctly displayed.This problem is only with DSI systems (Windows XP-DSI and Windows Vista).
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Community Chosen Answer

2
I had this myself on XP SP2 (not sure what you mean buy XP-DSI ?!)

Although the port number is configured correctly and will work - it won't display for a locked down user unless you open up permissions on HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\Client\ConnectTo

Cheers,
Rob.
Answered 07/29/2009 by: MSIPackager
Third Degree Black Belt

Please log in to comment
Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Hi Rob,

Thanks a lot for your response.

XP-DSI is Windows XP SP3 (DSI - Desktop Standarisation Initiative which is going to replace the SOE environment soon at my workplace).

This is what is happening.

When the user launches the executable on test user privileges, he gets an error "could not start trader.exe as the ODBC settings are incorrect", this means that the executable is looking at the port number from the "odbcad32.exe" and not from the "HKLM\SOFTWARE\Microsoft\MSSQLServer\Client\ConnectTo" path in the registry.
I mean, the "HKLM\SOFTWARE\Microsoft\MSSQLServer\Client\ConnectTo" path in registry displays the port number correctly but the "odbcad32" does not.

I will try opening up the permissions on the registry path in the MSI and will inform you on how it goes.

Thanks and Best Regards,
Satyajit.
Answered 07/29/2009 by: satyapai
Orange Senior Belt

Please log in to comment
2
XP-DSI is Windows XP SP3

Ahh of course - I should have known [;)]
Answered 07/29/2009 by: MSIPackager
Third Degree Black Belt

Please log in to comment
0
Rob,
Let me say...YOU ROCK!!!

setting the permissions on the HKLM registry path worked like a charm!!!

The application now displays the correct port number on test user privileges.

Thanks a ton mate!!
Cheers,
Satyajit.[:D] [:)]
Answered 07/29/2009 by: satyapai
Orange Senior Belt

Please log in to comment
2
No problem.. don't be afraid to rate the post [;)]
Answered 07/29/2009 by: MSIPackager
Third Degree Black Belt

Please log in to comment
0
So...we have a piece of s/w that requires WRITE permissions to READ a registry entry? Why am I not surprised? How do these clowns get away with this cr@p?
Answered 07/29/2009 by: VBScab
Red Belt

Please log in to comment
0
I can't comment on the app Satyajit is working on but I found it just creating a standard SQL Server system DSN - only difference was that they wanted it setup for a specific port.

The connection itself was working fine but the ODBC GUI didn't display the specific port number. The only way I found to overcome this was the permissions. Hardly ideal I know.. but the crappy software in this case is Windows [:D]

God bless crap software.. keeps me employed and the family fed and watered!
Answered 07/29/2009 by: MSIPackager
Third Degree Black Belt

Please log in to comment
Answer this question or Comment on this question for clarity