If I'm logged in to a workstation as an administrator and double click on my msi, the software installs and all users can use the application if other people log in to the pc.

If I push the application, or do a manual run as another user, or psexec -s to install as system or psexec -u to load it as another admin user, the app doesn't install successfully. The msi still kicks back an error code 0 as if it does. It is not in add/remove programs, and the directory structure in c:\program files contains only a readme file.

It seems the only way the msi installs successfully is if a local administrator loggs in to th pc and manually runs the install, then everythgin is good to go.

I am a packaging newbie but understand the concepts behind packaging and have access to wise. this msi was packaged by someone who is no longer at our company, so I'm not sure what is going on with it. I need the msi to install as the system account and be available for all users, so I can push it through SMS.

Thanks In Advance for any assistance.
0 Comments   [ + ] Show Comments


Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.


I don't understand why you are testing the deployment with PSEXEC if you ultimately need to use SMS to send it out. I haven't got much experience with it but then I have tried PSEXEC it seems to be a bit of a pain in the backside.

If you really need to get to the bottom of what's going wrong you're going to need to start taking some logs and using some other sysinternals tools... but I really don't see the point.

Deploying through SMS can use the local system account so that your MSI can be deployed when end-users are logged on... Which client OS are you using and what happens when you try to deploy to your test machine / user via SMS?

To deploy to all users you need to either add ALLUSERS=1 to the msiexec command line, or get it into the property table.

Answered 01/29/2010 by: MSIPackager
Third Degree Black Belt

Please log in to comment
To deploy to all users you need to either add ALLUSERS=1 to the msiexec command line, or get it into the property table.

I'd try this first, without ALLUSERS 1 or 2 specified, many MSI's will attempt to install to the account you're running it from (E.G., the system account,) which will technically work, but you'll never be able to find the program because it's installed to the system profile, which you can't interactively log in to.
Answered 02/01/2010 by: Jsaylor
Second Degree Blue Belt

Please log in to comment
Enable windows logging or create log file during installation. i hope log files may help you.

Answered 02/01/2010 by: happyshak
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity