I have WISE Pro, working on making a package silently to install not signed Driver for USB device. For now users are using batch files created to install the driver but i have to change it to create package. i want to know what is the best way to go. include the current batch file with my package or ignore them. and how to package the USB driver? i went through some post but was not clear.
your help highly appreciated, thanks. [;)]
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
do a search there are lots and lots of info on this one

you will need to sign the driver first
then use tools like dpinst to install your driver
Answered 07/13/2010 by: cygan
Fifth Degree Brown Belt

Please log in to comment
0
I'd say this depends on 2 things. First is the contents of the batch file. What is it doing exactly and which mechanism is it using to install the driver. 2nd is your state of mind. Are you an 'I'll be damned if I'll redo work that's already been done' kind of guy, or a 'let's get this right this time around'-person?

first case: re-use the batch file and make it a CA in your msi based on it.
second case: look into using the DifxApp merge module and have a look at this thread.

Have fun [:)]

PJ

EDIT: as cygan already mentioned, you'll want to try and get a hold of signed drivers or sign em yourself. unsigned drivers equal pain and suffering.
Answered 07/13/2010 by: pjgeutjens
Red Belt

Please log in to comment
0
Thanks for the info. i am the kind "DO IT Once & Right"
i will look at the thread [8|]. Thanks.
Answered 07/13/2010 by: Netrock
Orange Senior Belt

Please log in to comment
0
the link :

"Plug and Play driver Installation Explained"

in the thread does not work for me. i get the error: Could not connect to remote server

any idea?? Thanks
Answered 07/13/2010 by: Netrock
Orange Senior Belt

Please log in to comment
0
Netrock - I believe this contains the same content as the (now dead) link used to: http://itninja.com/blog/view/application-reboot-requirements-in-xp8

Hope it helps [;)]

Regards,
Rob.
Answered 07/13/2010 by: MSIPackager
Third Degree Black Belt

Please log in to comment
0
Thank you Rob for the link. i used the following link using DPInst.exe:

http://www.symantec.com/connect/articles/creating-installations-device-driver-applications-using-dpinst

my package installs files to the destination & the installation goes through with no error, but the drivers do not get installed. i have included DPinst to all my *inf folders ( which is two), i think there might be a problem with my sequence order. i have ran ONLY DPinst (with the switches) from CMD with my *.inf file & installed my not signed driver alright. So, i think there could be an issue with the sequence, i placed as the pic shown after "create shortcut"

Any helps appreciated!!

Have a great day everyone!! [:D]
Answered 07/15/2010 by: Netrock
Orange Senior Belt

Please log in to comment
0
I haven't done one in a while but, from what I recall, using the DifxApp merge module - rather than trying to get the DPInst command line correct, etc. - makes the exercise very simple.
Answered 07/15/2010 by: VBScab
Red Belt

Please log in to comment
0
Thanks for the reply i can not use DifxApp as my driver is not signed. i must use DPInst with switch /LM to ignore looking for cat file.
still looking for a solution to get it done, as time is pretty short on this one, any help would be greatly appreciated. [8|]
Answered 07/15/2010 by: Netrock
Orange Senior Belt

Please log in to comment
0
From what I remember, DifXApp is essentially a wrapper for DPInst. Besides, you can self-sign drivers. The information is in the links somewhere. There's also plenty in the archives.
Answered 07/15/2010 by: VBScab
Red Belt

Please log in to comment
0
apparantly you can run difxapp in legacy mode to install unsigned drivers. By setting the flag column in the MsiDriverPackages table to 8

MsiDriverPackages table

http://msdn.microsoft.com/en-us/library/ff537781%28v=VS.85%29.aspx

cheers
Rich
Answered 07/15/2010 by: timmsie
Fourth Degree Brown Belt

Please log in to comment
0
Thanks i got the DPInst working only by changing & modifying the path in the EXE and command Line.
The only thing is i have a custom exe program where i have to assign a filename for variable. something like:
custpro.exe [filename]. i added a MSI script with the following line in the EXE and Command Line box (in wise execute program from destination):
"[INSTALLDIR]install\driver\custpro.exe [filename]"
but the custom action is not running. i can not get it to run!!!
maybe the dbl quote is not good or missing something else...?? [>:]

any idea? Thanks
Answered 07/15/2010 by: Netrock
Orange Senior Belt

Please log in to comment
0
"[INSTALLDIR]install\driver\custpro.exe [filename]"

You've got the syntax wrong

needs to be [INSTALLDIR]install\driver\custpro.exe [#Filekey]

here's a handy hidden away page for formatted data types

http://msdn.microsoft.com/en-us/library/aa368609.aspx
Answered 07/16/2010 by: timmsie
Fourth Degree Brown Belt

Please log in to comment
0
Hi timmsie,

since yesterday i was looking for the solution, thanks for your post i used the following:

[INSTALLDIR]install\driver\custpro.exe [#myfilename] but still did not work. any suggestions?

also, is there a way to turn on error log during installation.

Thank you for your Kind HELP.[;)]
Answered 07/16/2010 by: Netrock
Orange Senior Belt

Please log in to comment
0
Where you have '[#myfilename]' you should have the filename of the file upon which CUSTPRO.EXE is to act.

Let's say the file is called WHATEVER.CFG. Your command line should then look like this:
[INSTALLDIR]install\driver\custpro.exe [#WHATEVER.CFG]

Note that you only use the filename: the hash symbol in front tells the engine to prefix the name with the full path to that file, in long filename format. You would use the exclamation mark if you wanted to use short (8.3) filename format.
Answered 07/16/2010 by: VBScab
Red Belt

Please log in to comment
0
Thanks for your reply VBScab.

[#myfilename] is the same [#WHATEVER.CFG] that you have mentioned. i have tried with # & ! no change yet do not know why is not taking the file name. if i do from command prompt manually everything works as expected.

any ideas? [8|]

Thank you in advance.
Answered 07/16/2010 by: Netrock
Orange Senior Belt

Please log in to comment
0
So...you have a file whose name, when installed, is 'myfilename'?
Answered 07/16/2010 by: VBScab
Red Belt

Please log in to comment
0
Below is taken from the Help section in wise:

Wise for Windows Installer

Execute Program From Destination
This custom action calls an .EXE file that already resides on the destination computer. Use it to call .EXE files that are common to all Windows computers, such as notepad.exe. A tutorial demonstrates this custom action in the Wise for Windows Installer Getting Started Guide.

Usage
Double-click the custom action and complete the Details tab:

lCustom Action Name

Enter a unique name that begins with a letter or underscore. It can contain numbers and periods. It must not match the name of any Windows Installer standard action.

See Standard Actions Reference in the Windows Installer SDK Help.

lWorking Directory

Using a non-bracketed Windows Installer directory property (Example: INSTALLDIR), specify the working directory of the .EXE file to call. When the .EXE file is run on the destination computer, its current working directory is set to the directory you specify here. This must be set to a directory that can be specified with a Windows Installer directory property, which are listed when you click Browse.

lEXE and Command Line

Using a bracketed Windows Installer directory property to specify location, enter the full path to the .EXE file that exists on the destination computer. Example: [INSTALLDIR]TextEditor\MyEditor.EXE. If the .EXE file is registered or is in the PATH environment variable, you might not need to type the entire path. Example: To specify Notepad, just type NOTEPAD.EXE, because it is in the PATH variable.

(Optional) To pass command line options to the .EXE file, enter them after the name of the .EXE file. The command line options are executed in relation to the working directory. Example: If you type INSTALLDIR in Working Directory, and type NOTEPAD.EXE README.TXT in this field, the README.TXT file that is in INSTALLDIR is opened.

it says: NOTEPAD.EXE README.TXT in this field [8|]
Answered 07/16/2010 by: Netrock
Orange Senior Belt

Please log in to comment
0
the actual file name is audio.inf

so i entered the following:

[INSTALLDIR]install\driver\audio\custpro.exe [#audio.inf]
Answered 07/16/2010 by: Netrock
Orange Senior Belt

Please log in to comment
0
A thought...

Does that file's destination path contain any space characters? If so, try enclosing that construct in quotes:

"[INSTALLDIR]install\driver\audio\custpro.exe" "[#audio.inf]"
Answered 07/16/2010 by: VBScab
Red Belt

Please log in to comment
0
tried:

"[INSTALLDIR]install\driver\audio\custpro.exe" "[#audio.inf]"
"[INSTALLDIR]install\driver\audio\custpro.exe" [#audio.inf]

Nothing worked. is there a log file we can generate to see if there is an error?
or we can use one of the Windows program like notepad.exe (or any other) to get the right format to call file name?[8|]
Answered 07/16/2010 by: Netrock
Orange Senior Belt

Please log in to comment
0
i added a MSI script with the following line in the EXE and Command Line box (in wise execute program from destination):
Use it to call .EXE files that are common to all Windows computers, such as notepad.exe
[INSTALLDIR]install\driver\audio\custpro.exe" "[#audio.inf]"

I'm gonna have a guess.. your action runs before the file is in place? The Execute Program from Destination CA type should not be used for calling files that are actually part of your installation. Or if you do , then make sure to schedule somewhere AFTER InstallFiles in Deferred Context. (actually, let's just say -don't- [:)])
You might want to go for an "Execute File From Installed Files" Custom Action, or what they're called in Wise-land (I forgot)

PJ
Answered 07/16/2010 by: pjgeutjens
Red Belt

Please log in to comment
0
Thanks pjgeutjens for your reply.

i run .EXE after installed file , actually i have two .exe files frist one runs ok but the second one that needs to have a file as parameter does not run so:

[INSTALLDIR]install\driver\main\custpro.exe runs ok BUT
[INSTALLDIR]install\driver\audio\custpro.exe audio.inf not running

i believe making package is ok just the format is not right, or something like that......

still going around & trying to find a solution, any help highly appreciated! [;)]
Answered 07/16/2010 by: Netrock
Orange Senior Belt

Please log in to comment
0
Found out the solution: must place the full path for the file like:

"[INSTALLDIR]install\driver\audio\custpro.exe" "[INSTALLDIR]install\driver\audio\audio.inf"

this solution resulted of a solid TEAM Group...!!!

THANK YOU ALL.....[;)]
Answered 07/16/2010 by: Netrock
Orange Senior Belt

Please log in to comment
Answer this question or Comment on this question for clarity