I have seen the threads about repackaging ESSBase but I am not having an issue installing the product but rather a strange issue ONLY when SCCM delivers the product (as the system account).

Here is the short version:
Oracle ESSBase 11.1.x Excel Add in (205MB package from Oracle)
SCCM can deliver/install it using:
Spreadsheet Add-in.exe /S /v"/qn ALLUSERS=1"
OR even with the ALLUSERS=1 Either way the product gets installed to C:\Oracle like normal

Now each user will have to run the regExcelAddin.exe (like normal) however it doesn't work like it should. Procmon shows it doing the exact same commands like a normal install: unreg DLL's, then reg DLL's etc but the add in doesn't show in Excel.

1 problem I found is that the HYPERION_HOME environment variable does not get set when SCCM installs the product.
I fixed that with a simple VB script - no biggie

Then I tried to replace the regExcelAddin.exe function with another simple VB Script that would properly register the add in's.
That SEEMS to work - the ADD IN tab shows up in Excel
ESSBase is there!
When I click on anything in the ESSBase drop down menu - such as "Connect" it does NOTHING
Nada, 0, zilch
No popup for connection, not even a error - just nothing

All of this works perfectly if I run the install as an administrator and am logged on to the system. Any user can run the NORMAL regExcelAddin.exe OR my script and it works great.
BUT if the "system" account runs the install through SCCM or even locally through a cmd prompt launches as system, I get this issue.

Pulling what little hair I have left OUT.
Anyone get this to deploy through SCCM and actually work???
Any help is appreciated.
0 Comments   [ + ] Show Comments


Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.


Let me know if you have a solution. Having the same issue.
Answered 12/05/2011 by: allhart3735
Yellow Belt

Please log in to comment
Your commandline would lead me to believe that the installer exe you are running extracts an MSI file

Spreadsheet Add-in.exe /S /v"/qn ALLUSERS=1"

Anything after the '/v' is passed to the msiexec commandline.

Can you grab the MSI and create a transform for your customisations?
There may be something obvious in the MSI when you look inside it - custom actions or an activesetup that should be enabling the add-in.

Hope that helps,

Answered 12/05/2011 by: dunnpy
Red Belt

Please log in to comment
Thanks for the reply.
Yes it does extract an MSI but everything I tried failed to work properly when transforming the MSI.
Also since the silent install "works without error" everything should have been good BUT the application didn't actually work.
After combing through thousands of lines in Procmon I still couldn't figure it out.

I had to PUNT and capture it! Not the best solution but sometimes it has to be done. This company was still using WISE which did work to successfully capture the install and acatully let the users run the Add-IN.

Sorry I didn't have better news!
Answered 12/05/2011 by: niveknonrev
Yellow Belt

Please log in to comment
I went back and hacked around on this again to figure it out.
And noticed that someone had posted a partial answer on an oracle message board thread which lead me to the a real solution to fixing my problem

When using the standard oracle spreadsheet add in installer - InstallShield handles the pre MSI portion and passes a variable to it containing the install directory:

Then during the install the environment variables are set correctly. Then everything works great.

When it is run silently InstallShield FAILS to pass the front part of the path to the MSI and the environment variable is set WRONG to:

you will notice that after running Spreadsheet Add-in.exe /S /v/qn ALLUSERS=1
that the environment variables are set as follows:

Then the ADD IN WON'T work at all.
After changing the variables and running the normal RegisterSpreadsheet addin - it worked great!

So here is the final solution:
In a cmd/bat file use the following:

"%~dp0Spreadsheet Add-in.exe" /s /v/qn
SETX ARBORPATH C:\Oracle\Middleware\EPMSystem11R1\products\ExcelAddin /M
SETX ESSBASEPATH C:\Oracle\Middleware\EPMSystem11R1\products\ExcelAddin /M

then each user runs the register spreadsheet add in program and it works great.

If you will be installing this via SCCM and it gets installed as "system" then the shortcuts don't show up in the start menu so you could:
create a shortcut file and place it in your install diretctory
then change the cmd/bat file to look like this:

"%~dp0Spreadsheet Add-in.exe" /s /v/qn
copy /y "%~dp0*.lnk" "C:\ProgramData\Microsoft\Windows\Start Menu\Programs"
SETX ARBORPATH C:\Oracle\Middleware\EPMSystem11R1\products\ExcelAddin /M
SETX ESSBASEPATH C:\Oracle\Middleware\EPMSystem11R1\products\ExcelAddin /M

Unfortunetly the Oracle forum has a bunch of numbers for usernames so I don't know who to credit for pushing me in the right direction, but if you read this - Thank You!
Answered 12/07/2011 by: niveknonrev
Yellow Belt

Please log in to comment
1 more thing for SCCM - since the batch/cmd file will be setting ENV variables it apparently needs to be able to "interact"
Running the program as "hidden" but on the environment tab use"
Weather or not a user is logged on
Allow users to interact with this program

then the dang thing sets the env variables properly and it works.
Answered 12/08/2011 by: niveknonrev
Yellow Belt

Please log in to comment
Hello ....

i have the same probs with silent install. I have make a tiket by oracle. The Support say's :

Essbase Excel Add-In Silent Installation [ID 1205231.1] [hr] Modified 30-NOV-2011 Type HOWTO Status PUBLISHED In this Document
[size="-1"] Goal
[hr] Applies to: Hyperion Essbase - Version: to - Release: 11.1 to 11.1
Information in this document applies to any platform.
Goal Describe the Essbase Excel Add-In silent installation instructions.

Solution To use the Excel Add-In Silent installation follow these instructions:

Use this syntax to launch the silent install:

"Spreadsheet Add-in.exe" /S /v"/qn INSTALLDIR=<installDir> FOR_CURRENT_USER=<user> BINARY=<lang> /l*v >log>"[/align]

<installDir> - is the installation directory (default value: C:\Oracle\Middleware\EPMSystem11R1)
<user> - use "1" value to install addin for all users or "2" to install adding for the current user only (default value: 1)
<lang> - is the language to be installed. The following values can be used:

"en" - English
"da" - Danish
"bl" - Dutch
"fi" - Finnish
"fr_FR" - French
"de_DE" - German
"it" - Italian
"ja_JP" - Japanese
"ko_KR" - Korean
"pl" - Polish
"pt_BR" - Portuguese (Brazilian)
"ru_RU" - Russian
"zh_CN" - Simplified Chinese
"es_ES" - Spanish
"sv" - Swedish
"zh_TW" - Traditional Chinese
"tr_TR" - Turkish

"/l*v" is a verbose log parameter.
<log> - log file path

For example:

"Spreadsheet Add-in.exe" /S /v"/qn INSTALLDIR=C:\Oracle\ FOR_CURRENT_USER=1 BINARY=ja_JP /l*v C:\FRS_install.log"

[hr] Products [hr]
  • Middleware > Enterprise Performance Management > Essbase > Hyperion Essbase

And it Works ......
Answered 01/03/2012 by: joerg.schneider
Yellow Belt

Please log in to comment

Looking throught the logfile, generated by installing the MSI, i found out, that there is a custom action called "readEOH" which reads out the path wrong, when installed silent. This causes the wrong environment variables.

I build a transform file, where i changed the following rows in the environment table:

ARBORPATH to [INSTALLDIR]products\ExcelAddin
ESSBASEPATH to [INSTALLDIR]products\ExcelAddin

I deleted all "NewEnvironmentXXX" entries too.

I installed the it with the following command:

msiexec /i "<Path>\Oracle(R) Essbase Spreadsheet Add-in, Fusion Edition.msi" TRANSFORMS="<Path>\MyTransform.mst" /qn /l*v "<Logfile>"

It works, no need to copy shortcuts or anything. Hope that helps.


Answered 05/03/2012 by: cyb
White Belt

  • Where did you get the msi file for the Essbase Spreadsheet? Which version are you running?
    • This content is currently hidden from public view.
      Reason: Member has been banned from the site
      For more information, visit our FAQ's.
Please log in to comment
Answer this question or Comment on this question for clarity