I'm trying to deploy Office 365 (version 2016) and I'm unable to get it to accept the license agreement and disable the first things first screen when deploying this through SCCM.  If I install it outside of SCCM everything installs and works perfectly, it's only inside SCCM where the first things first screen keeps popping up and users have to accept the EULA.

I followed the instructions here https://technet.microsoft.com/en-us/library/dn708063.aspx?f=255&MSPPError=-2147217396  and it doesn't work properly.  Installing this through SCCM it seems to pick up everything from the .xml file except for the EULA.

This is my configuration.xml:

<Configuration>
   <Add OfficeClientEdition="32">
    <Product ID="O365ProPlusRetail">
     <Language ID="en-us" />
    </Product>
   </Add>
   <Display Level="None" AcceptEULA="TRUE" />
   <Updates Enabled="FALSE" />
   <Property Name="AUTOACTIVATE" Value="1" />
</Configuration>

Anyone have any success deploying Office 365 (2016) 32-bit through SCCM?

TIA

Answer Summary:
Cancel
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Answer Chosen by the Author

1
Microsoft provided me the following registry keys to change which resolved our issue:

[HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\Office\16.0\Common\General]
"OptInDisable"=dword:00000001

[HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\Office\16.0\Registration]
"AcceptAllEulas"=dword:00000001

We're currently deploying those via GPO.  We may change those to a compliance setting.
Answered 06/13/2016 by: EricD
White Belt

  • `OptInDisable` helped me to supress the dialog. Thank you.
Please log in to comment

Answers

0
Copy and paste us your XML, we need to check it.
Your actual xml, not from the web page.

Sometimes you can have bung quotes which can cause issues. Check it in Notepad++ or something, they should be straight, not angled.

Also screen shot the pops up you are getting.


Answered 05/26/2016 by: rileyz
Red Belt

  • <Configuration>
    <Add OfficeClientEdition="32">
    <Product ID="O365ProPlusRetail">
    <Language ID="en-us" />
    </Product>
    </Add>
    <Display Level="None" AcceptEULA="TRUE" />
    <Updates Enabled="FALSE" />
    <Property Name="AUTOACTIVATE" Value="1" />
    </Configuration>
  • Not sure how to post a screen shot, but if the user has normal rights it opens a "activate office" screen and prompts them for an email address. If they have admin rights it opens a "first things first" screen and asks them to accept the EULA
    • I believe the "activate office" screen was being caused by a test account not having email. We're still getting the prompt to accept the EULA though
      • Edit your post and add the image. Your xml should work fine, as it looks all good to me.
Please log in to comment
0
To suppress First thing first you need to capture the registry change that has been done when you accept the prompt and add it to the package and make it install via a script or batch file. You can check in this registry location for the fix.

[HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Registration\Machine Name\{90xx0000-xxxx-xxxx-0000xxxxxx}\O365ProPlusRetail\EULA]
"16"="PLEASE NOTE:  Your use of the subscription service and software is subject to the terms and conditions of the agreement you agreed to when you signed up for the subscription and by which you acquired a license for the software. 

Since it is a user registry, it will not be installed via SCCM as it runs in system context. Better use GPO or logon script.
Answered 06/03/2016 by: apptopack
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity