Has anyone gotten the installation options to work? I cant get it to stop displaying a completion notice, the silent install isnt completely silent, and registry keys dont seem to getting set.

Im using Office 2007 Enterprise with a command line of:
\\server\Office 2007\setup.exe /adminfile \\server\Office 2007\customized\Outlook2007.MSP

When the MSP is set with the interface of none, I still get the preparing files window and then its silent from that point on.

When the MSP is set with the completion notice off, I still get a completion notice.

When the MSP has an additional registry key set to be added, after the install the key still doesnt exist.

The MSP is clearly being used because it is only installing the components that were selected (Im only installing outlook) but it seems to be ignoring some settings.

Has anyone tried this yet and gotten it to work?
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Okay, I think I found a few answers. The default config.xml was configured to a Full display and to display a completion notice. Since I was not specifically using a different config file with the msp, the settings may have conflicted.

As for the registry keys it seemed to be ignoring, they dont get created until you actually run one of the apps you installed but they do get created.

Im not sure about the install being completely silent, Im pretty sure I had the config. xml set to none and still got the initial screen.
Answered 02/28/2007 by: nimexx
Blue Belt

Please log in to comment
0
I do not believe the installation can be entirely silent... even through GP the install requires the user to log in to finish... even if the user does not have Administrative rights to install software (office installation temporarily elevates user rights). The users can even cancel the installation by simply closing the install window. :(

I would recommend copying the config.xml file in the Enterprise.WW directory to the root installation directory and of course making your changes. Also place the MSP file in your updates folder. Any MSP files in the updates folder will be applied by default so there is no need for the /adminfile switch. And as long as setup.exe finds a config.xml in the root path it will use that as well.

I would also recommend using GP to deploy Office using the EnterpriseWW.msi and making adjustments to the config.xml file (in the EnterpriseWW folder) for components you do or do not wish to install. To me this is still the best method of deployment as scripting can become tedious, SMS can be very expensive, and manual installations can be exhausting. Only problem with GP deployment of Office 2007... at least from my experience... it cannot be uninstalled by pulling or disabling the GPO. I have no clue as to why but it fails for me every time. Not really a big deal since we don't plan on removing this software once it has been deployed but it still bugs the hell out of me.

One more thing... be absolutely sure that Outlook 2003 has been "uninstalled" before installing Outlook 2007 and I wouldn't let the 2007 installation remove 2003 for you... I would do this manually or via a script. We've had numerous issues where Outlook 2003 wasn't completely removed and it eventually caused major problems with 2007... such as the user not being able to send/receive/reply/etc.

Microsoft almost had a golden egg with this one until it was smashed by their deployment implementations and new restrictions!

oh well
Answered 02/28/2007 by: KrakaJap
Senior Yellow Belt

Please log in to comment
0
We have deployed Office 2007 via SMS with minimal problems. We also haven't had any issues with previous versions of Office 2003. I'm guessing your installation for 2003 is the root cause of your problems, not Office 2007. Perhaps you're not migrating settings? or something not sure. As far as the msp file is concerned, you should dump it in the Updates folder I agree. Works fine.
Answered 10/05/2007 by: Drye
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity