I've never seen anything like this, has anyone?

During install of MSI, following popup occurs:

Error
Initialization of UDA failed.
NLS-F-ENVAR, The COGNLSTAB variable is not set.
MSG-W-NOCATALOG, It was not possible to open the message file. Using default messages instead.

This is from a setup capture, no custom actions. Variable names seem to be related to the application. I haven't really begun to investigate, it's 5:30 and I don't need to deal with this today. :-)
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
the only thing I found similar was on a Chinese web page Do you read Chinese? LOL.

see if there's any .msg files in the original install or cabs

aren't NLS files language related components?

what app is it?
Answered 02/02/2005 by: aogilmor
Ninth Degree Black Belt

Please log in to comment
0
It's Cognos Impromptu 7, packaged with WisePS 5.51.

Found some more frustrations. A verbose log shows no errors, in spite of the popup error. Very, very odd. Lets see.. After the initial capture, the MSI install failed with error 2381 (I think, didn't write it down), Directory does not exist. Turns out the application has about a dozen files that are structured very similar to .INI files, but aren't INI's. That confused the capture and the files were duplicated, they were in both the File and IniFile tables. About 7 lines in the IniFile table were problematic, with the directory set to "_.." (without quotes). Since IniFile had erroneous lines, and these weren't INI files anyway, I removed the duplicated files from the IniFile table and left them in the File table. After that I got past the error in INI file creation, get the popup error (which looks like it's from a separate process, it doesn't halt Windows Installer) and install completes with no errors in the logfile. The error occurs during installation and when the application is launched. Unlike the install, which proceeds and completes under the popup, the launch halts and exits when the error occurs.

The only other thing I can think of is that it has ODBC entries. Maybe I should modify the ODBC capture settings and recapture.. I might be grasping at straws.
Answered 02/03/2005 by: VikingLoki
Second Degree Brown Belt

Please log in to comment
0
Jeez, that does seem confusing.
next on my to do list is Cognos Powerplay. If I can glean anything from that I'll let you know.

O
Answered 02/03/2005 by: aogilmor
Ninth Degree Black Belt

Please log in to comment
0
I know this thread is old, but i'm going to try anyway (i also emailed you VikingLoki)

I'm also getting an error when packaging this into an MSI. It compiles fine according to the instructions given on here, but when trying to distribute the msi, it gets almost all the way to the end of the installation (looks like 99-100%) and gives me an: "Internal Error 2343"

You can see where it stops as well. The install screen reads:

"Writing INI file values...

File: Writing INI file values...
Section:
Key: , Value: "

This obviously gives me no help whatsoever...blanks for everything. The only errors I find in the package are in the IniFile table and i'm not sure why they're even errors (and they're all in the 'tip' section).

I'm at a loss...any help is GREATLY appreciated...
Answered 11/08/2005 by: rchisolm
Senior Yellow Belt

Please log in to comment
0
actually, since i didnt seem to be getting any compile errors i experimented trying to force it to give one to find something to go on. i even deleted the entire IniFile table just for kicks, recompiled and STILL no error...so i'm even more at a loss now.

only thing i've found is that error 2343 in an MSI install is that the 'Specified path is empty', but that much was obvious. what isn't obvious is where it's coming from...
Answered 11/09/2005 by: rchisolm
Senior Yellow Belt

Please log in to comment
0
INI errors are usually due to having INI files that do not fit the INI format. You can copy these and just make them regular files in the installation.
Answered 11/09/2005 by: aogilmor
Ninth Degree Black Belt

Please log in to comment
0
so you're saying that after capturing the install, i should pull out all the files it lists in the INI section (including ones that don't have .ini extensions) and put them in seperately?
Answered 11/09/2005 by: rchisolm
Senior Yellow Belt

Please log in to comment
0
The INI files that have errors in them, make them regular files.

The ones without an INI extension, make sure they're needed. I've had those show up before and usually they're garbage.
Answered 11/09/2005 by: aogilmor
Ninth Degree Black Belt

Please log in to comment
0
well, that's the problem...i'm not sure which are the ones with the error (as you can see from the error message above, it gives me pretty much no info). what do you mean about 'make them regular files'. forgive me if i'm missing something...i've only been doing this a couple months [:)]

I have tried removing the ones without the .ini extension but still the same error.
Answered 11/09/2005 by: rchisolm
Senior Yellow Belt

Please log in to comment
0
I think it's safe to say that anything without the .ini extension is either junk or can be handled as a regular file. As for the errors, look at setup editor (if you're using Wise) at the INI file table. Any bad/invalid value should show up in red. Suffice to say I've had some very strange things happen with INI files, like one that was 500K and took about 30 minutes to install all of the entries. I ended up handling that as a regular file even though it was a correctly formatted INI.
Answered 11/11/2005 by: aogilmor
Ninth Degree Black Belt

Please log in to comment
0
that's exactly what i'm running into. even though there are no compile errors, there are a ton of lines marked red in the IniFile table, and they're all related. It seems to be the only table with errors. I don't even know where to begin really...either for making the .ini files 'normal' files like you said, or to correct the errors. Can you explain exactly what you mean about making the files Wise lists as INI's without .ini extentions into 'regular' files?
Answered 11/14/2005 by: rchisolm
Senior Yellow Belt

Please log in to comment
0
Hello,

What they are trying to say is: instead of creating the INI file using the INIFile table, include the actual file in your list of files/directories.

This way, it excludes all the "issues" with the INIFile table.

Cool?
Answered 11/14/2005 by: brenthunter2005
Fifth Degree Brown Belt

Please log in to comment
0
Oh, and once you have included the INI file as a normal file in your installation, then remove the INI entries from the INIFile table.
Answered 11/14/2005 by: brenthunter2005
Fifth Degree Brown Belt

Please log in to comment
0
alright...i'm trying to understand this one step at a time, thanks for sticking with me here...again, only been doing this a few months and this program has been a headache!

in Wise Package Studio, I have the capture to the point where i'm editing it. In the Feature Details, in the INI Files section, you can browse through and find the .ini and .cer and whatever else it's considering an .in file in there. Should i leave all of them there? How do i make them a 'normal' file if not?

as for the tables section of the Setup Editor, how to i go about changing the INiFile table so the files arent created by it? Is that's what is causing the errors?
Answered 11/14/2005 by: rchisolm
Senior Yellow Belt

Please log in to comment
0
No no no. You need to 'cut' the contents of the INI file in "Installation Expert" mode, and then paste the contents into a new file in Notepad. This will remove the INI file from your MSI package. Then save this new file (with its proper name) and drag that file to the correct directory in your MSI package.


So basically what you are doing is telling Wise that you don't want it as an INI file, you want it as a normal file, like EXEs, DOCs, BATS, DLLs, DATs, COMs, TLBs, etc etc etc.
Answered 11/14/2005 by: brenthunter2005
Fifth Degree Brown Belt

Please log in to comment
0
ok, that makes sense, but i guess the next question is, when i recompile this, how will it affect the errors in the IniFile table, especially if they're referring to files that I moved?
Answered 11/14/2005 by: rchisolm
Senior Yellow Belt

Please log in to comment
0
See, thats where the magic comes into it! [:D]

In Installation Expert, when you "cut" the contents from that file you are actually editing the INIFile table (but in a GUI mode).

Sweet huh!?
Answered 11/14/2005 by: brenthunter2005
Fifth Degree Brown Belt

Please log in to comment
0
ahhhhh, nice....ok, i'll give that a whirl and let you know how it goes! thanks for the help!
Answered 11/14/2005 by: rchisolm
Senior Yellow Belt

Please log in to comment
0
alright, i went in to each directory in the 'Files' part of Feature Details that contained .INI files, and added them into the appropriate directoy in there. then, i went into the INI files directory and removed all of the INI files. this is the correct procedure right? i'm recompiling and testing in a few...
Answered 11/14/2005 by: rchisolm
Senior Yellow Belt

Please log in to comment
0
EXCELLENT! It worked...learned a lot today...lol.

I do have one more oddity though...the application does not show up in the Add/Remove programs. I do have the setting in the .msi to have it show up there, but it does not...any ideas?
Answered 11/14/2005 by: rchisolm
Senior Yellow Belt

Please log in to comment
0
OK, thats interesting then. Ensure that the following property does not exist in the property table: ARPSYSTEMCOMPONENT. If it does exist, then delete it. This property, when set, disables this MSI from showing up in the Add/Remove Programs applet.

If this isn't set, then you've got an interesting issue...... [;)]
Answered 11/15/2005 by: brenthunter2005
Fifth Degree Brown Belt

Please log in to comment
0
it doesn't exist in the table. the only setting that pertains to what i changed in the Add/Remove settings that I see in the table is the 'ARPNOMODIFY' which is set to 1

The only odd thing about this app is that i set it to be a per-user installation. Usually I don't use that...would that cause this problem? Because even though all the files get install and i can go directly to the .exe and run it normally, the shortcuts don't show up either. it's very strange...
Answered 11/15/2005 by: rchisolm
Senior Yellow Belt

Please log in to comment
0
This message describes a very similar problem I'm having - however, I have one question - once I've cut the cotents of the ini file into Notepad and then save it with the same file name - do I give it a .txt extension?

When I am currently compiling my msi the ini files are not discovered and do not appear - I therefore copy them in using the 'Files' tool, however, when I compile it the ini files filename get converted to some random filename, and the iniFile table takes ages to compile. Any ideas?

Thanks

Matt
Answered 03/27/2006 by: mattyskinner
Senior Yellow Belt

Please log in to comment
0
actually, if you're using WPS, you dont really have to copy the contents out into another file. just go to the .ini section and remove the files from there (make sure you note what directories they were in). after that, go to the files section and find the .ini files and add them back in to the appropriate directories there...basically acting as normal files.

i've actually had this happen with multiple applications and it has solved about 99% of my problems...
Answered 03/27/2006 by: rchisolm
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity