Hi All,
I have created an MSI Package which contains a .MSI file along with ODBC entries.This package needs to be tested in Windows XP SP3,Windows Vista and Windows 7 operating systems.I have managed to create the ODBC SQL server entries and the package works fine on Windows XP and Windows Vista.I created a custom action to execute the registry script for the Windows 7 Operating System.However, I am unable to update the "Port Number" sextion of the ODBC Settings.

In the registry, the ODBC Port Number corresponds to the "HKLM/Software\Microsoft\MSSQLServer\Client\ConnectTo" section in the registry.Even though the HKLM Path in the registry is updated, the port number section in ODBC does not reflect the change.

Even if full permissions are provided to the "HKLM/Software\Microsoft\MSSQLServer\Client\ConnectTo" section in the registry,it still does not reflect the change in the "Port Number" settings of the ODBC.
Note that the Port numbe settings are correctly reflected on Windows XP and Windows Vista Operating systems and this issue is limited to only Windows 7 Operating system.
Any Assistance to resolve this would be much appreciated.
Thanks in advance for your assistance.
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
ORIGINAL: satyapai

I created a custom action to execute the registry script for the Windows 7 Operating System.

Even though the HKLM Path in the registry is updated, the port number section in ODBC does not reflect the change.

Even if full permissions are provided to the "HKLM/Software\Microsoft\MSSQLServer\Client\ConnectTo" section in the registry,it still does not reflect the change in the "Port Number" settings of the ODBC.

Is it just that the settings are not displyed but the connection is working?

Are you using 64 bit OS? In that case, the registry path that ODBC is looking for must be different .
Answered 12/15/2011 by: SandeepPanat
Orange Senior Belt

Please log in to comment
0
Hi Sandeep,
I am unable to check to see whether the connection works fine at my end as I do not have access to SQL server during package creation.So I cannot say for sure that the connection will work or not.What I can do however is to ask the user to check the package at his end to see the connection works or not.

Yes, Windows 7 is a 64-bit OS and I have added the port Number registry entries in the "HKLM/Software\Microsoft\MSSQLServer\Client\ConnectTo" path as well as the "HKLM/Software\Wow6432Node\Microsoft\MSSQLServer\Client\ConnectTo" path.But the Port Number change still does not reflect in either registry path.
Any Suggestions?
Answered 12/15/2011 by: satyapai
Orange Senior Belt

Please log in to comment
0
Check for - user permissions on the folder where the odbc executable resides, reg permissions, firewall settings if it blocks the specified port and lastly whether named pipe, OR tcp/ip makes any difference on Windows 7.
Answered 12/16/2011 by: SandeepPanat
Orange Senior Belt

Please log in to comment
Answer this question or Comment on this question for clarity