Seems I am having trouble getting Lync to install with a full install of Office 2013 Pro. I have created an MSP with the config that states that I want Lync 2013 to run from this computer. I run the install in silent mode and all the other programs are there i.e. word, excel and outlook but no Lync. If I go to programs and features I get the option to change and install Lync. I am hoping to not to have to do this extra step for each person I upgrade to Office 2013. Any help would be appreciated TIA.

0 Comments   [ + ] Show Comments


Please log in to comment


when you run setup.exe /admin to create the msp was lync selected in there? as i have seen the msp override the config file in the past
Answered 07/06/2016 by: sparky86
Third Degree Brown Belt

  • I go into the Set Feature installation states and set Lync to run from this computer. I am not sure where else I need to make this selection. Please let me know and check and see.
    • ok, it sounds more like the issue around office 2013 RTM where lync and share point wouldn't install from the media, the work around for that was to either copy the sp1 msp's to the updates folder or add the following line to your config file

      <Configuration Product="ProPlus">

      <Display Level="none" CompletionNotice="no" SuppressModal="yes" AcceptEula="yes" />
      <OptionState Id="GrooveFiles2" State="local" Children="force" />
      <OptionState Id="LyncCoreFiles" State="local" Children="force" />

      • Thank you so much for the help so far. I am afraid that I am bit confused as to what I am to change or add based on the xml that I have.

        Here is my current config.xml

        -<Configuration Product="ProPlus">
        <!-- <Display Level="full" CompletionNotice="yes" SuppressModal="no" AcceptEula="no" /> -->
        <!-- <Logging Type="standard" Path="%temp%" Template="Microsoft Office Professional Plus Setup(*).txt" /> -->
        <!-- <USERNAME Value="Customer" /> -->
        <!-- <COMPANYNAME Value="MyCompany" /> -->
        <!-- <INSTALLLOCATION Value="%programfiles%\Microsoft Office" /> -->
        <!-- <LIS CACHEACTION="CacheOnly" /> -->
        <!-- <LIS SOURCELIST="\\server1\share\Office;\\server2\share\Office" /> -->
        <!-- <DistributionPoint Location="\\server\share\Office" /> -->
        <!-- <OptionState Id="OptionID" State="absent" Children="force" /> -->
        <!-- <Setting Id="SETUP_REBOOT" Value="IfNeeded" /> -->
        <!-- <Command Path="%windir%\system32\msiexec.exe" Args="/i \\server\share\my.msi" QuietArg="/q" ChainPosition="after" Execute="install" /> -->
Please log in to comment
your current config isn't doing anything as everything inside is commented out 

i would say the best option would be is to add the SP1 msp files from the SP1 KB2817430 to the office updates folder

to get the msp files out of the exe run proplussp2013-kb2817430-fullfile-x86-en-us.exe /extract and select a folder, you can then copy the msp files to the update folder and that should resolve the issue
Answered 07/08/2016 by: sparky86
Third Degree Brown Belt

  • Sparky thank you for your help but it didn't seem any of those wanted to work. I did go back and get a older version that didn't have SP1 and that seemed to allow me to install. Thanks again for you help I am sure I will need it again.
Please log in to comment
Answer this question or Comment on this question for clarity