Hi guys,

I have a word document which should be deployed on this path C:\Documents and Settings\<username>\Application Data\Microsoft\Templates.

I have created a msi which has word document on the specified path. when i install manually it is working good. But when i deploy through SCCM i can see the msi file in add remove programs not the word document file in the specified path.

Can any one provide me a solution.
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Does this have anything to do with the AppDeploy Repackager or its recipe files or should this post be moved to Package Development?
Answered 05/29/2009 by: bkelly
Red Belt

Please log in to comment
0
May be i dont know exactly where it should be.
Answered 06/01/2009 by: rvkc831
Senior Yellow Belt

Please log in to comment
0
I suspect that when you're deploying it via SCCM it is installing under the local system account and not the user account. This would result in the document being installed under a different location.

To check to see how your application is installing. Expand you application in SCCM, select Programs, right click the Program that you are installing (e.g. Per-user attended) and select properties. Look on the Environment tab and I suspect that it's set to run as 'Run with administrative rights'.

If you change this to 'Run with user's rights' then your document should install to the desired path.
Answered 06/01/2009 by: michaelnowell
Second Degree Blue Belt

Please log in to comment
0
Hi krishna,
has this file to go to each user on a machine or only to one particular profile?
Regards, Nick
Answered 06/02/2009 by: nheim
Tenth Degree Black Belt

Please log in to comment
0
ORIGINAL: rvkc831

Hi guys,

I have a word document which should be deployed on this path C:\Documents and Settings\<username>\Application Data\Microsoft\Templates.

I have created a msi which has word document on the specified path. when i install manually it is working good. But when i deploy through SCCM i can see the msi file in add remove programs not the word document file in the specified path.

Can any one provide me a solution.



Probably you may try to put this in your msi:

C:\Documents and Settings\[LogonUser]\Application Data\Microsoft\Templates.
Answered 06/02/2009 by: djain3
Second Degree Blue Belt

Please log in to comment
0
Probably you may try to put this in your msi:

C:\Documents and Settings\[LogonUser]\Application Data\Microsoft\Templates.
...which will mean your package will only install on XP. NT uses a different profile path as do Vista and Windows v7. I would regard that as sub-optimal, wouldn't you? :)

Far and away the easiest route is to do as Michael says.
Answered 06/02/2009 by: VBScab
Red Belt

Please log in to comment
0
put an HKCU entry in the component that houses the word template file.

mark the HKCU key as the keypath.

I would suggest something along the lines of

HKCU\Software\[CompanyName]\Packages\[ProductName]\ValidationFix_ComponentName = true
Answered 06/03/2009 by: jmcfadyen
Fifth Degree Black Belt

Please log in to comment
0
Hi nheim,

All the users who logon to the machine.
Answered 06/03/2009 by: rvkc831
Senior Yellow Belt

Please log in to comment
0
Hi VBScab,

In my company only XP work stations.
Answered 06/03/2009 by: rvkc831
Senior Yellow Belt

Please log in to comment
0
Oh, I see. You work at a company which never upgrades. Cool. It probably never UATs new OS releases, either, eh?

Make your packages future-proof, as far as you can. It's a pain to re-visit them.
Answered 06/03/2009 by: VBScab
Red Belt

Please log in to comment
0
When i changed the Administrative Rights to User Rights in the SCCM Program properties it is working.
Thanks to all of you guys and michaelnowell too.
Answered 06/04/2009 by: rvkc831
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity