/bundles/itninjaweb/img/Breadcrumb_cap_w.png
Hi everyone!

I am looking how to modify the Access list of a specific hive in the Windows registry to make my Tivoli Enterprise Console Client working correctly in my user without rights environment.

There is the hive :

HKEY_LOCAL_MACHINE - \Software\JavaSoft

I need to do in in a command line or in a vbs because I am deploying the application with SMS 2003.

Regards
0 Comments   [ - ] Hide Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.
Answer this question or Comment on this question for clarity

Answers

0
To change a registry value or registry permissions from a command line or from a script, use the Regini.exe(WINDOWS\SYSTEM32) utility.

Cheers!
Answered 10/02/2008 by: zipsantro
Purple Belt

Please log in to comment
0
Just google "Regini.doc" to get full details to use REGINI.EXE.
Answered 10/02/2008 by: zipsantro
Purple Belt

Please log in to comment
0
SetACL.exe should also be sufficient.
http://www.helge.mynetcologne.de/setacl/
http://setacl.sourceforge.net/html/examples.html (Search for the "Registry" example)
Answered 10/03/2008 by: AngelD
Red Belt

Please log in to comment
0
AngelD: How can I set the rights for "All users" with SetACL? Can I type only "All users"..?
Answered 10/03/2008 by: jmpouliot
Second Degree Blue Belt

Please log in to comment
0
You need to use the name of an actual user and/or group, thus 'Everyone', Users' or 'Domain Users' are all valid.
Answered 10/03/2008 by: VBScab
Red Belt

Please log in to comment
0
ok thanks.

I see that if I want to grant permission for the registry, I need to do the following:

SetACL.exe \\servername\MACHINE\software /registry /grant S-1-1-0 /read /sid

How could I set the permission for the local machine on which I am deploying the script.

I tried setacle.exe hkey_local_machine\Software\abcd /registry /grant s-1-1-0 /write_owner /sid and it did not work.
Answered 10/03/2008 by: jmpouliot
Second Degree Blue Belt

Please log in to comment
0
Well I got it.
Answered 10/03/2008 by: jmpouliot
Second Degree Blue Belt

Please log in to comment
0
User: JohnDoe
Domain: MyDomain
Target: HKEY_LOCAL_MACHINE\Software\Microsoft\Policies
Required permission: Full Control (there are fewer registry permissions than for file system)

SetACL.exe -on "HKEY_LOCAL_MACHINE\Software\Microsoft\Policies" -ot reg -actn ace -ace "n:MyDomain\JohnDoe;p:full"
Answered 10/03/2008 by: VBScab
Red Belt

Please log in to comment
0
I used this one:

setacl.exe MACHINE\SOFTWARE\Microsoft /registry /grant S-1-1-0 /write_owner /sid
Answered 10/03/2008 by: jmpouliot
Second Degree Blue Belt

Please log in to comment