I'm trying to create an image using Microsoft Deployment Toolkit and use Windows Deployment Services to deploy the image via a PXE boot.  Within the image I have Office 2007 set to install.  However when the image is deployed, the machine doesn't have Office installed.  I have tried the following:

  • Create the *.MSP file using Office Customization Toolkit and saved it in the Updates folder.  I then added the quiet install command of "setup.exe".
  • Created the *.MSP, and then added the following command into Quiet Install command: setup.exe /adminfile CUSTOM.MSP
  • Modified the config.xml file and used the following command into Quiet Install command: setup.exe /config .\Enterprise.WW\config.xml
  • I have also tried following command into Quiet Install command: setup.exe /admifile CUSTOM.MSP /config .\Enterprise.WW\config.xml
I am also trying to look for any logs that I can use to assist me.  I have setup logging from the Microsoft KB article http://support.microsoft.com/kb/936625, but I am still unable to locate the log file that would give me the error.  Any help would be greatly appreciated.
0 Comments   [ + ] Show Comments


Please log in to comment



Try renaming your .msp with a 1_<whatevername>.msp then copy it to the updates folder and run the setup.exe again. It will automatically use that as your /adminfile without any switches.

For example: 1_OfficePro2007.msp

Answered 01/02/2013 by: Estes
Second Degree Blue Belt

  • this is the right and easiest way to do it. You can also create a log file and see what is the issue.
  • Estes - I will try that. Should I also make sure the working directory is pointing to the server as well, or should I just leave it the default location of the file?

    For example: "\\<server>\Application\Microsoft Office" or ".\Application\Microsoft Office"

    Piyushnasa - How can I create the log file? Still having issues locating the logs from the KB article.
    • I didn't set a working directory. The log file should be in the %temp% directory but you can modify the config.xml file to be verbose and to create it in a different location if needed. I just leave it at the default setting.
Please log in to comment

Make sure you have the Display Level set to "None" in your MSP (found under Licensing and User Interface) and automatically accept the EULA. Other than that you might try a manual installation of Office using the MSP and see if it throws any visible errors.

Answered 01/03/2013 by: mpace
Red Belt

  • I went back and found that I didn't set it to "None" but rather "Basic". I have since changed it to "None" and will get back to you with the result.
Please log in to comment

Do you enabled the application on MDT ?

Answered 12/31/2012 by: fantomasss
Orange Senior Belt

  • Yes the application is enabled.
Please log in to comment
Answer this question or Comment on this question for clarity
Nine Simple (but Critical) Tips for Effective Patch Management
This paper reviews nine simple tips that can make patch management simpler, more effective and less expensive.