We deployed an .exe to about 25 machines and we pushed it with psexec.exe. On all the machines we kept getting this error.

Couldn't access YourPCName:
The network path was not found.

Make sure that the default admin$ share is enabled on YourPCName.


We know each machine does have the Admin$ share
We pushed this .exe using an Admin Account
We've had psexec work on other machines, just not this group

What causes this error and how do you fix it?
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
check that the workstation service is running on the targets.

check you have correct perms on those boxes as well
Answered 08/01/2011 by: jmcfadyen
Fifth Degree Black Belt

Please log in to comment
0
Yes, the workstation service is running and I am using an Admin account. I've even tried using the local system account and I get the same result.
Answered 08/02/2011 by: mhsl808
Fifth Degree Brown Belt

Please log in to comment
0
AV, Firewalls and other such software can cause problems like this.
Do you have a bare bones image you can try it on?
Answered 08/02/2011 by: aogilmor
Ninth Degree Black Belt

Please log in to comment
0
It must be a firewall. I am running this on remote machines of course and I used a .txt file. So I ran the following.

psexec @Machines.txt -c -d -s package.exe

and I've tried this:

psexec @Machines.txt -c -d -u Domain\AdminUser -p password package.exe

the machines.txt has 25 computer names and package.exe WILL install on 6 of them. The other 19 give me the Admin$ error.
Answered 08/03/2011 by: mhsl808
Fifth Degree Brown Belt

Please log in to comment
1
Hi,

An option to check on the fault workstation : Turn off "network users identify as guests" like it is explaining here : http://davidchuprogramming.blogspot.com/2009/12/psexecexe-access-denied.html

Hope it can help.

Regards,

Mike
Answered 08/05/2011 by: Mike74
Yellow Belt

  • Estava com o mesmo problema..
    consegui resolver alterando o hostname pelo IP

    psexec \\10.248.50.30 - u "DOMÃNIO"\"LOGIN" -p "SENHA" "ARQUIVO".exe ou
    psexec @maquinas.txt - u "DOMÃNIO"\"LOGIN" -p "SENHA" "ARQUIVO".exe

    no arquivo txt utilize o ip da maquina que deseja ao invés do host.

    Boa sorte!
Please log in to comment
Answer this question or Comment on this question for clarity