Hi ,

I had created a /MST for Lotus Notes. When i install the application using mst it is working fine in windows xp but when i install the same mst in Citrix server the application is not working fine. Did any of you created single mst for both XP and Citrix server. Kindly hel me to sort out this issue.

Regards,
S.Yuvaraj.
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
how did you install lotus notes on the citrix farm did you use the citrix installation manager or did you install it manually on the farm where by you have to run the command change user / install

what exactly is not working . post your log file
Answered 11/02/2009 by: cygan
Fifth Degree Brown Belt

Please log in to comment
0
Hi Cygan,

I installed the application in my test citrix server by giving the below command :

msiexec /i "lotus notes 6.5.msi" transforms="GLO_Rev0.mst".

Regards,
S.Yuvaraj.
Answered 11/02/2009 by: Yuvaraj_Subramanian
Senior Purple Belt

Please log in to comment
0
but you have not answered the question .

did you install it manually on the test farm hence you will need to run the command change user / install first or did you install via CIM
Answered 11/02/2009 by: cygan
Fifth Degree Brown Belt

Please log in to comment
0
Yes but the same result.
Answered 11/02/2009 by: Yuvaraj_Subramanian
Senior Purple Belt

Please log in to comment
0
have you used a monitoring tool ie filemon , procmon, regmon to see if there are any permissions issues

not specifically packaged lotus notes for citrix platfoms are you sure it is supported on citrix platforms
Answered 11/02/2009 by: cygan
Fifth Degree Brown Belt

Please log in to comment
0
Hi,

I got the clue finally. They have used a custom action for windows 2003 server where they have set the installation directory folder to all users profile o that is why it is behaving so in citrix server. Now i wrote two script for making it working in citrix also but the script which i am using for folder permission is not running silently. I am using CACLS.exe in the script. Is there any way to run the CACLS.exe silently?
Answered 11/07/2009 by: Yuvaraj_Subramanian
Senior Purple Belt

Please log in to comment
0
you can do a search there a lots of tools to set permissions ie setacl, secedit, xcacls
Answered 11/09/2009 by: cygan
Fifth Degree Brown Belt

Please log in to comment
0
- I find it helps to use one tool for permissioning. CACLS only permissions the file system, whereas SetACL does that and the registry, too
- To silence the output of any command line tool, you can either use Start and have it not open a window by specifying the '/B' argument or, more simply, send the tool's output to a file, e.g.CommandLine /argument > %temp%\CommandLineOutput.TXT I think you can also use the special 'nul' device, e.g. CommandLine /argument > nul. Output to a file would probably be preferable, since you then have a log of the tool's activity.
Answered 11/09/2009 by: VBScab
Red Belt

Please log in to comment
0
Hi,
I have created transforms for citrix as welll as windows 7 platform.
win7 mst installed fine with the reqd customization but while configuring lotus notes client it used to pop up UAC message to write 2 reg files.
we tried several options like importing those reg files in package as it was not present in the package, checking CAs, running procmon etc.
finally we found that tfew properties were deleted (NTMULTIDIR,PROGDIR,REDIR_DATADIR) and restoring those properties gave us a working mst.

now am facing the same issue with citrix mst. i am through installing msi along with mst manually on the xen app server.
how to get rid of this UAC prompt(after install- during configuration).

any idea regarding the same?
Answered 01/11/2010 by: karshi
Purple Belt

Please log in to comment
0
Hello guys,
Finally we came across solution to suppress the annoying UAC prompt which came up on every first launch of the Lotus notes Shortcut.
The culprit is a property file named Handler.properties. Removing it from the package served the purpose.
Some of you may find it useful.
Answered 01/13/2010 by: karshi
Purple Belt

Please log in to comment
Answer this question or Comment on this question for clarity