I have three different LDAP labels set up to target computers in 3 different OUs.  The queries test fine in the LDAP browser by replacing the KBOX_ variable with a computer name, but the devices never seem to update with the label.  I've read that this only happens on device check-in, so I've let it sit for a couple hours and I've also been forcing inventory on some test machines to no avail...  The LDAP queries are:

Base DN: OU=All Computers,DC=sub,DC=domain,DC=com
Advanced Search: (&(Name=KBOX_COMPUTER_NAME)(objectClass=Computer))

Base DN: DC=sub,DC=domain,DC=com
Advanced Search: distinguishedName=CN=KBOX_COMPUTER_NAME,OU=Servers,DC=ad,DC=adcomparisons,DC=com

Base DN: OU=Non-Production,OU=Servers,DC=sub,DC=domain,DC=com
Advanced Search: (&(Name=KBOX_COMPUTER_NAME)(objectClass=Computer))

Any ideas?
3 Comments   [ + ] Show Comments

Comments

  • I'm sure you did but I'll ask anyways.. Did you checkbox enable at the top of each of those LDAP Smart Labels?

    2nd example: why is there a pathway for the adv search? Should just be (distinguishedName=KBOX_COMPUTER_NAME)

    and honestly if there are no users accounts in those base DN you dont need to use objectclass in the adv search. Keep it simple with (CN=KBOX_COMPUTER_NAME)


    Your examples

    Base DN: OU=All Computers,DC=sub,DC=domain,DC=com
    Advanced Search (CN=KBOX_COMPUTER_NAME)

    Base DN: DC=sub,DC=domain,DC=com
    Advanced Search: (CN=KBOX_COMPUTER_NAME)

    Base DN: OU=Non-Production,OU=Servers,DC=sub,DC=domain,DC=com
    Advanced Search: (CN=KBOX_COMPUTER_NAME)
  • Wow... I did not have the enable button checked, thanks.

    So, upon enabling, it looks like my label for the All Computers and Non-Production OUs (examples 1 and 3) are working, but the label for Servers is not. I had to specify the full path in the 2nd example because Non-Production is a sub-OU of Servers, and I don't want the Servers label to apply to the non-production servers. I could restructure AD if needed, just being curious at this point I guess...
  • It's working fine now, no changes, maybe I wasn't giving it enough time? Anyways, thanks for reminding me to enable... Doh!
Please log in to comment

There are no answers at this time

Answers

Answer this question or Comment on this question for clarity

Share