I want to deploy Windows 10 with Dell KACE so already would like to add an WinPE 10 in Dell KACE.
The KBEM supports the newly released ADK 10, but when trying to create a new KBEM, it's stuck with the message "Adding KBE registry settings"

Any ideas on how to upload WinPE 10 to Dell KACE K2000?

1 Comment   [ + ] Show Comment


  • The WINPE10 drivers would be manually added to the //ikbox/drivers location. Any drivers for Windows 10 specific for the model can be manually added to the \\ikbox\drivers_postinstall\[manufacture]\Windows_10_x64\[Model Number]. Would be treated like a non-dell system if they are not being listed in the driver feed.
Please log in to comment




The WINPE 10 drivers can be accessed on the Dell site and could be used to create the KBE.


Answered 08/18/2015 by: TheAustinDave
Second Degree Blue Belt

  • Hi, thanks for your reply. Yesterday, I also saw that windows 10 drivers are available, but I always thought that they needed to be added to the corresponding WINPE version. (eg: When adding windows 7 drivers to WinPE 5, it won't be used during PE).

    And to deploy windows 10, you normally would need WinPE 10.. Isn't this correct?
    • They may be needed, if that is the case the full WINPE pack can be downloaded and used for the KBE build till KACE compiles a WINPE pack on the support.soffware.dell.com site.
      • Okay thanks for the information. Will check out the WinPE Pack, but if the WinPE Version of the boot image is still WinPE 5.0.. What's the point of having to add WinPE 10 drivers in a WinPE 5.0?

        I'm not able to add WinPE 10 to Dell KACE.. Any recommendations on that topic?
Please log in to comment
This content is currently hidden from public view.
Reason: Removed by member request
For more information, visit our FAQ's.

Answer this question or Comment on this question for clarity