Anytime I try to launch my KBE manipulator it throws up an error. The error is "Could not find Dell Kace Media Manager. Would you like to browse for its location??". I have browsed for the location and I have to do it every time. Everything is installed in its default location. Any ideas???
5 Comments   [ + ] Show Comments


  • What is the location of the Media Manager and what version of KBEM are you using?
    Lead T3 Enterprise Solutions Consultant, K2000
  • the media manager is located in C:\Program Files (x86)\Dell\K2000 Media Manager. The kbe info is file version 3.6 and product version
  • I just checked the code and I do search for that exact location, so that is strange. Are you saying Media Manager is Because that isn’t supported by KBEM anymore. There is an update to KBEM to, but that doesn’t address what you are seeing. Are you running as admin? Are the permissions correct? Do you have more than 1 partition? Is Program Files located on a different partition?
    Lead T3 Enterprise Solutions Consultant, K2000
  • Everything is in a standard format. All folders are on the c: drive and i am running as admin. I have full access to all files and folders and have only one partition. I will try uninstalling and redownloading again and see if it will correct. I am using the kbe manipulator that came in the k2 training bundle.
  • After reinstall it finds the media manager but it inputs a different password than i am giving it. This is moderately confusing.
    • Can you please use the version of KBEM from
Please log in to comment

There are no answers at this time


Answer this question or Comment on this question for clarity