Hi all,
First time poster here. We've recently purchased and deployed the k1000 and k2000 boxes. We run our dhcp and dns on Bluecat Proteus/Adonis.

We're trying to pxe boot off the k2000. We identified two other pxe servers (Novell Zenworks and Altiris) and shut them down, so now our client machines seem to find the k2000, but we get an error. Here's the boot dialog:

TFTP.
PXE-T01: File not found
PXE-E3B:TFTP Error: File not found
PXE-M0F: Exiting the PXE boot agent

We've set option 66 to our k2000 dns name and ip address, and option 67 to "kbox2000.0" and "k2000.0", with the same error.

Any suggestions would be appreciated. Thank you.
Answer Summary:
We needed to set BootP and next-server service options rather than tftp client option.
Cancel
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Is the PXE client on the same subnet as the K2000? If not, you probably need to add ip helper entries as we did (we also have Bluecat appliances with Cisco switches).

See Discussion on booting using MacBoot from a subnet other than where the K2000 appliance resides. It deals primarily with Macs, but the ip helper is also needed for PCs.
Answered 07/06/2011 by: grayematter
Fourth Degree Black Belt

Please log in to comment
0
OK thanks for the feedback guys. The devices we are attempting to PXE boot in this case are on the same ip subnet. That said, we've actually already configured the ip helpers on our WAN switches to account for no longer having a local dhcp server when we moved from serving dhcp on a local NetWare server to the Bluecat solution. Thanks for the suggestion though.

I've reached out to Bluecat support for assistance as I believe the answer lies in what Corey is referring to. I'm just not sure where or how to set this. I'll report back with further info and hopefully a solution. Thanks again.
Answered 07/07/2011 by: lbonk
Senior Yellow Belt

Please log in to comment
0
Corey was correct. We needed to set BootP and next-server service options rather than tftp client option.

Thanks!!
Answered 07/08/2011 by: lbonk
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity