We can't get the VNC remote tool action to work for the K1000, we tried all the steps that dell offered from its walk through, which i provided below. Anyways we went through the directions step by step but we are still getting the error in IE8,9 or 10. We added all of the Kace IP's and FQDN addresses to the "Trusted Sites" and we even opened everything up in the trusted site settings, but we are still getting the error. Is there something that we are over looking?

These are the directions we followed.

INTERNET EXPLORER 6

Launch Internet Explorer 6 and navigate to:

1. Tools > Internet Options > Security
2. Select Trusted Sites Icon
-Add K1000 IP address to the zone
-Require Server Identification (Uncheck)
3. Click 'Custom Level' button
-Reset to Low or Medium Low
4. Under 'ActiveX Controls and Plugins'
-Automatic Prompting for ActiveX controls > Enable
-Download unisgned ActiveX controls > Enable
-Initialize & script ActiveX controls not marked safe for scripting > Enable
-Run ActiveX controls and plugins > Enable
5. Click 'OK'
6. Click 'Yes'
7. Click 'OK'

INTERNET EXPLORER 8

Launch Internet Explorer 8 and navigate to:

1. Tools > Internet Options > Security
2. Select Trusted Sites Icon > Sites Button
-Add K1000 IP address to the zone
-Require Server Identification (Uncheck)
-Click Close
3. Custom Level > Medium
4. ActiveX Controls Plugins
-Allow previously unused ActiveX controls > Enable
-Allow scriptlets > Enable
-Automatic Prompting for ActiveX controls > Enable
-Download unisgned ActiveX controls > Enable
-Initialize & script ActiveX controls not marked safe for scripting > Enable
-Run ActiveX controls and plugins > Enable
5. Click OK to close Security Settings Window
6. Click OK to close Internet Options Window

MACHINE ACTION SETTINGS:

1. Log into the K1000 Admin UI
2. Settings > Control Panel > General Settings
3. Scroll down to Machine Actions > Edit Mode
4. Verify the path variables to the VNC Executable on the PC
-Default is "%ProgramFiles%\\ultravnc\\vncviewer.exe" KACE_HOST_NAME [change this to reflect the actual path, if needed]
5. Click 'Set Actions' button

Note: When using Windows 7 64-bit and IE8 you must use the full path to the vncviewer.exe in the machine action settings.

Example:

"C:\\Program Files\\ultravnc\\vncviewer.exe" KACE_HOST_NAME

If your Internet Explorer settings are correct, and you continue to receive this error, also verify that the executable for the Machine Action command is in your system path. For example, if you are using the Dameware option, the path to dwrcc.exe must be in your system path for the command to launch.

Answer Summary:
Cancel
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Answer Chosen by the Author

1

Ok I found a great solution to my own problem. I have VNC Viewer Plus, and I'm not sure if that gives me more capability, but this is the approach that I took so that I could have VNC auto-popup without even having to change IE settings, or add my kace addresses to my "Trusted Sites"

kvm://admin:@KACE_HOST_NAME.yourdomainnamehere.com

This is using the syntax found after running:

C:\Program Files (x86)\RealVNC\VNCViewerPlus\vncviewerplus.exe /?

And like most "Help" commands, it gives you the entire list of options available to you via kvm:// or cmd.exe

Answered 07/31/2015 by: AeroMIS
White Belt

Please log in to comment

Answers

Answer this question or Comment on this question for clarity