Ran into something today which is really weird, I was doing some tests with the GP to push out Kace 1.5.10 and I added a new PC to the GP, Kace installed itself in the background the AMP service was running yet it still didn't appear in the Inventory. 

Any ideas on how I might go about troubleshooting this? 

 

*Just to add, machines currently on the inventory seem to be updating fine, it's just new machines.

 

Answer Summary:
Cancel
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Community Chosen Answer

5

Ahh, I think I found the issue. I havn't configured the new .MSI and the amp.conf doesn't have the correct server details thus It's unable to communicate with the Kace Server.

Answered 05/16/2013 by: Mobzy
Third Degree Blue Belt

  • possible solution here: Copy a working amp.conf to all affected machines or run AMPTools.exe -resetconf host=CORRECT_K1
    • This should work too assuming the hostname can be resolved:

      ampagent.exe -host=HOST_NAME
  • This content is currently hidden from public view.
    Reason: Removed by member request
    For more information, visit our FAQ's.
  • It's only a few machines that have this issue and they are only used for tests but that is handy to know.

    Question is, I'm going to roll it out to a lot of machines soon so what's the best way to resolve this issue? I don't know what I'm doing wrong with the .msi for it not to have the correct Kace server details?
    • This content is currently hidden from public view.
      Reason: Removed by member request
      For more information, visit our FAQ's.
    • Rename the ampagent-5.x.xxxxx-x86.msi to include your host name. e.g. ampagent-5.3.44367-x86_hostname.company.com.msi

      http://www.kace.com/support/resources/kb/article/installing-the-kace-k1000-agent-through-windows-group-policy
    • What's your full command line you are using to install?
Please log in to comment

Answers

3

if you want to use the GP to push it out you can use the host switch with the MSI or rename the msi to include the host name.

ampagent-5.4.10622-x86.msi HOST=kbox.company.com

ampagent-5.4.10622-x86_kbox.company.com.msi

http://blog.kace.com/2012/05/24/options-for-deploying-the-k1000-agent/

Answered 05/16/2013 by: SMal.tmcc
Red Belt

  • Yeah, that's been done but it still doesn't seem to work which is weird.
Please log in to comment
2

If your not running DHCP within your infrastructure you can update the inventory as follows:

K1000 > Settings >K1000 Agent > Advanced Provisioning

Specify the IP range that you give your users and ensure that you wish to push down the correct and upto date K1000 Agent. You can either run this on a schedule or run one time. Perhaps im missing the point but if you simply want to update the inventory then this should do it.

Answered 05/16/2013 by: k4rl@TES
Senior Purple Belt

  • Infact what am I talking about. Ofocurse you can do this if you have DHCP implemented. Just state the specific range. Had a moment there. My bad :)
  • Ah great! That will come in handy! :) Thanks
Please log in to comment
Answer this question or Comment on this question for clarity