Have ran runkbot.exe 4 0 and this is what I get.

C:\Program Files (x86)\Dell\KACE>runkbot.exe 4 0
[2017-02-01.15:11:54][runkbot:GetKbot                 ] Kbot [4-0] not found locally, downloading ...
kbot[4:0] @ 2017-02-01T15:11:54 (status) START
kbot[4:0] @ 2017-02-01T15:11:54 (output) Running as SYSTEM
kbot[4:0] @ 2017-02-01T15:11:54 (activity) Launching program: 'C:\Program Files (x86)\Dell\KACE\KDeploy' '-custominventory' wait='true'
[2017-02-01.15:11:54][runkbot:GetIdOfActiveUser       ] GetIdOfActiveUser: SECURITY_LOGON_TYPE: 2(18) There are no more files.

[2017-02-01.15:11:54][runkbot:KLaunchSession::CreateSe] KLaunchSession::CreateSessionOnDesktop: Failed to set token information: 0x522
kbot[4:0] @ 2017-02-01T15:11:55 (output) *   Trying 10.0.252.60...
kbot[4:0] @ 2017-02-01T15:11:55 (output) * Connected to kbox (10.0.252.60) port 80 (#0)
kbot[4:0] @ 2017-02-01T15:11:55 (output) > POST /service/kbservice.php?request=GetCustomInventoryRules HTTP/1.1
kbot[4:0] @ 2017-02-01T15:11:55 (output) Host: kbox
kbot[4:0] @ 2017-02-01T15:11:55 (output) Accept: */*
kbot[4:0] @ 2017-02-01T15:11:55 (output) KUID: 1D218B36-72AE-4279-9507-8A7A79D8D81A
kbot[4:0] @ 2017-02-01T15:11:55 (output) Content-Length: 193
kbot[4:0] @ 2017-02-01T15:11:55 (output) Expect: 100-continue
kbot[4:0] @ 2017-02-01T15:11:55 (output) Content-Type: multipart/form-data; boundary=------------------------d53915e3b19ec6e0
kbot[4:0] @ 2017-02-01T15:11:55 (output)
kbot[4:0] @ 2017-02-01T15:11:55 (output) < HTTP/1.1 100 Continue
kbot[4:0] @ 2017-02-01T15:11:55 (output) < HTTP/1.1 200 OK
kbot[4:0] @ 2017-02-01T15:11:55 (output) < Date: Wed, 01 Feb 2017 20:11:54 GMT
kbot[4:0] @ 2017-02-01T15:11:55 (output) < Server: Apache
kbot[4:0] @ 2017-02-01T15:11:55 (output) < Expires: Thu, 19 Nov 1981 08:52:00 GMT
kbot[4:0] @ 2017-02-01T15:11:55 (output) < Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
kbot[4:0] @ 2017-02-01T15:11:55 (output) < Pragma: no-cache
kbot[4:0] @ 2017-02-01T15:11:55 (output) < Set-Cookie: kboxid=pf4ojm72ds61qcjuj6q1f6coh0; path=/; HttpOnly
kbot[4:0] @ 2017-02-01T15:11:55 (output) < Access-Control-Allow-Headers: x-dell-auth-timestamp, x-dell-auth-key, x-dell-auth-signature, accept, origin, content-type
kbot[4:0] @ 2017-02-01T15:11:55 (output) < Access-Control-Allow-Origin: *
kbot[4:0] @ 2017-02-01T15:11:55 (output) < Access-Control-Allow-Methods: PUT, DELETE, POST, GET, OPTIONS
kbot[4:0] @ 2017-02-01T15:11:55 (output) < X-DellKACE-Appliance: k1000
kbot[4:0] @ 2017-02-01T15:11:55 (output) < X-DellKACE-Host: kbox
kbot[4:0] @ 2017-02-01T15:11:55 (output) < X-DellKACE-Version: 6.4.120822
kbot[4:0] @ 2017-02-01T15:11:55 (output) < X-KBOX-WebServer: kbox
kbot[4:0] @ 2017-02-01T15:11:55 (output) < X-KBOX-Version: 6.4.120822
kbot[4:0] @ 2017-02-01T15:11:55 (output) < Cache-Control: private, no-cache, no-store, proxy-revalidate, no-transform
kbot[4:0] @ 2017-02-01T15:11:55 (output) < Transfer-Encoding: chunked
kbot[4:0] @ 2017-02-01T15:11:55 (output) < Content-Type: text/html; charset=utf-8
kbot[4:0] @ 2017-02-01T15:11:55 (output) <
kbot[4:0] @ 2017-02-01T15:11:55 (output) * Connection #0 to host kbox left intact
kbot[4:0] @ 2017-02-01T15:11:55 (output) *   Trying 10.0.252.60...
kbot[4:0] @ 2017-02-01T15:11:55 (output) * Connected to kbox (10.0.252.60) port 80 (#0)
kbot[4:0] @ 2017-02-01T15:11:55 (output) > POST /service/kbservice.php?request=HereisCustomInventoryResults HTTP/1.1
kbot[4:0] @ 2017-02-01T15:11:55 (output) Host: kbox
kbot[4:0] @ 2017-02-01T15:11:55 (output) Accept: */*
kbot[4:0] @ 2017-02-01T15:11:55 (output) KUID: 1D218B36-72AE-4279-9507-8A7A79D8D81A
kbot[4:0] @ 2017-02-01T15:11:55 (output) Content-Length: 195
kbot[4:0] @ 2017-02-01T15:11:55 (output) Expect: 100-continue
kbot[4:0] @ 2017-02-01T15:11:55 (output) Content-Type: multipart/form-data; boundary=------------------------27155a819b8fba6f
kbot[4:0] @ 2017-02-01T15:11:55 (output)
kbot[4:0] @ 2017-02-01T15:11:55 (output) < HTTP/1.1 100 Continue
kbot[4:0] @ 2017-02-01T15:11:55 (output) < HTTP/1.1 200 OK
kbot[4:0] @ 2017-02-01T15:11:55 (output) < Date: Wed, 01 Feb 2017 20:11:54 GMT
kbot[4:0] @ 2017-02-01T15:11:55 (output) < Server: Apache
kbot[4:0] @ 2017-02-01T15:11:55 (output) < Expires: Thu, 19 Nov 1981 08:52:00 GMT
kbot[4:0] @ 2017-02-01T15:11:55 (output) < Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
kbot[4:0] @ 2017-02-01T15:11:55 (output) < Pragma: no-cache
kbot[4:0] @ 2017-02-01T15:11:55 (output) < Set-Cookie: kboxid=velk1i09mg81fv7t21mjlkrv64; path=/; HttpOnly
kbot[4:0] @ 2017-02-01T15:11:55 (output) < Access-Control-Allow-Headers: x-dell-auth-timestamp, x-dell-auth-key, x-dell-
auth-signature, accept, origin, content-type
kbot[4:0] @ 2017-02-01T15:11:55 (output) < Access-Control-Allow-Origin: *
kbot[4:0] @ 2017-02-01T15:11:55 (output) < Access-Control-Allow-Methods: PUT, DELETE, POST, GET, OPTIONS
kbot[4:0] @ 2017-02-01T15:11:55 (output) < X-DellKACE-Appliance: k1000
kbot[4:0] @ 2017-02-01T15:11:55 (output) < X-DellKACE-Host: kbox
kbot[4:0] @ 2017-02-01T15:11:55 (output) < X-DellKACE-Version: 6.4.120822
kbot[4:0] @ 2017-02-01T15:11:55 (output) < X-KBOX-WebServer: kbox
kbot[4:0] @ 2017-02-01T15:11:55 (output) < X-KBOX-Version: 6.4.120822
kbot[4:0] @ 2017-02-01T15:11:55 (output) < Cache-Control: private, no-cache, no-store, proxy-revalidate, no-transform
kbot[4:0] @ 2017-02-01T15:11:55 (output) < Content-Length: 0
kbot[4:0] @ 2017-02-01T15:11:55 (output) < Content-Type: text/html; charset=utf-8
kbot[4:0] @ 2017-02-01T15:11:55 (output) <
kbot[4:0] @ 2017-02-01T15:11:55 (output) * Connection #0 to host kbox left intact
kbot[4:0] @ 2017-02-01T15:11:55 (output) Launched Process: KDeploy
kbot[4:0] @ 2017-02-01T15:11:55 (status) Submitted custom inventory results...
kbot[4:0] @ 2017-02-01T15:11:55 (output) Running as SYSTEM
kbot[4:0] @ 2017-02-01T15:11:55 (activity) Launching program: 'C:\Program Files (x86)\Dell\KACE\KInventory' '-machine -silent -out "C:\ProgramData\Dell\KACE\inventory.xml"' wait='true'
[2017-02-01.15:11:55][runkbot:GetIdOfActiveUser       ] GetIdOfActiveUser: SECURITY_LOGON_TYPE: 2(18) There are no more files.

[2017-02-01.15:11:55][runkbot:KLaunchSession::CreateSe] KLaunchSession::CreateSessionOnDesktop: Failed to set token information: 0x522
kbot[4:0] @ 2017-02-01T15:12:08 (output) [2017-02-01.15:11:55][KInventory:runInventory         ] KInventory   Begin capturing Inventory...
kbot[4:0] @ 2017-02-01T15:12:08 (output) [2017-02-01.15:11:55][KInventory:GetIdOfActiveUser    ] GetIdOfActiveUser: SECURITY_LOGON_TYPE: 2(0) The operation completed successfully.
kbot[4:0] @ 2017-02-01T15:12:08 (output)
kbot[4:0] @ 2017-02-01T15:12:08 (output) [2017-02-01.15:11:55][KInventory:CInventoryData::Initi] KInventory   InventoryData attempting to open DB file [C]
kbot[4:0] @ 2017-02-01T15:12:08 (output) [2017-02-01.15:11:55][KInventory:CInventoryData::OpenD] KInventory   InventoryData opening DB
kbot[4:0] @ 2017-02-01T15:12:08 (output) [2017-02-01.15:11:55][KInventory:CInventoryData::OpenD] KInventory   InventoryData calling db.open
kbot[4:0] @ 2017-02-01T15:12:08 (output) [2017-02-01.15:11:55][KInventory:CInventoryData::Initi] KInventory   InventoryData opened DB successfully
kbot[4:0] @ 2017-02-01T15:12:08 (output) [2017-02-01.15:11:55][KInventory:CInventoryData::Initi] KInventory   InventoryData populated the DB
kbot[4:0] @ 2017-02-01T15:12:08 (output) [2017-02-01.15:11:55][KInventory:GetIdOfActiveUser    ] GetIdOfActiveUser: SECURITY_LOGON_TYPE: 2(18) There are no more files.
kbot[4:0] @ 2017-02-01T15:12:08 (output)
kbot[4:0] @ 2017-02-01T15:12:08 (output) [2017-02-01.15:11:55][KInventory:KLaunchSession::Creat] KLaunchSession::CreateSessionOnDesktop: Failed to set token information: 0x522
kbot[4:0] @ 2017-02-01T15:12:08 (output) [2017-02-01.15:11:55][KInventory:GetIdOfActiveUser    ] GetIdOfActiveUser: SECURITY_LOGON_TYPE: 2(18) There are no more files.
kbot[4:0] @ 2017-02-01T15:12:08 (output)
kbot[4:0] @ 2017-02-01T15:12:08 (output) [2017-02-01.15:11:55][KInventory:KLaunchSession::Creat] KLaunchSession::CreateSessionOnDesktop: Failed to set token information: 0x522
kbot[4:0] @ 2017-02-01T15:12:08 (output) [2017-02-01.15:12:04][KInventory:GetIdOfActiveUser    ] GetIdOfActiveUser: SECURITY_LOGON_TYPE: 2(18) There are no more files.
kbot[4:0] @ 2017-02-01T15:12:08 (output)
kbot[4:0] @ 2017-02-01T15:12:08 (output) [2017-02-01.15:12:04][KInventory:KLaunchSession::Creat] KLaunchSession::CreateSessionOnDesktop: Failed to set token information: 0x522
kbot[4:0] @ 2017-02-01T15:12:08 (output) [2017-02-01.15:12:04][KInventory:GetIdOfActiveUser    ] GetIdOfActiveUser: SECURITY_LOGON_TYPE: 2(18) There are no more files.
kbot[4:0] @ 2017-02-01T15:12:08 (output)
kbot[4:0] @ 2017-02-01T15:12:08 (output) [2017-02-01.15:12:04][KInventory:KLaunchSession::Creat] KLaunchSession::CreateSessionOnDesktop: Failed to set token information: 0x522
kbot[4:0] @ 2017-02-01T15:12:08 (output) [2017-02-01.15:12:05][KInventory:GetIdOfActiveUser    ] GetIdOfActiveUser: SECURITY_LOGON_TYPE: 2(18) There are no more files.
kbot[4:0] @ 2017-02-01T15:12:08 (output)
kbot[4:0] @ 2017-02-01T15:12:08 (output) [2017-02-01.15:12:05][KInventory:KLaunchSession::Creat] KLaunchSession::CreateSessionOnDesktop: Failed to set token information: 0x522
kbot[4:0] @ 2017-02-01T15:12:08 (output) [2017-02-01.15:12:05][KInventory:GetIdOfActiveUser    ] GetIdOfActiveUser: SECURITY_LOGON_TYPE: 2(18) There are no more files.
kbot[4:0] @ 2017-02-01T15:12:08 (output)
kbot[4:0] @ 2017-02-01T15:12:08 (output) [2017-02-01.15:12:05][KInventory:KLaunchSession::Creat] KLaunchSession::CreateSessionOnDesktop: Failed to set token information: 0x522
kbot[4:0] @ 2017-02-01T15:12:08 (output) [2017-02-01.15:12:06][KInventory:GetIdOfActiveUser    ] GetIdOfActiveUser: SECURITY_LOGON_TYPE: 2(18) There are no more files.
kbot[4:0] @ 2017-02-01T15:12:08 (output)
kbot[4:0] @ 2017-02-01T15:12:08 (output) [2017-02-01.15:12:06][KInventory:KLaunchSession::Creat] KLaunchSession::CreateSessionOnDesktop: Failed to set token information: 0x522
kbot[4:0] @ 2017-02-01T15:12:08 (output) [2017-02-01.15:12:08][KInventory:runInventory         ] KInventory   Inventory Capture completed and stored in C:\ProgramData\Dell\KACE\inventory.xml
kbot[4:0] @ 2017-02-01T15:12:08 (output) [InventoryArgs.cpp::_parseArgs] SUCCESS
kbot[4:0] @ 2017-02-01T15:12:08 (output) [CInventoryRenderMachineXml::Initialize]
kbot[4:0] @ 2017-02-01T15:12:08 (output)    reportPath  : C:\ProgramData\Dell\KACE\inventory.xml
kbot[4:0] @ 2017-02-01T15:12:08 (output) Launched Process: KInventory
kbot[4:0] @ 2017-02-01T15:12:08 (activity) Launching program: 'C:\Program Files (x86)\Dell\KACE\KCOPY' '"C:\ProgramData\Dell\KACE\inventory.xml" "http://kbox:80/service/inventory.php?KUID=1D218B36-72AE-4279-9507-8A7A79D8D81A&VERSION=6.4.522"' wait='true'
[2017-02-01.15:12:08][runkbot:GetIdOfActiveUser       ] GetIdOfActiveUser: SECURITY_LOGON_TYPE: 2(18) There are no more files.

[2017-02-01.15:12:08][runkbot:KLaunchSession::CreateSe] KLaunchSession::CreateSessionOnDesktop: Failed to set token information: 0x522
kbot[4:0] @ 2017-02-01T15:12:08 (output) [2017-02-01.15:12:08][KCopy:UploadUsingCurl           ] UploadFile:  Server gzip compression is active
kbot[4:0] @ 2017-02-01T15:12:08 (output) [2017-02-01.15:12:08][KCopy:GZipFile                  ] GZipFile: size of file C:\ProgramData\Dell\KACE\inventory.xml to zip is 371197
kbot[4:0] @ 2017-02-01T15:12:08 (output) [2017-02-01.15:12:08][KCopy:UploadUsingCurl           ] UploadFile:  uploading file C:\ProgramData\Dell\KACE\inventory.xml.gz to http://kbox:80/service/inventory.php?KUID=1D218B36-72AE-4279-9507-8A7A79D8D81A&VERSION=6.4.522
kbot[4:0] @ 2017-02-01T15:12:08 (output) [2017-02-01.15:12:08][KCopy:UploadUsingCurl           ] UploadFile, curl stderr is stored in C:\ProgramData\Dell\KACE\user\KAgent.log
kbot[4:0] @ 2017-02-01T15:12:08 (output) Error renaming log file C:\ProgramData\Dell\KACE\user\KAgent.log to C:\ProgramData\Dell\KACE\user\KAgent1.log: Permission denied (13)
kbot[4:0] @ 2017-02-01T15:12:08 (output) Error writing to log file: C:\ProgramData\Dell\KACE\user\KAgent.log (13) Permission denied
kbot[4:0] @ 2017-02-01T15:12:08 (output) [2017-02-01.15:12:08][KCopy:UploadUsingCurl           ] UploadFile:  Content-Encoding: gzip added to HTTP Header.
kbot[4:0] @ 2017-02-01T15:12:08 (output) Error renaming log file C:\ProgramData\Dell\KACE\user\KAgent.log to C:\ProgramData\Dell\KACE\user\KAgent1.log: Permission denied (13)
kbot[4:0] @ 2017-02-01T15:12:08 (output) Error writing to log file: C:\ProgramData\Dell\KACE\user\KAgent.log (13) Permission denied
kbot[4:0] @ 2017-02-01T15:12:08 (output) [2017-02-01.15:12:08][KCopy:UploadUsingCurl           ] UploadFile: Uploaded to http://kbox:80/service/inventory.php?KUID=1D218B36-72AE-4279-9507-8A7A79D8D81A&VERSION=6.4.522 Upload speed: 140776.000000 bytes/second
kbot[4:0] @ 2017-02-01T15:12:08 (output) Error renaming log file C:\ProgramData\Dell\KACE\user\KAgent.log to C:\ProgramData\Dell\KACE\user\KAgent1.log: Permission denied (13)
kbot[4:0] @ 2017-02-01T15:12:08 (output) Error writing to log file: C:\ProgramData\Dell\KACE\user\KAgent.log (13) Permission denied
kbot[4:0] @ 2017-02-01T15:12:08 (output) [2017-02-01.15:12:08][KCopy:UploadUsingCurl           ] UploadFile:  Server gzip compression cleanup.
kbot[4:0] @ 2017-02-01T15:12:08 (output) Launched Process: KCOPY
kbot[4:0] @ 2017-02-01T15:12:08 (status) Submitted inventory to k1000...
kbot[4:0] @ 2017-02-01T15:12:08 (status) FINISH (In state 'verification_success')
[2017-02-01.15:12:08][runkbot:UploadUsingCurl         ] UploadFile:  Server gzip compression is active
[2017-02-01.15:12:08][runkbot:GZipFile                ] GZipFile: size of file C:\Users\acifani\AppData\Local\Temp\dklA5F3.tmp to zip is 12861
[2017-02-01.15:12:08][runkbot:UploadUsingCurl         ] UploadFile:  uploading file C:\Users\acifani\AppData\Local\Temp\dklA5F3.tmp.gz to http://kbox/service/kbot_upload.php?BAD_MAC_IP=10.100.50.200&filename=KBOT_LOG.txt&mac=1D218B36-72AE-4279-9507-8A7A79D8D81A&kbotId=4
[2017-02-01.15:12:08][runkbot:UploadUsingCurl         ] UploadFile, curl stderr is stored in C:\ProgramData\Dell\KACE\user\KAgent.log
Error renaming log file C:\ProgramData\Dell\KACE\user\KAgent.log to C:\ProgramData\Dell\KACE\user\KAgent1.log: Permission denied (13)
Error writing to log file: C:\ProgramData\Dell\KACE\user\KAgent.log (13) Permission denied
[2017-02-01.15:12:08][runkbot:UploadUsingCurl         ] UploadFile:  Content-Encoding: gzip added to HTTP Header.
Error renaming log file C:\ProgramData\Dell\KACE\user\KAgent.log to C:\ProgramData\Dell\KACE\user\KAgent1.log: Permission denied (13)
Error writing to log file: C:\ProgramData\Dell\KACE\user\KAgent.log (13) Permission denied
[2017-02-01.15:12:08][runkbot:UploadUsingCurl         ] UploadFile: Uploaded to http://kbox/service/kbot_upload.php?BAD_MAC_IP=10.100.50.200&filename=KBOT_LOG.txt&mac=1D218B36-72AE-4279-9507-8A7A79D8D81A&kbotId=4 Upload speed: 39872.000000 bytes/second
Error renaming log file C:\ProgramData\Dell\KACE\user\KAgent.log to C:\ProgramData\Dell\KACE\user\KAgent1.log: Permission denied (13)
Error writing to log file: C:\ProgramData\Dell\KACE\user\KAgent.log (13) Permission denied
[2017-02-01.15:12:08][runkbot:UploadUsingCurl         ] UploadFile:  Server gzip compression cleanup.
[2017-02-01.15:12:08][runkbot:CleanupLog              ] Cleaning up log file [C:\Users\acifani\AppData\Local\Temp\dklA5F3.tmp]

1 Comment   [ + ] Show Comment

Comments

  • Any luck? I have the same problem
    • I rebuild the WMI you can find out how to do it here: https://goo.gl/Zok38S it can take anywhere from a few minutes to a few hours for kace to update itself so don't be worried if it doesn't show up right away.
Please log in to comment

Answers

0
You'll need to run runkbot from an elevated command prompt, but '4 0' will run the inventory check-in script. Are you attempting to force an agent upgrade to 7.0? The agent upgrade script is ID=5, so you'd run 'runkbot 5 0'.
Answered 02/01/2017 by: airwolf
Tenth Degree Black Belt

  • Alright. So I ran it with the 5 0 and last time I did run it with elevated privileges. This is what I got this time.

    C:\Program Files (x86)\Dell\KACE>runkbot.exe 5 0
    [2017-02-01.16:22:05][runkbot:GetKbot ] Kbot [5-0] not found locally, downloading ...
    kbot[5:0] @ 2017-02-01T16:22:05 (status) START
    [2017-02-01.16:22:05][runkbot:DownloadDependency ] Downloading dependency from KBOX location [http://kbox/packages/kbots/5/ampagent-6.4.522-x86.msi.5162a414cf261ef37b5b8c34d6a4451d]
    kbot[5:0] @ 2017-02-01T16:22:09 (output) Running as SYSTEM
    kbot[5:0] @ 2017-02-01T16:22:09 (activity) Launching program: 'C:\WINDOWS\System32\cmd.exe' '/c copy "$(KACE_DEPENDENCY_DIR)\$(1)" "%temp%\$(1)"' wait='true'
    [2017-02-01.16:22:09][runkbot:GetIdOfActiveUser ] GetIdOfActiveUser: SECURITY_LOGON_TYPE: 2(18) There are no more files.

    [2017-02-01.16:22:09][runkbot:KLaunchSession::CreateSe] KLaunchSession::CreateSessionOnDesktop: Failed to set token information: 0x522
    kbot[5:0] @ 2017-02-01T16:22:09 (output) The system cannot find the path specified.
    kbot[5:0] @ 2017-02-01T16:22:09 (output) Creating process returned non-zero: C:\WINDOWS\System32\cmd.exe /c copy "$(KACE_DEPENDENCY_DIR)\$(1)" "%temp%\$(1)": (0) The operation completed successfully.

    kbot[5:0] @ 2017-02-01T16:22:09 (output) Error Code: 0
    kbot[5:0] @ 2017-02-01T16:22:09 (output) Status Code: 1
    [2017-02-01.16:22:09][runkbot:ProcessOps_LaunchProgram] runkbot : create kbot process returned non-zero: error code 0 or status code 1(0) The operation completed successfully.

    kbot[5:0] @ 2017-02-01T16:22:09 (status) FINISH (In state 'remediation_success')
    [2017-02-01.16:22:09][runkbot:UploadUsingCurl ] UploadFile: Server gzip compression is active
    [2017-02-01.16:22:09][runkbot:GZipFile ] GZipFile: size of file C:\Users\acifani\AppData\Local\Temp\dklE5B4.tmp to zip is 752
    [2017-02-01.16:22:09][runkbot:UploadUsingCurl ] UploadFile: uploading file C:\Users\acifani\AppData\Local\Temp\dklE5B4.tmp.gz to http://kbox/service/kbot_upload.php?BAD_MAC_IP=10.100.50.200&filename=KBOT_LOG.txt&mac=1D218B36-72AE-4279-9507-8A7A79D8D81A&kbotId=5
    [2017-02-01.16:22:09][runkbot:UploadUsingCurl ] UploadFile, curl stderr is stored in C:\ProgramData\Dell\KACE\user\KAgent.log
    Error renaming log file C:\ProgramData\Dell\KACE\user\KAgent.log to C:\ProgramData\Dell\KACE\user\KAgent1.log: Permission denied (13)
    Error writing to log file: C:\ProgramData\Dell\KACE\user\KAgent.log (13) Permission denied
    [2017-02-01.16:22:09][runkbot:UploadUsingCurl ] UploadFile: Content-Encoding: gzip added to HTTP Header.
    Error renaming log file C:\ProgramData\Dell\KACE\user\KAgent.log to C:\ProgramData\Dell\KACE\user\KAgent1.log: Permission denied (13)
    Error writing to log file: C:\ProgramData\Dell\KACE\user\KAgent.log (13) Permission denied
    [2017-02-01.16:22:09][runkbot:UploadUsingCurl ] UploadFile: Uploaded to http://kbox/service/kbot_upload.php?BAD_MAC_IP=10.100.50.200&filename=KBOT_LOG.txt&mac=1D218B36-72AE-4279-9507-8A7A79D8D81A&kbotId=5 Upload speed: 7489.000000 bytes/second
    Error renaming log file C:\ProgramData\Dell\KACE\user\KAgent.log to C:\ProgramData\Dell\KACE\user\KAgent1.log: Permission denied (13)
    Error writing to log file: C:\ProgramData\Dell\KACE\user\KAgent.log (13) Permission denied
    [2017-02-01.16:22:09][runkbot:UploadUsingCurl ] UploadFile: Server gzip compression cleanup.
    [2017-02-01.16:22:09][runkbot:CleanupLog ] Cleaning up log file [C:\Users\acifani\AppData\Local\Temp\dklE5B4.tmp]
    • You could have a corrupt agent installation, but there are other possibilities. Please have a look at https://support.quest.com/kb/129683 for more info regarding the BAD_MAC_IP error I notice toward the bottom of the log.
      • Ive uninstalled and reinstalled numerous times because I thought that was the case. I checked that link and tried a few different methods that it offered, none of them worked. Im wondering why it says:

        Error renaming log file C:\ProgramData\Dell\KACE\user\KAgent.log to C:\ProgramData\Dell\KACE\user\KAgent1.log: Permission denied (13)
        Error writing to log file: C:\ProgramData\Dell\KACE\user\KAgent.log (13) Permission denied
        [2017-02-01.16:22:09][runkbot:UploadUsingCurl ] UploadFile: Uploaded to http://kbox/service/kbot_upload.php?

        What is it that is causing the permissions to be denied? I am an administrator in my organization and my PC is the only one that is not showing up in Kace. The only difference between mine and everyone else's is mine is Win10 Enterprise Build 14393 and everyone else is on Win7 Enterprise & Win10 Enterprise LTSB Build 10240.
      • The inability to write to the log is a known issue with the 6.4 agent and does not affect the agent's ability to perform inventory. Please contact KACE Support so we can further investigate this issue for you. Thanks!
Please log in to comment
Answer this question or Comment on this question for clarity