Hi Ninja community

We have nearly finished our Windows 10 scripted deployment using K2000 v3.7.120251. This has been a seamless process bar a couple of issues. One of them is proving hard to fix. About half way through the scripted install the laptop will run through a reboot cycle eventually showing the network selection page 'Choose a WiFi Network' which is  part of the OOBE process. As this requires human intervention this halts the automated process so I'm hoping someone here can take a look at our script (shown below) and let me know where we have gone wrong? In the script below there is an OOBE section about three quarters of the way down the page. There are two parameters which I believe may apply,

<SkipMachineOOBE>false</SkipMachineOOBE>

<SkipUserOOBE>false</SkipUserOOBE>

If I set either of these to 'true' the scripted install fails when trying to join the domain which is a setting that runs much earlier in the script. We have set both of these to false as shown however the 'Choose a WiFi Network' page keeps re-appearing. NOTE: this is the only OOBE page that appears, after this K2000 resumes and continues to run our custom script as normal Any help would be appreciated. As stated K2000 is on the latest version. We are deploying win 10 x 64 to three different dell latitudes, E5430, E7440 and E6430. We have a working windows 7 script which we have been working alongside to iron out the issues. Let me know if you need more info.

Cheers 







<?xml version="1.0" encoding="utf-8"?>

<unattend xmlns="urn:schemas-microsoft-com:unattend" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

  <settings pass="windowsPE">

    <component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">

      <UseConfigurationSet>true</UseConfigurationSet>

      <UserData>

        <AcceptEula>true</AcceptEula>

        <FullName>OB LIMITED</FullName>

        <Organization>OB LIMITED</Organization>

      </UserData>

      <ImageInstall>

        <OSImage>

          <InstallToAvailablePartition>true</InstallToAvailablePartition>

        </OSImage>

      </ImageInstall>

    </component>

    <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">

      <UILanguage>en-US</UILanguage>

      <SetupUILanguage>

        <UILanguage>en-US</UILanguage>

      </SetupUILanguage>

      <InputLocale>en-au</InputLocale>

      <SystemLocale>en-au</SystemLocale>

      <UserLocale>en-au</UserLocale>

    </component>

  </settings>

  <settings pass="specialize">

    <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">

      <RegisteredOwner>OB LIMITED</RegisteredOwner>

      <RegisteredOrganization>OB LIMITED</RegisteredOrganization>

      <ProductKey>XXXXX-XXXXX-XXXXX-XXXXX-XXXXX</ProductKey>

      <TimeZone>E. Australia Standard Time</TimeZone>

      <AutoLogon>

        <Enabled>true</Enabled>

        <Username>administrator</Username>

        <Password>

          <PlainText>true</PlainText>

          <Value>*********</Value>

        </Password>

        <LogonCount>3</LogonCount>

      </AutoLogon>

      <ComputerName>*</ComputerName>

    </component>

    <component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">

      <Identification>

        <JoinDomain>ob.local</JoinDomain>

        <Credentials>

          <Domain>ob.local</Domain>

          <Username>ob\administrator</Username>

          <Password>*****</Password>

        </Credentials>

      </Identification>

    </component>

    <component name="Microsoft-Windows-Deployment" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">

      <RunSynchronous>

        <RunSynchronousCommand wcm:action="add">

          <Path>reg add "HKLM\SOFTWARE\Policies\Microsoft\Windows NT\CurrentVersion\NetworkList\Signatures\FirstNetwork" /v Category /t REG_DWORD /d 00000000 /f</Path>

          <Description>Setting Network Location</Description>

          <Order>1</Order>

          <WillReboot>OnRequest</WillReboot>

        </RunSynchronousCommand>

      </RunSynchronous>

    </component>

  </settings>

  <settings pass="oobeSystem">

    <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">

      <OOBE>

        <HideEULAPage>true</HideEULAPage>

        <NetworkLocation>Work</NetworkLocation>

        <SkipMachineOOBE>false</SkipMachineOOBE>

        <SkipUserOOBE>false</SkipUserOOBE>

        <ProtectYourPC>3</ProtectYourPC>

      </OOBE>

      <Display>

        <ColorDepth>32</ColorDepth>

        <HorizontalResolution>1920</HorizontalResolution>

        <VerticalResolution>1080</VerticalResolution>

      </Display>

      <UserAccounts>

        <LocalAccounts>

          <LocalAccount wcm:action="add">

            <Name>administrator</Name>

            <Group>Administrators</Group>

            <Password>

              <Value>******</Value>

              <PlainText>true</PlainText>

            </Password>

          </LocalAccount>

        </LocalAccounts>

      </UserAccounts>

      <AutoLogon>

        <Password>

          <Value>*******</Value>

          <PlainText>true</PlainText>

        </Password>

        <Username>Administrator</Username>

        <Enabled>true</Enabled>

        <LogonCount>5</LogonCount>

      </AutoLogon>

    </component>

    <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">

      <InputLocale>en-au</InputLocale>

      <SystemLocale>en-au</SystemLocale>

      <UILanguage>en-au</UILanguage>

      <UserLocale>en-au</UserLocale>

    </component>

  </settings>

</unattend>

Answer Summary:
Cancel
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Answer Chosen by the Author

3
Try adding this to the <OOBE> section:
<HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>

If that doesn't work you can check my example unattend file here:
https://github.com/csteelatgburg/scripts/blob/master/Windows/Win10Unattend.xml

Answered 02/16/2016 by: chucksteel
Red Belt

  • Thanks Chucksteel that worked!
Please log in to comment

Answers

1
I would do what @chucksteel mentions above and use ICD (Image Customization Designer) to create a wireless config package.
-Corey
Answered 02/16/2016 by: cserrins
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity