Very odd issue, we have a perfectly working k2000 KBE that will image fine when inside of our firewall, in one of our regional offices we have been unable to do this so far, we have muddle through to the stage where its getting an IP address and then attempting to launch the KBE, but when getting ot the ***Mounting the KBOX install shares we get:

System error 67 has occurred.

 

The network name was not found 

ERROR: Unable to mKBOX share at \\â””¿Ë¾Y\peinst 

(and yes its with those odd characters)

on our firewall we see nothing hitting it to indicate a port being blocked. and after it fails i can get an IP address and can ping the IP and hostname of our K2000.

None of this happens from inside our main office, so the system seems to be working perfectly, i was wondering if anyone had any ideas on this - we are doing this on a CISCO 1841

DHCP config on this is as follows to get us this far:

 

ip dhcp pool Test-WAN

   network 172.30.10.0 255.255.255.0

   bootfile kbox2000.0

   next-server 192.168.28.89

   domain-name ourdomain.com

   default-router 172.30.10.1

   dns-server 192.168.21.10 192.168.21.11

   option 66 ip 192.168.28.89 (our k2000 ip)


any thoughts would be really appriciated.


Answer Summary:
Cancel
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Answers

1

Hi Trentderby,

Can you manually mount the PEINST share? 

When it fails, type this command:    net use \\%K2000_IP%\peinst Y:

If it mounts, try browsing to Y: and see if it you can access the contents.

Also what version if your K2000 running?

Answered 11/22/2012 by: ruanben
White Belt

  • Also , if you're on 3.4 , make sure your driver share password does not include any special characters. eg. ?/#@ .

    If thats the case, you'll have to change the driver share password in the K2000 , build a new KBE with the new password in it, and replicate this KBE over to the RSA.
  • ah, im on 3.4 and the password does have an ! in it.

    ill change this now.
  • seems to still be occuring, i have changed the driver share password to not have ! in it and no other odd characters. when trying to run the command net use \\%K2000_IP%\peinst Y: im getting Error 53 - network path was not found. im going to try a reboot and see what occurs.


    which i have just done and the same issue occurs.
  • just tested and the issue still happens to be outside of our network, when your in our network it all works fine.
  • After changing the password, did you create a new KBE?

    In order for the password to be updated, a new KBE needs to be created.

    If its still happening with a new KBE, i'd suggest to contact your local kace support.
  • to answer yes i did create a new KBE after changing the password, this is the response i got from kace support:

    Hi Terence,

    if I correctly understand the issue the most effective way would be a K2 RSA which is installed in the branch office.
    The RSA can be downloaded from the main K2.

    As far as I understood:
    You try to install in the branch office from the main K2.
    This fails.
    If you try to install in the main office all is correct.

    For branch offices we have the RSA (remote site appliance)



    so i need to setup remove site appliances for each of our regional office? i must say i am a bit surprised that that seems to be the fix for this issue.
    • Yes, see my response to your next question...
  • well i have been given a fantastic gem from support:

    Hi Terence,

    correct, it is a firewall issue.
    Our best practices are RSA.
    Please contact the vendor of your firewall.

    Kind regards
    ----------------------------

    so helpful.

    not even, please contact the vendor of your firewall, we normally recommend you have ports x and x unblocked, and in our general experience there is issues with x firewalls, you might want to ask them if x is enabled.

    just a "contact the vendor of your firewall"
    • Here is the list of ports from KACE: http://www.kace.com/support/resources/kb/article/Network-ports-needed-for-K2000-appliance-operation

      Their answer may seem frustrating (and seems par for the course in my experience), but it makes sense. They can't be expected to know all of the different firewall configurations that are out there, but they do have the port list above available for you to use. Also, setting up RSA's is very easy and will cut down on the traffic across your WAN significantly. So it really is the best thing to do in your situation, in my opinion.
  • Fair enough, but the information you have provided is more than i got from support, normally you would expect the support to be more helpfull than the forums considering they may deal with these types of issues all the time. anyway, ill try those ports and see how i get on, thanks.
  • ok, we are now at the stage where its mounting when we run your commands:

    net use \\%K2000_IP%\peinst Y:

    i checked the logs on the server and we get:
    Nov 27 14:15:44 KBOX2 in.tftpd[65191]: RRQ from 172.30.10.7 filename kbox2000.0
    Nov 27 14:15:44 KBOX2 in.tftpd[65191]: tftp: client does not accept options
    Nov 27 14:15:44 KBOX2 in.tftpd[65192]: RRQ from 172.30.10.7 filename kbox2000.0
    Nov 27 14:15:44 KBOX2 in.tftpd[65193]: RRQ from 172.30.10.7 filename pxelinux.cfg/44454c4c-3100-1048-8042-b2c04f33334a
    Nov 27 14:15:44 KBOX2 in.tftpd[65194]: RRQ from 172.30.10.7 filename pxelinux.cfg/01-00-1c-23-0a-f0-f6
    Nov 27 14:15:44 KBOX2 in.tftpd[65195]: RRQ from 172.30.10.7 filename pxelinux.cfg/AC1E0A07 remapped to pxelinux.cfg/ac1e0a07
    Nov 27 14:15:44 KBOX2 in.tftpd[65196]: RRQ from 172.30.10.7 filename pxelinux.cfg/AC1E0A0 remapped to pxelinux.cfg/ac1e0a0
    Nov 27 14:15:44 KBOX2 in.tftpd[65197]: RRQ from 172.30.10.7 filename pxelinux.cfg/AC1E0A remapped to pxelinux.cfg/ac1e0a
    Nov 27 14:15:44 KBOX2 in.tftpd[65200]: RRQ from 172.30.10.7 filename pxelinux.cfg/AC1E0 remapped to pxelinux.cfg/ac1e0
    Nov 27 14:15:44 KBOX2 in.tftpd[65202]: RRQ from 172.30.10.7 filename pxelinux.cfg/AC1E remapped to pxelinux.cfg/ac1e
    Nov 27 14:15:44 KBOX2 in.tftpd[65203]: RRQ from 172.30.10.7 filename pxelinux.cfg/AC1 remapped to pxelinux.cfg/ac1
    Nov 27 14:15:44 KBOX2 in.tftpd[65204]: RRQ from 172.30.10.7 filename pxelinux.cfg/AC remapped to pxelinux.cfg/ac
    Nov 27 14:15:44 KBOX2 in.tftpd[65205]: RRQ from 172.30.10.7 filename pxelinux.cfg/A remapped to pxelinux.cfg/a
    Nov 27 14:15:44 KBOX2 in.tftpd[65206]: RRQ from 172.30.10.7 filename pxelinux.cfg/default
    Nov 27 14:15:44 KBOX2 in.tftpd[65207]: RRQ from 172.30.10.7 filename vesamenu.c32
    Nov 27 14:15:44 KBOX2 in.tftpd[65210]: RRQ from 172.30.10.7 filename pxelinux.cfg/default
    Nov 27 14:15:44 KBOX2 in.tftpd[65211]: RRQ from 172.30.10.7 filename kbox2000.png
    Nov 27 14:15:55 KBOX2 in.tftpd[65212]: RRQ from 172.30.10.7 filename memdisk
    Nov 27 14:15:55 KBOX2 in.tftpd[65213]: RRQ from 172.30.10.7 filename kbe0054.iso

    the bit i find interesting is the

    ": tftp: client does not accept options"

    part. could this be something do do with the router?
  • sorry as a side, its still not working with the same errors.
  • i have a support call tomorrow morning hopefully ill have some answers then.
  • OK, an extremely helpful support representative resolved this for me. the issue was with DHCP Option 66 on the Cisco kit, when running this it saw the share as: \\ââ€â€Â¿Ã‹Â¾Y\peinst

    the solution was to bypass this by using a tool called the KBE manipulator, with this we created a new KBE with the IP address hard coded instead of using the DHCP options for the router.

    this allowed us to boot directly into the KBE with no issues.

    if anyone else encounters this issue it will require a support call but you can refer to this ticket number:

    TICK: 258561
Please log in to comment
Answer this question or Comment on this question for clarity