Is there a way to stop ticket looping in the Service Desk of the K1000?  We mostly have tickets created by emails and some of those emails are "no reply" addresses.  We get a an email to the helpdesk, it send an acknowledgement email, the no reply sends back a "do not reply" email, help desk replys again with an acknowledgement, and so on.  Before we know it, there are 10000 worthless tickets that have to be cleared out of the queue.  I know that addresses can be set to be ignored, but that doesn't help if we don't know from where we will get the autoreply.  Suggestions?

3 Comments   [ + ] Show Comments


  • I don't think you can set this from KACE. I had a similar problem with bounced emails yesterday causing tickets to be filled up with non-delivery notifications. And once in awhile, a user will submit a ticket, and promptly leave for vacation, with their out of office turned on.

    The only way to address this is either from the mail server (in Exchange, that would most likely be mail flow rules) or in the service that sends the no reply emails. It sounds like in your case these emails are coming in from outside your organization. If you are required to accept tickets from no reply submitters for some reason, I don't see any real options to solve this.

    I do wonder though, when a ticket is submitted from such an address, how do you communicate back to the submitter for status updates, etc.?
    • Such tickets are usually action items. An outside service emails information for one of our agents to input. It's for things that don't usually require a response, but it does require a ticket for tracking purposes. We use our Kace help desk for much more than just I.T. related issues.
      • Would it be possible to create a separate ticket queue for them to submit tickets to, which had the email notification turned off? Tickets could, if needed, be moved to your current queue either manually or by a rule. You may still need to watch which other events the queue sends notifications for.
  • Unfortunately no, but I thought we could put a rule in place that limits the number of tickets any user can submit in a specific period of time. Say no more than three every 10 minutes.
  • Back in 5.5.x we had the same issue and ended up disabling the "we got your ticket" message. Today, thanks to our customer satisfaction survey, the number one compliant is "did you get my ticket, I didn't get a auto reply." Now that we are finally on 6.4.x we plan to reserect our custom ticket rule and enable it for emails only.
Please log in to comment


When we had this problem we ran through a few solutions before settling on a fix that is outside the kbox itself. We worked with some of our network staff to create a spam filter rule to stop "bad" email addresses from responding to KACE alerts. Here are some other solutions we explored, maybe these will help:
There are two support articles with instructions for creating custom ticket rules (CTR) to avoid loops, these will need to be tweaked for your specific environment
I also created my own CTR with a sloppy fix. It appended "_donotemail" to the end of email addresses which sent a bunch of emails in a short amount of time.
Like I said, the final solution ended up being outside KACE entirely, but I hope this helps.
Answered 02/12/2016 by: JasonEgg
Second Degree Green Belt

Please log in to comment
Answer this question or Comment on this question for clarity