K1000: for some reason both in osx and windows, "SHELL_LOG.txt" never gets created.  Apparently it needs to be uploaded to the kbox to signal the result of an online shell script.  Here's part of the debug logs in windows.  Could it depend on the share file permissions?  I changed the name of the server url.

[2015-12-23.12:09:05][pluginRunProcess:UploadUsingCurl] UploadFile:  uploading file C:\ProgramData\Dell\KACE\user\SHELL_LOG.txt to https://kbox/service/kbot_upload.php?checksum=2f3458f932d2f86a8ae199c5cb657d18988d322b01138e33fefab372fb705e5ae849040b74262a5a82789c2629aea3627c1df95093853390a900209249f794c6
[2015-12-23.12:09:05][pluginRunProcess:UploadUsingCurl] UploadFile(https://kbox/service/kbot_upload.php?checksum=2f3458f932d2f86a8ae199c5cb657d18988d322b01138e33fefab372fb705e5ae849040b74262a5a82789c2629aea3627c1df95093853390a900209249f794c6, C:\ProgramData\Dell\KACE\user\SHELL_LOG.txt) unable to read source file: No such file or directory (2)
[2015-12-23.12:09:05][pluginRunProcess:LogDebug       ] Error uploading C:\ProgramData\Dell\KACE\user\\SHELL_LOG.txt: 99

In procmon, it just says "name not found" when it tries to create SHELL_LOG.txt:

3:06:16.8923422 PM AMPAgent.exe 4700 CreateFile C:\ProgramData\Dell\KACE\user\SHELL_LOG.txt NAME NOT FOUND Desired Access: Read Attributes, Delete, Disposition: Open, Options: Non-Directory File, Open Reparse Point, Attributes: n/a, ShareMode: Read, Write, Delete, AllocationSize: n/a

0 Comments   [ + ] Show Comments

Comments

Please log in to comment

There are no answers at this time

Answers

Answer this question or Comment on this question for clarity